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Where to Find the Latest Information

Documentation is updated periodically. For the latest information about this product, including instrument 
software upgrades, application information, and product information, browse to the following URL:

https://www.keysight.com/us/en/product/M9484C/m9484c.html

Information on preventing instrument damage can be found at:

http://keysight.com/find/PreventingInstrumentRepair

Is your product software up-to-date?

Periodically, Keysight releases software updates to fix known defects and incorporate product enhancements. 
To search for software updates for your product, go to the Keysight Technical Support website at:

http://www.keysight.com/find/techsupport

http://www.keysight.com/find/PreventingInstrumentRepair
http://keysight.com/find/PreventingInstrumentRepair
http://keysight.com/find/PreventingInstrumentRepair
http://www.keysight.com/find/techsupport
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1 M9484C VXG Basic Measurements

— “Overview” on page 10

— “Equipment Setup” on page 11

— “Required Software” on page 12

— “Setting Up Triggers on the X-Series Signal Analyzer” on page 13

— “Basic Measurements” on page 14

— “Generating a Continuous Waveform (CW)” on page 14

— “Generating Amplitude Modulation” on page 19

— “Generating Frequency Modulation” on page 24

— “Generating Phase Modulation” on page 28

— “Generating Synchronized Pulse (IQ + Analog) Modulation” on 
page 33

— “Generating a Multitone Signal” on page 37

— “Setting Up Waveform File Vector Modulation” on page 42
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M9484C VXG Basic Measurements
Overview

Overview
The M9484C VXG Vector Signal Generator provides frequency coverage from 
9 kHz to 54 GHz, with up to 2.5 GHz RF modulation bandwidth per channel 
using an internal baseband generator, and up to 5 GHz RF modulation 
bandwidth with channel bonding. 

The measurement examples use an X-Series Signal Analyzer to view the 
results. A few measurement examples require an N9042B signal analyzer and is 
called out in those specific measurement examples. For information on using 
the X-Series Signal Analyzer multi-touch user interface, refer to the Online 
Help.

Please refer to the VXG data sheet and X-Series Signal Analyzer data sheet to 
ensure your measurement setup has adequate power. 

https://www.keysight.com/us/en/product/M9484C/m9484c.html

The software versions used in this measurement guide are:

— VXG: A.12.02

— X-Series Spectrum Analyzers/N9085EM0E: A.34.xx or later

— 89601 VSA: Version 2023 or later
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M9484C VXG Basic Measurements
Equipment Setup

Equipment Setup

— M9484C front panel RF 1 Out to X-Series Signal Analyzer front panel RF In

— M9484C front panel Event 2 to X-Series Signal Analyzer rear panel Trig 1 In

Trig 3 In is used for an N9040B with Option H1G (1 GHz Bandwidth). For 
N9040B with Bandwidth 510 MHz or less, use Trig 1 In.

— M9484C rear panel 10 MHz Ref Out to X-Series Signal Analyzer rear panel 
Ext Ref In
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M9484C VXG Basic Measurements
Required Software

Required Software

— M9484C

— N7631APPC - 5GNR

— N7608APPC - Custom Modulation

— N7605APOC - 3GPP Real Time/Fading

— PathWave Automatic Channel Response Correction and S-parameter 
De-embedding (N7653APPC)
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M9484C VXG Basic Measurements
Setting Up Triggers on the X-Series Signal Analyzer

Setting Up Triggers on the X-Series Signal Analyzer

1. From the X-Series Signal Analyzer Menu Panel (on the top right of the 
display), select Mode/Meas > Spectrum Analyzer mode. 

2. Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. From the dropdown on the top right, select Trigger and set Trigger Source 
to Free Run. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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M9484C VXG Basic Measurements
Basic Measurements

Basic Measurements

Generating a Continuous Waveform (CW)

This procedure will demonstrate the amplitude and frequency accuracy of the 
VXG at RF and µW frequencies.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. In the Output area, set Frequency to 1 GHz and Power to 0 dBm.

These values are coupled to CW Frequency and Total Power (RMS) in the 
corresponding RF Output Block.

3. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

4. For multi-channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. From the Menu Panel, select Frequency and set Center Frequency to 
1 GHz and Span to 1 MHz.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series 
Signal Analyzer” on page 13.

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.
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M9484C VXG Basic Measurements
Basic Measurements

3. Select Peak Search.

Observe the accuracy of the amplitude and frequency of the signal.

On the VXG:

1. Set Output 1 Power to –90 dBm.

2. Ensure that RF Out is On.

On the X-Series Signal Analyzer: 

1. Select Amplitude and set Ref Level to –70 dBm and Scale/Div 5 dB.

2. Select BW and set Video BW to 300 Hz.

3. Select Peak Search. 



16                                                                                   M9484C VXG and X-Series SA Measurement Guide

M9484C VXG Basic Measurements
Basic Measurements

Observe the frequency and amplitude accuracy of the VXG at low power 
levels.

On the VXG:

1. Set Frequency to 44 GHz and Power to 0 dBm.

On the X-Series Signal Analyzer:

1. Select Frequency and set Center Frequency to 44 GHz.

2. Select Amplitude and set Ref Level to 0 dBm and Scale/Div to 
10 dB. 

3. Select BW > Video BW and set to Auto.

4. Select Peak Search.
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M9484C VXG Basic Measurements
Basic Measurements

Observe the frequency and amplitude accuracy at high frequency levels.
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M9484C VXG Basic Measurements
Basic Measurements

Using the equivalent SCPI commands

Creating a CW signal on Channel 1.

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 1GHZ

RF1:POWer:AMPLitude 0dBm

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

FREQuency:CENTer 1GHZ

FREQuency:SPAN 1MHZ

CALCulate:MARKer1:MAXimum

On the VXG:

RF1:FREQuency:CW 1GHZ

RF1:POWer:AMPLitude -90dBm

RF1:OUTPut:STATe ON

On the X-Series Signal Analyzer:

DISPlay:WINDow1:TRACe:Y:RLEVel -70

DISPlay:WINDow1:TRACe:Y:PDIVision 5

BWIDth:VIDeo 300Hz

CALCulate:MARKer1:MAXimum

On the VXG:

RF1:FREQuency:CW 44GHZ

RF1:POWer:AMPLitude 0dBm

On the X-Series Signal Analyzer:

FREQuency:CENTer 44GHZ

DISPlay:WINDow1:TRACe:Y:RLEVel 0

DISPlay:WINDow1:TRACe:Y:PDIVision 10

BANDwidth:VIDeo:AUTO ON

CALCulate:MARKer1:MAXimum
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M9484C VXG Basic Measurements
Basic Measurements

Generating Amplitude Modulation 

Follow the steps below for AM analog modulation using the internal or an 
external I/Q modulation source.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Signal block.

4. Select the arrow for Signal 1 to open the Signal Setup window.

The VXG must have the N7642APPC PathWave Signal Generation for IQ 
Based AM, FM, Phase license installed.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series 
Signal Analyzer” on page 13.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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M9484C VXG Basic Measurements
Basic Measurements

5. In the Mode dropdown, select Analog Modulation and then select the 
Analog Modulation tab in the left pane.

6. In the Analog Modulation Signal Setup:

a. Set Modulation Type to AM.

b. Set Waveform to Sine.

c. Set Rate to 100 kHz.

d. Set Depth to 50%.
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M9484C VXG Basic Measurements
Basic Measurements

7. Select the General tab > Enable.

Selecting Enable automatically turns on both Output Modulation and 
Internal I/Q Modulation as displayed in the Output Modulation block.

8. Close the Vector Modulation Signal Setup by selecting the Home icon at 
the top of the display.

9. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to 
500 kHz.
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M9484C VXG Basic Measurements
Basic Measurements

3. Select BW and set Res BW to 100 Hz.

4. Select Peak Search.

5. Use markers to measure sideband power relative to the center frequency 
by selecting Marker Delta. Select Next Pk Right until the second marker is 
at the next highest peak. 

The Delta Marker should be approximately –12 dB for 50% AM. 
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M9484C VXG Basic Measurements
Basic Measurements

Using the equivalent SCPI commands

On The VXG:

SYSTem:PRESet

RF1:FREQuency:CW 20GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal:MODE AMODulation

SIGNal1:AMODulation:TYPE AM

SIGNal1:AM:SHAPe SINE

SIGNal1:AM:FREQuency 100KHZ

SIGNal1:AM 50

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

FREQuency:CENTer 20GHZ

FREQuency:SPAN 500KHZ

BANDwidth 100 Hz

CALCulate:MARKer1:MODE DELTa

CALCulate:MARKer1:MAXimum:RIGHt

Repeat the above command until the marker is at the next highest peak.

To retrieve the delta marker:

CALCulate:MARKer1:Y?
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M9484C VXG Basic Measurements
Basic Measurements

Generating Frequency Modulation

Follow the steps below for FM analog modulation using the internal or an 
external I/Q modulation source.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Signal block.

4. Select the arrow for Signal 1 to open the Signal Setup window.

The VXG must have the N7642APPC PathWave Signal Generation for IQ 
Based AM, FM, Phase license installed.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series 
Signal Analyzer” on page 13.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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M9484C VXG Basic Measurements
Basic Measurements

5. In the Mode dropdown, select Analog Modulation and then the Analog 
Modulation tab.

a. Set Modulation Type to FM.

b. Set Waveform to Sine.

c. Set Rate to 400 Hz.

d. Set Deviation to 10 MHz.

6. Select the General tab > Enable.
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7. Close the Vector Modulation Signal Setup by selecting the Home icon at 
the top of the display.

8. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to 
50 MHz.

3. Select BW and set Res BW to 240 Hz.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 20GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal:MODE AMODulation

SIGNal1:AMODulation:TYPE FM

SIGNal1:FM:SHAPe SINE

SIGNal1:FM:FREQuency 400HZ

SIGNal1:FM 10MHZ

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

FREQuency:CENTer 20GHZ

FREQuency:SPAN 50MHZ

ACPower:BANDwidth 240 Hz
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Generating Phase Modulation

Follow the steps below for PM analog modulation using the internal or an 
external I/Q modulation source.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Signal block to open.

4. Select the arrow for Signal 1 to open the Signal Setup window.

The VXG must have the N7642APPC PathWave Signal Generation for IQ 
Based AM, FM, Phase license installed. The X-Series Analyzer must have 
N9063EM0E Analog Demodulation Measurement license installed.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series 
Signal Analyzer” on page 13.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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5. In the Mode dropdown, select Analog Modulation and then the Analog 
Modulation tab.

6. In the Analog Modulation Signal Setup:

a. Set Modulation Type to PM.

b. Set Waveform to Sine.

c. Set Rate to 10 kHz.
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d. Set Deviation to 1 rad.

7. Select the General tab > Enable.

8. Close the Vector Modulation Signal Setup by selecting the Home icon at 
the top of the display.

9. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.
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On the X-Series Signal Analyzer:

1. From the Menu Panel (on the top right of the display), select Mode/Meas > 
Analog Demod mode.

2. Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. From the Menu Panel (on the top right of the display), select Mode/Meas > 
Analog Demod mode > PM Measurement > Quad View.

4. Select Frequency and set Center Frequency to 20 GHz.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 20GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal:MODE AMODulation

SIGNal1:AMODulation:TYPE PM

SIGNal1:PM:SHAPe SINE

SIGNal1:PM:FREQuency 10KHZ

SIGNal1:PM 1

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

INSTrument:CONFigure:ADEMOD:PM

SYSTem:PRESet

DISPlay:VIEW:ADVanced:SELect "QUAD"

FREQuency:CENTer 20GHZ
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Generating Synchronized Pulse (IQ + Analog) Modulation

You will need to create your own ASCII text marker file and a binary file with 
the exact same name. Both files must be stored in the same file folder. For this 
example, we will use example files that have been stored on the VXG.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set the Frequency to 1 GHz and Power to 0.0 dBm.

3. Select the Signal block to open.

4. Select the arrow for Signal 1 to open the Signal Setup window.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series 
Signal Analyzer” on page 13.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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5.  Select the Mode dropdown and select Waveform File.

6. Select the Waveform File tab (left pane), and then in the Waveform Setup 
area, use File Select to navigate to:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
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4000_SampleQPulseOnOff_50%_wfm.csv

then Select.

7.  Set the Sample Rate to 2 kHz.

8. Select the General tab > Enable.

9. Close the Vector Modulation Signal Setup by selecting the Home icon at 
the top of the display.

10. Set RF Out to On by selecting the numbered channel indicator switch. 
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This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. From the Menu Panel (on the top right of the display), select Mode/Meas > 
Spectrum Analyzer mode > Swept SA Measurement > Normal View.

2. Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. Select Frequency and set Center Frequency to 1.0 GHz and Span to 0 Hz.

4. Select BW and set the Video BW to 300 Hz.

5. Select Sweep and set the Sweep Time to 4.0 s.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 



 M9484C VXG and X-Series SA Measurement Guide                                                                                        37  

M9484C VXG Basic Measurements
Basic Measurements

Generating a Multitone Signal

This example shows you how to create a multitone signal, which allows you to 
separate the usable frequency band into multiple channels. This can make a 
signal that is difficult to characterize in the time domain more readable.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 20 GHz and Amplitude to -10 dBm.

3. Select the Signal block to open.

4. Select the arrow for Signal 1 to open the Signal Setup window.

The VXG must have the N7621APPC PathWave Signal Generation for 
Multitone license installed.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series 
Signal Analyzer” on page 13.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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5. Select the Mode dropdown and select Mutitone.

6. Select the Multitone tab and set: 

a. Set Vector Modulation Signal Mode to Multitone.

b. Set Tones to 15.

c. Set Tone Spacing to 500 kHz.
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7. Select the General tab > Enable.

8. Close the Vector Modulation Signal Setup by selecting the Home icon at 
the top of the display.

9. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to 
10 MHz.

3. Select BW and set Res BW to 300 Hz.

Observe the 15 tones.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 20GHZ

RF1:POWer:AMPLitude -10dBm

SIGNal1:MODE MTONes

SIGNal1:MTONe:ARB:NTON 15

SIGNal1:MTONe:ARB:FSP 500KHZ

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:
Change to Spectrum Analyzer mode, Swept SA measurement.

INSTrument:CONFigure:SA:SAN

DISPlay:VIEW:ADVanced:SELect “NORMAL”

FREQuency:CENTer 20GHZ

FREQuency:SPAN 10MHZ
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Setting Up Waveform File Vector Modulation

In this section, we will load a GSM and a LTE waveform into the VXG to 
demonstrate the accuracy of the VXG’s vector modulation using error vector 
magnitude (EVM) measurement applications available on the X-Series Signal 
Analyzer.

The VXG supports all ARB waveforms that are provided on the X-Series 
sources. This section will use a few of the ARB files that come with the X-Series 
sources.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Group 1: Signals block to open.

4. Select the arrow for Signal 1 to open the Signal Setup window.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series 
Signal Analyzer” on page 13.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples
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d. Highlight GSM_1C_BURST_SECUREWAVE.wfm, then Select. 

e. Select the General tab > Enable.

6. Close the Vector Modulation Signal Setup by selecting the Home icon at 
the top of the display.

7. Set RF Out to On by selecting the numbered channel indicator switch. 
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This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to 
900 kHz.

3. Select BW and set Res BW to 470 Hz.

4. Select Trace and set Trace Type to Max Hold.

5. Observe the GSM signal. 

On the VXG:

1. Select the Group 1: Signals block to open.
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2. Select the arrow for Signal 1 to open the Signal Setup window.

3. Select the Mode drop down menu and select Waveform File and then 
select the Waveform File tab on the left side.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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4. Use File Select to navigate to: 
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

5. Set the file extension to All Files (*.*), highlight 
WDCMA_TM1_64DPCH_4C.wfm, then Select. 
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6. Select the General tab > Enable.

7. Ensure that RF Out is on.

On the X-Series Signal Analyzer:

1. Select BW and set Res BW to 620 Hz.

2. Select Frequency and set Span to 30 MHz.

3. Observe the WCDMA signal.



 M9484C VXG and X-Series SA Measurement Guide                                                                                        49  

M9484C VXG Basic Measurements
Basic Measurements

Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 20GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal1:MODE WAVeform

SIGN1:WAV " D:\Users\Instrument\Documents\Demo 
Waveforms\GSM_1C_Burst.wfm"

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

FREQuency:CENTer 20GHZ

FREQuency:SPAN 900KHZ

ACPower:BANDwidth 470 Hz

DISPlay:TXPower:WINDow1:TRACe:MAXHold ON

On the VXG:

SIGN1:WAV " D:\Users\Instrument\Documents\Demo 
Waveforms\WDCMA_TM1_64DPCH_4C.wfm"

SIGNal1 ON

RF1:OUTPut:STATe ON

On the X-Series Signal Analyzer:

ACPower:BANDwidth 620 Hz

FREQuency:SPAN 30MHZ
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2 Corrections

— “Corrections/De-embedding Using PathWave N7653APPC Software” on 
page 52

— “Using a Spectrum Analyzer to Make the Corrections Measurement” 
on page 58

— “Using a Power Meter to Make the Corrections Measurement” on 
page 65

— “Adding Fixture Blocks using s2p Files” on page 52

— “Instrument Nonlinear Correction” on page 71

— “Setting Up an INC 1CC 4 GHz, 10 dBm EVM Measurement” on 
page 71

— “Setting Up an INC 8CC 28 GHz, 10 dBm EVM Measurement” on 
page 82
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Corrections/De-embedding Using PathWave N7653APPC Software
De-embedding is used to remove the effects of the test fixtures and cabling 
from the measurement results. De-embedding uses a model of the test fixture 
and mathematically removes the fixture characteristics (cables, connectors 
and other passive components) between the source and the device under test 
(DUT). Once the desired topology has been characterized, its effects can be 
removed from the output signal, moving the effective reference plane to the 
point at which the power sensor was connected. 

Blocks can be added from supported file formats (.s2p, .csv, .uflat) or by direct 
measurement, using one of the supported power sensors (power meter, 
spectrum analyzer, or a network analyzer). 

Adding Fixture Blocks using s2p Files

Amplitude and phase can be corrected by adding multiple s2p files as Fixture 
Blocks. 

An s2p file (also known as a Touchstone file) is an ASCII text file used for 
documenting the n-port network parameter data and noise data of linear 
active devices, passive filters, passive devices, or interconnect networks. Each 
record contains 1 stimulus value and 4 S-parameters (total of 9 values)

The first line in the figure below (# GHz DB R 50) designates:

— (GHz) designates the frequency in Hz, kHz, MHz, or GHz

— (S) the measurements are in S parameters (rather than Y or Z)

— (DB) the values are given in decibel/angle. Instead of DB, you can have RI 
(real/imaginary) or MA (magnitude/angle)

— (50) the characteristic impedance is 50 ohms

1. Create s2p files in Notepad in the format shown above.

The VXG must have the N7653APPC PathWave Automatic Channel 
Response Correction and S-parameter De-embedding license installed.

If there is not a first line header, the default format is GHz, S-parameters, 
and magnitude/angle.
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TIP An s2p example file is included on the VXG. Go to 

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\simpleAt10GHzInDB.s2p

2. Select Preset > Preset to set the instrument to a known state.

3. In the VXG Output area, set the Frequency to 10 GHz and Power to 
–10 dBm. 

4. Select the Group 1: Signals block to open.

5. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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6. Select the Mode dropdown and select Multitone.

7. From the left pane, select Multitone and set:

— Vector Modulation Signal Mode to Multitone

— Tones to 21

— Tone Spacing to 100 MHz
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8. Select the General tab > Enable.

9. Close the Signal block by selecting the Home icon, and then select RF Out 
to turn on.

10. On the X-Series Signal Analyzer spectrum analyzer in Spectrum Analyzer 
Mode:

— Select Mode Preset to set Spectrum Analyzer mode to a known 
state.

— Set the Center to 10 GHz

— Set Span to 3 GHz
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11. On the VXG, select the RF Output block > Corrections/De-embedding.

12. In the Corrections Setup dialog, select Add from File.

13. Navigate and select the s2p file and then Select. 
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\simpleAt10GHzInDB.s2p

Notice that Block B is added in the Correction Setup diagram.
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14. Turn Corrections On. 

View the results on the signal analyzer. Observe how the .s2p file has 
impacted the signal.
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15. Add a third block using the same file name as shown in the steps above. 
Under Block C Properties, set to Embed.

View the results on the X-Series spectrum analyzer. Notice that the 
corrections are no longer shown. This is because the de-embedded 
corrections applied in Block B cancel the embedded corrections applied in 
Block C.

Using a Spectrum Analyzer to Make the Corrections Measurement

When using a spectrum analyzer, it must be locked to the VXG Frequency 
Reference. This is important because the power measurement can be 
inaccurate due to a narrow resolution bandwidth (RBW) used in the spectrum 
analyzer. Supported Keysight X-Series signal analyzers are:

— N9000A/B CXA
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— N9010A/B EXA

— N9020A/B MXA

— N9030A/B PXA

— N9040B and N9041B UXA

On the VXG:

1. Connect the VXG 10 MHz Out to the N90x0A/B Ext Reference In. 

2. Connect cable or DUT between the VXG RF Out and the signal analyzer 
RF in.

3. Select Preset > Preset to set the instrument to a known state.

4. Set the Frequency to 12 GHz and Amplitude to –10 dBm.

5. Select the Signal block to open. 

6. Select the arrow for Signal 1 to open the Signal Setup window.

7. Select the Mode dropdown and select Multitone.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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8. Select the Multitone tab from the left pane and then, configure the signal 
to have 501 Tones with 4 MHz Tone Spacing, then select the General tab 
> Enable.

9. Select the Home icon and set RF Out to On by selecting the numbered 
channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.
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On the Signal Analyzer:

1. From the Menu Panel (on the top right of the display), select Mode/Meas > 
Spectrum Analyzer mode > Occupied BW Measurement > OBW Results 
View.

2. Set the Center Frequency to 12 GHz and the Span to 3 GHz.

Observe how the fixturing is impacting this signal, including the flatness 
and the total power.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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On the VXG:

1. Select the RF Output block > Corrections/De-embedding tab to open the 
Correction Setup.

2. Select Block A to highlight > Add from Measurement to open the Measure 
Corrections Block Wizard.

3. Connect the power sensor (in this case, the X-Series signal analyzer) as 
shown in the diagram below. After reading the overview, select Next to 
move to the Configure Sensor setup.

4. In the Configure Sensor setup, select the Power Measurement Device 
dropdown and select Spectrum Analyzer.
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5. Set the Start and Stop Freq, Amplitude, and the Num Steps. For this 
example Start Freq 11 GHz, Stop Freq 13 GHz, Amplitude to the highest 
power used in your measurement (For this example, -10 dBm, which we 
already set in the main window. If you change the value here, it will update 
the value in the main measurement window.) and Number of Steps to 101.

6. Set Connection Type to LAN, enter the LAN Address and set the Protocol 
parameters to HiSLIP, and then select Test Connection. 

7. Once you are successfully connected, select Next to move to the Measure 
Corrections step.

8. Select Measure Correction Data. 
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During the measurement, the VXG outputs a CW between the Start and 
Stop Frequencies for the specified number of steps and output power. It 
will take some time to measure all 101 points, and the progress is 
indicated by the blue bar. You can watch the signal analyzer as it steps 
through this process.

The measurement results are saved to a csv file using an automatically 
generated file name. 

9. When the measurement is complete, select Finish, then select Corrections 
On.

The output csv file is set to Block A.
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Block A is dedicated for User Correction. The image below shows how 
blocks are assigned in the User Correction and Fixture block.

10. On the signal analyzer, Restart (on the left corner of the user interface) 
the measurement (because it is applying averaging). Observe how the 
measured corrections impacted the signal. You can easily toggle 
Corrections on and off on the VXG to see the difference. 

Using a Power Meter to Make the Corrections Measurement

The following USB power sensors can be used for the power measurement.

— U8487A-CFG007

— U8485A-CFG006

— U2000A

— U2001A

— U2002A

— U2004A

— U2000B

— U2001B

— U2000H

— U2001H

— U2002H
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On the VXG:

1. Connect the VXG 10 MHz Out to the N90x0A/B Ext Reference In.

2. Select the RF Output block > Corrections/De-embedding block to open 
the Correction Setup.

3. Select the A Block (to highlight) then Add from Measurement to open the 
Measure Corrections Block Wizard. 

4. Connect the power sensor as shown in the diagram below then select 
Next.

5. Select Next to go to Configure Sensor dialog and select the Power 
Measurement Device dropdown > Power Meter.

6. Set the Start and Stop Freq, Amplitude, and the Num Steps. For this 
example Start Freq 26 GHz, Stop Freq 30 GHz, Amplitude to the highest 
power used in your measurement 5 dBm, and Num Steps to 20.
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7. Select the Connection Type to USB, and then specify the Device and VISA 
Address. 

8. Select Test Connection to verify connectivity, and then select OK then 
Next to continue.

You can also calibrate and zero out the power sensor before measuring 
corrections.

9.  Select Next to go to the Measure Corrections dialog and select Measure 
Correction Data. 

During the measurement, the VXG outputs a CW between the Start and 
Stop Frequencies for the specified number of steps and output power. The 
measurement results are saved to a csv file using an automatically 
generated file name. 

10. Select Finish. The output csv file is set to Block A.



68                                                                                   M9484C VXG and X-Series SA Measurement Guide

Corrections
Corrections/De-embedding Using PathWave N7653APPC Software

Block A is dedicated for User Correction. The image below shows how 
blocks are assigned in the User Correction and Fixture block.

11. Select Corrections On to apply.
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Using the equivalent SCPI commands

Using a spectrum analyzer to make the corrections measurement

On the VXG:

SYSTem:PRESet

Set the power level to the highest level used in your measurement.

RF1:POWer:AMPLitude 5dBm

CORRection:PMDevice SANalyzer

CORRection:FLATness:STEP:STARt 26GHZ

CORRection:FLATness:STEP:STOP 30GHZ

CORRection:FLATness:STEP:POINts 20

CORRection:SANalyzer:COMMunicate:TYPE SOCKets

Set the LAN address and protocol parameters for your spectrum analyzer.

CORRection:SANalyzer:COMMunicate:LAN:IP "192.168.1.5"

CORRection:SANalyzer:COMMunicate:LAN:PORT 5025

CORRection:FLATness:CALibrate

CORRection ON

Using a power meter to make the corrections measurement.

On the VXG:

SYSTem:PRESet

RF1:POWer:AMPLitude 5dBm

CORRection:PMDevice PMETer

CORRection:FLATness:STEP:STARt 26GHZ

CORRection:FLATness:STEP:STOP 30GHZ

CORRection:FLATness:STEP:POINts 20

CORRection:SANalyzer:COMMunicate:TYPE USB

CORRection:PMETer:COMMunicate:USB:DEVice “instr0”

[Optional] CORRection:PMETer:CALibrate 

[Optional] CORRection:PMETer:ZERO 

CORRection:FLATness:CALibrate

Use query CORRection:PMETer:COMMunicate:USB:LIST? for a list of all 
connected USB devices. 
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CORRection ON

Adding fixture blocks using s2P files

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 10GHZ

RF1:POWer:AMPLitude -20dBm

SIGNal1:MODE MTONe

SIGNal1:MTONe:ARB:NTON 21

SIGNal1:MTONe:ARB:FSP 100MHZ

SIGNal1 ON

RF1:OUTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

SYSTem:PRESet

FREQuency:CENTer 10GHZ

FREQuency:SPAN 3GHZ

On the VXG:

Set the path to the s2p data as block 2 (you can use 1 through 4).

CORRection:BLOCk2:FILE "FixtureChannel2"

CORRection:BLOCk2 ON

Add block C with the same file.

CORRection:BLOCk3:FILE "FixtureChannel2"

Change Block C to Embed.

CORRection:BLOCk3:APPLy EMBedding

CORRection:BLOCk3 ON
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Instrument Nonlinear Correction
Instrument Nonlinear Correction (INC) is a digital pre-distortion (DPD) based 
correction using a Keysight signal analyzer (N9042B, N9040B, or N9030B) to 
compensate for nonlinearities in the VXG. INC is useful in reducing EVM (and 
other metrics impacted distortion) at high power levels and extending the 
range of the power with linear output of the VXG. INC is a point correction valid 
for a given frequency/power/waveform combination and can be used for EVM 
and ACP measurements at high power levels (>5 dB). The VXG must have the 
N7653APPC PathWave automatic channel response correction and 
S-parameter de-embedding license installed.

Instrument nonlinear corrections compensate for nonlinearities in the VXG. 
Improvement to EVM will only be seen at power levels where distortion is the 
limiting factor. INC will not improve EVM in the area where signal to noise ratio 
(SNR) is the limiting factor.

Setting Up an INC 1CC 4 GHz, 10 dBm EVM Measurement

On the VXG:

In order to compare before and after correction results, we will start by making 
an EVM measurement without applying corrections.

1. Select Preset > Preset to set the instrument to a know state.

2. In the Output area, set Frequency to 4 GHz and Power to 
10 dBm.
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3. Select the Signal block to open the Vector Modulation Signal Setup panel.

4. Select the arrow for Signal 1 to open the Signal Setup window.

5. Set Mode to Waveform File, then select the Waveform File tab in the left 
pane.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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6. In the Waveform Playback Setup area, use File Select to navigate to:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
5G_100MHz_1CC_FR1.wfm

then Select.

7. Select the General tab > Enable. 

8. Select the Home icon and set RF Out to On. 



74                                                                                   M9484C VXG and X-Series SA Measurement Guide

Corrections
Instrument Nonlinear Correction

On the UXA:

1. From the X-Series Signal Analyzer Menu Panel (on the top right of the 
display), select Mode/Meas > 5G NR & V2X Mode > OK. 

2. Select Mode Preset to set Spectrum Analyzer 5G NR & V2X mode to a 
known state.

3. From the X-Series Signal Analyzer Menu Panel (on the top right of the 
display), select Mode/Meas > 5GNR & V2X Mode > Modulation Analysis 
Measurement > OK. 

4. Select Recall (If accessing the X-Series Signal Analyzer remotely, select 
the Folder icon at the bottom of the display) Demod Info > Data Type set 
to CC Setup > Recall From > 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or 
the PC running the VSA application.
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Signal Studio_5G_100 MHz_1CC_FR1.scp 

Recall

5. The Signal Stuidio_5G_100 MHz_1CC_FR1.scp file automatically sets the 
Carrier Frequency to 4 GHz. 

6. From the Main menu, select Meas Setup > Advanced tab > Advanced 
Demod Setup and set DC Punctured to On, then Close the Advanced 
Demod Setup window.

7. In the Meas Setup window, select the Settings tab > Optimize EVM.

Record the results. For this example EVM is 0.32% and EVM Peak is 1.79%
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To Measure ACP: 

a. Select Mode/Meas > 5GNR & V2X Mode > ACP > OK. 

b. Select Amplitude > Signal Path tab > and set µW Path Control to 
Low Noise Path Enable (if Option LNP is available on your analyzer).

Record the results for the Lower and Upper ACP results. For this 
example -50.9 dBc (lower) and -50.9(upper).

c. Select Mode/Meas > 5GNR & V2X > Modulation Analysis > OK. 
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On the VXG:

1. Open the Signal block and select the Waveform File tab > Configure to 
open the Nonlinear Correction Setup. 

2. In the Instrument Nonlinear Correction area, select Measure Correction to 
open the Instrument Nonlinear Calibration screen.

3. Under the Receiver tab (opened by default), enter your connection 
information and test the connection. For this example, select LAN as the 
Connection Type > Enter the IP address for you signal analyzer (for this 
example, 141.121.149.32) as the Hostname > Test Connection. 



 M9484C VXG and X-Series SA Measurement Guide                                                                                        79  

Corrections
Instrument Nonlinear Correction

The Connection status will be displayed in the Notifications area at the 
bottom of the main window.

4. Select the Calibrations tab and select EVM and ACP for the Calibration 
types, then Start Calibration.
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The calibration will take a few minutes to complete. Once done, the INC 
file will be created and it will automatically be used in place of the .wfm 
file originally loaded. An "I" will be displayed in the Signal block indicating 
this status.

On the UXA:

1. Select Optimize EVM.

Note the changes to EVM RMS and EVM Peak values. For this example 
EVM RMS is 0.24% (before 0.32%) and EVM Peak is 1.47% (before 1.79%).

To Measure ACP:

a. Select Mode/Meas > 5GNR & V2X Mode > ACP > OK. 

b. Select Amplitude > Signal Path tab > and set µW Path Control to 
Low Noise Path Enable.
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Note the changes to the Lower and Upper ACP values. For this 
example Lower -58.67 dBc (before -50.9 dBc) and Upper 
-57.85 dBc (before -50.9).
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Setting Up an INC 8CC 28 GHz, 10 dBm EVM Measurement

On the VXG:

In order to compare before and after correction results, we will start by making 
an EVM measurement without applying corrections.

1. Select Preset > Preset to set the instrument to a know state.

2. In the Output area, set Frequency to 28 GHz and Power to 
10 dBm.

3. Select the Group 1: Signals block to open.

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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5. Set Mode to Waveform File and then select the Waveform File tab in the 
left pane.

6. In the Waveform Playback Setup area, use File Select to navigate to:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

5G_100MHz_8cc_FR2.wfm

then Select.

7. Select the General tab > Enable.

8. Select the Home icon and set RF Out to On. 

On the UXA:

1. From the X-Series Signal Analyzer Menu Panel (on the top right of the 
display), select Mode/Meas > 5GNR & V2X Mode > OK. 

2. Select Mode Preset to set Spectrum Analyzer 5GNR mode to a known 
state.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 



84                                                                                   M9484C VXG and X-Series SA Measurement Guide

Corrections
Instrument Nonlinear Correction

3. From the X-Series Signal Analyzer Menu Panel (on the top right of the 
display), select Mode/Meas > 5GNR & V2X Mode > Modulation Analysis 
Measurement > OK. 

4. Select Recall (If accessing the X-Series Signal Analyzer remotely, select 
the Folder icon at the bottom of the display) Demod Info > Set Data Type 
to CC Setup > Recall From > 

5G_100 MHz_8CC_FR2.scp 

Recall

5. The .scp file automatically sets the Carrier Frequency to 28 GHz. 

6. Select Meas Setup > Advanced tab > Advanced Demod Setup and set DC 
Punctured to On, then Close the Advanced Demod Setup window.

7. Select the Sweep > Single Sweep.

8. Select Meas Setup > Settings tab > Optimize EVM. 

It will take a few minutes for the UXA to measure all 8 carriers.

Record the results. 

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or 
the PC running the VSA application.
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For this example CC0 EVM RMS is 6.21%, EVM Peak is 27.33% and for CC7 
EVM RMS is 4.51% and EVM Peak is 15.75%

To Measure ACP:

a. Select Mode/Meas > 5GNR & V2X Mode > ACP > OK. 

b. Select Amplitude > Signal Path tab > and set µW Path Control to 
LNP (Low Noise Path) Enable (if your analyzer has Option LNP).

c. Select Sweep > Restart to take a new sweep.
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Note the values of the Lower and Upper ACP. For this example 
Lower, at 100 MHz offset is -26.7 dBc and Upper 
-27.06 dBc.

d. Select Mode/Meas > 5GNR & V2X > Modulation Analysis > OK. 

On the VXG:

1. In the Signal block, select Waveform File Mode > Waveform File tab > 
Configure to open the Nonlinear Correction Setup. 

2. In the Instrument Nonlinear Correction area, select Measure Correction to 
open the Instrument Nonlinear Calibration screen.

3. Under the Receiver tab (opened by default), enter your connection 
information and test the connection. For this example, select LAN as the 
Connection Type > Enter the IP address for you signal analyzer (for this 
example, 141.121.149.32) as the Hostname > Test Connection. 
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The Connection status will be displayed in the Notifications area at the 
bottom of the main window.

4. Select the Calibrations tab and select EVM and ACP for the Calibrations, 
then Start Calibration.

On the UXA:

1. Select the Sweep > Restart.

2. Select Optimize EVM.

Note the changes to EVM RMS and EVM Peak values.
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For this example CC0 EVM RMS went from 6.21% to 3.13%, EVM Peak 
went from 27.33% to 11.68% and for CC7 EVM RMS went from 4.51% to 
2.87% and EVM Peak went from 15.75% to 10.55%.

To Measure ACP:

a. Select Mode/Meas > 5GNR & V2X Mode > ACP > OK. 

b. Select Amplitude > Signal Path tab > and set µW Path Control to 
LNP (Low Noise Path) Enable.

c. Select Sweep > Restart to take a new sweep.
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Note the changes to the Lower and Upper ACP values. For this 
example Lower, at 100 MHz offset is -32.27 (before -26.7 dBc) and 
Upper -31.15 (before -27.06 dBc).
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3 Advanced Measurements

— “Channel Bonding” on page 92

— “Generating a Multi-Carrier DVB-S2X Signal for Satellite TV” on 
page 93

— “Generating a Wide Band QPSK” on page 107

— “Generating a 5G NR Waveform” on page 116

— “Setting Up 8 Virtual Signal Generators” on page 126

— “Using the VSA Flex Frame to Create a DVB-S2X Signal” on page 136

— “Creating & Analyzing a 5G NR DL 2x2 MIMO Measurement Using Two 
UXAs” on page 174

— “Creating and Analyzing a 4x4 MIMO using a UXR Running VSA Software” 
on page 196
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Channel Bonding

Data requirements are pushing bandwidths and modulation complexity across 
many global industries.

— Global data consumption is growing

— IoT drives new data consumption

— Autonomous vehicles require data links

— Satellite networks need to provide 5G backbone in 5G Non-Terrestrial 
Networks (NTN)

— New applications generate new sources of data intelligence

The following three examples are showing

— “Generating a Multi-Carrier DVB-S2X Signal for Satellite TV” on page 93

— “Generating a Wide Band QPSK” on page 107

— “Generating a 5G NR Waveform” on page 116

For this measurement example, we are using the following equipment: 

— M9484C with options 

— Two channels (M9484C-001 and 002)

— RF bandwidth of 2.5 GHz per channel (M9484C-R25)

— Channel bonding, 5 GHz (M9484C-CB5 and M9484C-PCH)

— PathWave Signal Generation for Custom Modulation (N7608APPC)

— PathWave Automatic Channel Response Correction and S-parameter 
De-embedding (N7653APPC)

— Accessories

— Channel Bonding Combiner kit (Y1166A or Y1167A, frequency 
dependent)

— N9042B UXA

— Analysis bandwidth of 4 GHz (N9042B-R40)

— 89600 PathWave Vector Signal Analysis software, VSA
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Figure 3-1 Channel Bonding Setup

Generating a Multi-Carrier DVB-S2X Signal for Satellite TV

DVB-S2X is a digital satellite television broadcast standard. Channel bonding 
can be used for UHDTV services where statistical multiplexing is used to allow 
many television channels can use the same bandwidth. Other applications 
include Direct to Home (DTH), Digital Satellite News Gathering (DSNG) and 
professional VSAT.

On the VXG:

1. Connect the equipment as shown above.

2. Select Preset > Preset to set the VXG to a known state.
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If a Synchronization Alignment is required, indicated by  in the 
bottom left corner, tap or click the warning message and choose Perform 
Alignment before proceeding.

3. Select the System menu (triple bar icon at the top left of the window), and 
then select Configure Channels > 2 Channel Bonded > Add (for 4 channel 
instruments only) > Apply > Apply.

4. Set the Center Frequency to 12 GHz and Power to 0 dBm.
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5. Select the Apps block to open, then select Custom Modulation.

6. In the Custom Modulation setup, select the Carrier tab > Quick Setups > 
DVB-S2X > 32APSK > 4+8+4+16APSK 140/180.

7. From the bottom pane, select Remove Segment to remove the Header. 
This will simplify the demonstration.

8. From the left pane, select Custom ASK & PSK & QAM Settings and set the 
Symbol Rate to 500 Msps per channel.
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9. Select Filter > Alpha to 0.2. 

10. Select the Waveform tab > Basic > Oversampling Ratio to 7 x multiplier 
which provides a span of 3.5 GHz. 

Each channel is 2.56 GHz for a combined sample rate of 5.12 GHz. This 
could be set by entering 5.12 GHz as the User Defined Sample Rate 
however; for Multi-carrier it is best to set the Oversampling Ratio. 

11. From the left pane, select Multi Carrier and select Multicarrier Enabled.

12. Open the Frequency Offsets setup screen. For Carrier Index 0, set the 
Frequency Offset to -1200 MHz, then select Add Rows.
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13. Enter the 1st Frequency Offset of -600 MHz, # of Carriers 4, and Carrier 
Spacing 600 MHz. Select Add.

All five carriers will be setup. Select OK to close the Frequency Offsets 
dialog.
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14. Generate the waveform and select the Spectrum tab from the bottom 
pane to ensure the resulting waveform is correct.

15. Select the Home icon to return to the main window and then select the 
Signal Block to open.

16. In the Signal Setup dialog box, notice that new custom modulation file is 
already selected (CustomMod_G1S1.wfm). Set the Occupied Bandwidth 
to 3 GHz.
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17. Select Configure Channel Bonding and configure the Hostname or IP 
address for the UXA, then Test Connection. Ensure that you have 
successfully connected to the UXA, a message will be displayed in the 
Status area at the bottom of the display.

18. Select the Calibrations tab and clear the ACP calibration.

In some cases it is not possible (or necessary) to improve the ACP of the 
bonded waveform. In these cases, it is best to disable it.

— If the ACP cannot be improved, in some cases, the highest fidelity 
bonded waveform will result from Bonding with ACP disabled.

— ACP increases the time it takes to perform Bonding, and if the 
receiver does not have sufficient analysis bandwidth to cover the 
ACP regions + modulated bandwidth of the waveform, then 
frequency-stitching will be performed and this will further increase 
the Bonding time.

— With ACP enabled, the resulting signal will typically have 
significantly increased bandwidth, sample rate, and number of 
samples (as compared to a Bonded signal with ACP disabled).



100                                                                                   M9484C VXG and X-Series SA Measurement Guide

Advanced Measurements
Channel Bonding

— Note that the available ACP region bandwidth is limited by the 
bandwidth of the source, so if the available source 
bonded-bandwidth is 5 GHz, and the bonded waveform is 5 GHz, 
then there is no available BW for performing an ACP calibration.

19. Select the Advanced tab and set Compaction Off, then Start Calibration. 

When the waveform length is short enough, compaction is not needed. 
However, for 5G signals (which tend to be relatively long and have a lot of 
IQ samples), the calibration time can be long (without compaction). So for 
signals with lots of IQ samples, the suggestion is to use compaction as this 
will reduce the calibration time. The calibration takes a few minutes to 
complete. However, the highest fidelity bonded waveform may result 
without compaction. How much compaction to use can be optimized 
(none, automatic, or a specified compaction level) by experimenting with 
the different settings.

The calibration takes a few minutes to complete. 
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Notice that the CustomMod_G1S1.bnd waveform is now playing.

On the Signal Analyzer:

1.  Select Frequency > Auto Tune to observe the spectrum.

2. Open the VSA software by selecting Mode Meas > Launch VSA.

Ensure that signal analyzer is set to Spectrum Analyzer mode > Swept SA 
Measurement > View Normal.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top left of the display) to open the 
Mode/Measurement/View Selector window. 
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3. In the Spectrum window, select Center frequency and set to 12 GHz, then 
select Auto-range.
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4. From the menu bars, select MeasSetup > Measurement Type: Vector > 
General Purpose > Custom IQ.

5. Select MeasSetup > Custom IQ Demod Properties.

a. In the Format tab, select Constellation Edit. 

b. Select Preset to Standard Constellation > DVB S2X APSK > 32APSK 
(4+8+4+16) > 32APSK 7/9. This is equivalent to the 4+8+4+16APSK 
140/180 setting we chose in the Custom Modulation setup. 



104                                                                                   M9484C VXG and X-Series SA Measurement Guide

Advanced Measurements
Channel Bonding

c. Select OK to close the Constellation Edit dialog.

d. Turn off Pulse Search Enable (checkbox cleared).

e. Set the Result Length to 2000 Symbols.

f. Set the Symbol Rate to 500 MHz. The Result Length and Symbol 
Rate will adjust the resolution bandwidth to better define the 
waveform.
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g. Select the Filter tab and set Alpha/BT to 0.2, Filter Length to 33, 
and Equalizer Type to Minimize EVM. Close the Custom IQ Demod 
Properties window and notice the center carrier is now being 
demodulated.

6. In the CustomIQMeas Time window, click on I-Q and change to 
Constellation, if desired.

7. Change the window layout to Grid 2x2. 
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8. Note the measured EVM value in the CustomIQSyms/Errs window. For this 
example, 1.2%rms.
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Generating a Wide Band QPSK

On the VXG:

1. Connect the equipment as shown in Figure 3-1 on page 93.

2. Select Preset > Preset to set the VXG to a known state.

3. Select the System menu (triple bar tab at the top left of the window), and 
then select Configure Channels > Group 1:2 Channel Bonded > Add (for 4 
channel instruments only) > Apply.

4. Set the Center Frequency to 12 GHz and Power to 0 dBm.

5. Select the Apps block to open, then select Custom Modulation.
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6. In the Custom Modulation setup, select the Carrier tab > Quick Setups > 
DVB-S2 > QPSK.

7. From the bottom pane, select Remove Segment to remove the Header. 
This will simplify the demonstration.

8. From the left pane, select Custom ASK & PSK & QAM Settings and set the 
Symbol Rate to 3 Gsps per channel.

9. Select Filter > Alpha to 0.2. 

10. Select the Waveform tab > Basic > Select User Defined Sample Rate and 
set Sample Rate to 5.12 GSa/s. 

Each channel is 2.56 GHz for a combined sample rate of 5.12 GHz. 
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11. Generate the waveform and select the Spectrum tab from the bottom 
pane.

12. Select the Home icon to return to the main window and then select the 
Signal Block to open.

13. In the Signal Setup dialog box, notice that new custom modulation file is 
already selected (CustomMod_G1S1.wfm). 

14. Set the Occupied Bandwidth to 3.6 GHz (or 1.2 x 3 GHz) and the Sample 
Rate to 5.12 GHz Samples per second.

15. Select Configure Channel Bonding and configure the Hostname or IP 
address for the UXA, then Test Connection. Ensure that you have 
successfully connected to the UXA.
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16. Select the Calibrations tab and clear the ACP calibration.

17. Select Start Calibration.

The calibration takes a few minutes to complete. Note that the VXG 
displays an Invalid file selection message. This is because the VXG 
no longer sees the .wfm waveform instead the newly calibrated waveform 
has a .bnd file extension.

Notice that the CustomMod_G1S1.bnd waveform is now playing.
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On the Signal Analyzer:

1. Select Frequency > Auto Tune to observe the spectrum.

2. Open the VSA software by selecting Mode Meas > Launch VSA. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top left of the display) to open the 
Mode/Measurement/View Selector window. 
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3. In the Spectrum window, set the Center Frequency to 12 GHz and 
Auto-range.

4. From the menu bar, select MeasSetup > Measurement Type > General 
Purpose > Custom IQ.

5. From the menu bar, select MeasSetup > Custom IQ Demod Properties.

a. Select the Format tab and select Constellation Edit. 

b. Select Preset to Standard Constellation > PSK > QPSK. 

c. Select OK to close the Constellation Edit dialog.
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d. Turn off Pulse Search Enable (checkbox cleared).

e. Set the Symbol Rate to 3 GHz.

f. Select the Filter tab and set Alpha/BT to 0.2, Filter Length to 33, 
Equalizer Type to Minimize Error Vector, and Reset the Filter.
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6. View the results. 

7. In the menu bar, select the Trace Layout icon and select the Grid 2 x 2 
format.

This allows you to view more measurement details like the EVM results, 
which for this example is ~1.6 %rms. 
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Generating a 5G NR Waveform

On the VXG:

1. Connect the equipment as shown in Figure 3-1 on page 93.

2. Select Preset > Preset to set the VXG to a known state.

If a Synchronization Alignment is required, indicated by  in the 
bottom left corner, tap or click the warning message and choose Perform 
Alignment before proceeding.
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3. Select the System menu (triple bar tab at the top left of the window), and 
then select Configure Channels > Group 1:2 Channel Bonded > Add (for 4 
channel instruments only) > Apply > Apply.

4. Set the Center Frequency to 12 GHz and Power to 0 dBm.

5. Select the Apps block to open, then select 5G NR.

6. Select the Carrier tab.
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7. Select Full-Filled Config and set Bandwidth to FR2 400 MHz, and then 
select OK.

Full Filled Configurations is a great place to start creating your waveform. 
You can select FR, bandwidth, and modulation format with a fully 
allocated PDSCH data channel. This would represent a spectrally correct 
signal that is typically used in power amplifier measurements. You can 
modify the RB allocations and Slot allocations if fully allocated data 
channels are not desired.

8. Select DL Test Model to open. set Bandwidth to FR2 400 MHz and set 
Phase Compensation to Off, and then select OK.
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9. Select the Waveform Tab, and set the Time Scale Factor to 10.

10. Generate the waveform and select the Spectrum tab from the bottom 
pane. The waveform will take a moment to finish generating.
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11. Select the folder icon in the right corner of the display, and select Export 
Signal Setup (*.scp) file. In the File Name field, create a name for the 
setup file, then select Enter. Note the location where you saved this file as 
you will need to copy it to the UXA.

12. Select Export 89600 VSA Setup. In the File Name field, create a name for 
the setup file, then select Enter. Note the location where you saved this 
file as you will need to copy it to the UXA.

To copy the two setup files to the UXA:

a. Select the System menu icon (triple bar), then Switch to Windows. 

b. Select the Windows icon (bottom left corner), open File Explorer 
and navigate to the setup files and Copy both files. 

c. On the UXA, select the Windows icon, open File Explorer and Save 
the two setup files.

d. On the VXG, select the PathWave SG icon in the Desktop to restore 
the PathWave application.

13. Select the Home icon to return to the main window and then select the 
Signal Block to open.

14. In the Signal Setup dialog box, notice that new custom modulation file is 
already selected (NR5G_G1S1.wfm). 

15. Select Configure Channel Bonding and configure the Hostname or IP 
address for the UXA, then Test Connection. Ensure that you have 
successfully connected to the UXA.
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16. Select the Calibrations tab and clear the ACP calibration, then select 
Start Calibration.

On the Signal Analyzer:

Below are two methods for viewing the results of the 5G NR wideband 
waveform. 

— Using X-Apps 5G NR & V2X Modulation mode Modulation Analysis 
measurement

— Using 89600 VSA
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Using X-Apps 5G NR & V2X 1 Mode

1. Select Frequency > Auto Tune to observe the channel bonded signal.

2. From the N9042B select Mode/Meas > 5G NR &V2X Mode > OK. 

3. Select Mode Preset to set Spectrum Analyzer 5G NR mode to a known 
state.

4. From the N9042B Menu Panel (or the Screen tab), select Mode/Meas > 5G 
NR & V2X Mode > Modulation Analysis Measurement > OK. 

5. Select Recall (If accessing the N9042B remotely, select the Folder icon at 
the bottom of the display) Demod Info > Data Type set to CC Setup > 
Recall From. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top left of the display) to open the 
Mode/Measurement/View Selector window. 
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6. Navigate to the .scp file you created in step 11 above and select Recall.

7. From the Menu Panel, select Meas Setup > Settings tab > Optimize EVM. 
For this example, the EVM RMS is ~1.9%.
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Using 89600 VSA

1. Open the VSA software by selecting Mode Meas > Launch VSA. 

2. In the Spectrum window, set the Center Frequency to 12 GHz and 
Auto-range.

3. From the menu bar, select File > Recall Setup > Recall and select the .setx 
file you copied over from the VXG.

4.  From the menu bar, select MeasSetup > 5G NR Demod Properties > Time 
tab and set Time Scale Factor to 10. Close the Demod Properties windows 
and observe the results.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top left of the display) to open the 
Mode/Measurement/View Selector window. 
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5. In the Spectrum window, set the Span to 4 GHz, then select the 
Auto-range icon at the top of the display.

In this example, the EVM is ~2%
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Setting Up 8 Virtual Signal Generators 

The M9484C Option 8SG provides eight virtual signal generators (multiple IQ 
paths to RF) allowing you to emulate up to 8 signals simultaneously with one 
channel. This feature is most beneficial in receiver design and test applications 
in which the current implementation often involves RF combining of multiple 
signal generators due to dynamic range limitations. 8SG can simplify device 
characterization where multi-carrier or multi-radio access technology signals 
are required.

For this example we will use the following equipment:

— M9484C VXG

— RF bandwidth of 2.5 GHz per channel (M9484C-R25)

— 8 Virtual Signal Generators (M9484C-8SG)

— N7631APPC PathWave Signal Generation for 5G NR measurement 
application

— X-Series Signal Analyzer

— N9085EMOE 5G NR Measurement application

The VXG must have Option M9484C-8SG (8 virtual signal generators) 
installed. 
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On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. In the Output area for Channel 1, set Frequency to 2 GHz and Power to 
-5 dBm.

3. Select the arrow for Signal 1 to open the Signal Setup window.

4. Select Group 1 Signal block to open.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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5. Select the Mode drop down menu and select Waveform File and then 
select the Waveform File tab on the left side.

6. In the Waveform Playback Setup area, use File Select to navigate to:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples 

and choose 
01_GSM_Framed_slots 1 3 5 off_EDGE Framed_slots 0 2 4 6 off_2MHz 
separation_WFM1.wfm

then Select.
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7. Set the Frequency Offset to the desired value. For this example –1.2 GHz. 

The Frequency Offset is the distance from the channel’s RF center 
frequency (set in step 2) to the center frequency of the signal. You can 
adjust the signal attenuation for each signal to allow scaling the signal 
down without disrupting the output. 

8. Select the General tab > Enable

9. From the Menu/Tool & Navigation bar, select Group 1: Signal Summary.

Notice the Remaining Sample Rate has decreased from 3.0 GHz to 
2.9956 GHz now that Signal 1 is consuming 4.333 MHz.

10. Repeat step step 5 through step 9 for Signal 2, Signal 3, and Signal 4 with 
the following changes. 

Whenever you enable a particular waveform file that is not currently 
enabled in another IQ path, it uploads prior to playback. If the file is 
already enabled in one or more other IQ paths, an upload does not occur 
and the waveform plays directly.

If you update the IQ data for a particular waveform file, you must first 
disable the IQ paths where the old version of the same file is being used so 
that it uploads, replacing the old data.



130                                                                                   M9484C VXG and X-Series SA Measurement Guide

Advanced Measurements
Setting Up 8 Virtual Signal Generators

— Signal 2

— Waveform: 
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\02_W-CDMA_TM1_1 DPCH.wfm

— Frequency Offset: –1.0 GHz

— Signal 3

— Waveform: 
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\03_LTE full 
filled_16QAM.wfm

— Frequency Offset: –900 MHz

— Signal 4

— Waveform: 
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\04_802.11ac_160 MHz0.wfm

— Frequency Offset: 1.0 GHz

11. Signals 5 -7 will be configured using the embedded PathWave Signal 
Generation for 5G NR (N7631APPC). Select the Radio Apps icon in the top 
left of the window, and then select 5G NR.

12. To create signal 5, select the Carrier tab > Full-filled Config and set 

— Bandwidth to FR1 100 MHz
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— Duplex Type to FDD

—  Modulation to 64QAM, then select OK

13. Select the Waveform tab and scroll down to turn Phase Compensation 
Off. This will allow the waveform to be offset in frequency without needing 
to be re-generated.
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14. From the left pane, select the Routing tab, set the signal number to 5, and 
then Generate.

15. To create signal 6, select the Carrier tab > Full-filled Config and set 
Bandwidth to FR2 200 MHz. 

16. Select the Waveform tab, then from the left pane, select the Routing tab, 
set the signal number to 6, and then Generate.

17. To create signal 7, select the Carrier tab > Full-filled Config and set 
Bandwidth to FR2 400 MHz. 

18. Select the Waveform tab, then from the left pane, select the Routing tab, 
set the signal number to 7, and then Generate.

19. Return to Group 1: Signal Summary by selecting the Home icon > Group1: 
Signals and set the Frequency Offset for each of the newly generated 5G 
NR signals as follows:

— Signal 5 to –700 MHz

— Signal 6 to –300 MHz

— Signal 7 to 300 MHz
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20. Select the arrow for Signal 8.

21. Select the Mode drop down and select AWGN. Select the AWGN tab and 
set Channel Bandwidth to 1.5 GHz. 

22. Select the General tab and set Frequency Offset to -200 MHz and Enable 
the AWGN signal.

23. Select the Home icon and set RF Out to On by selecting the numbered 
channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.
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24. For multi-channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

On the Signal Analyzer:

1. Select Mode/Meas > Spectrum Analyzer Mode > Swept SA Measurement.

2. Select Mode Preset to set the spectrum analyzer to a known state.

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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3. Adjust the center frequency and span to view all of the signals around the 
RF center frequency. For this example, set the Center Frequency to 2 GHz 
and Span to 2.5 GHz.

4. Adjust the Resolution Bandwidth and Video Bandwidth as needed. 

5. Now that 8 waveforms are playing, try some of the following experiments 
to see how different settings impact the signals.

— Toggle the Enable checkbox for various signals.

— Adjust the Frequency Offset of various signals. Note that signals can 
overlap.

— Set up a Channel Power measurement on the Signal Analyzer. 
Observe how changing different signal settings (relative power, 
attenuation, mute, enable, etc.) either impact or do not impact Total 
Channel Power.

— Use the Auto Configure Analyzer feature to demodulate one of the 
5G NR signals. Note, the center frequency will need to be manually 
adjusted on the Signal Analyzer to match the Frequency Offset of 
the signal set on the VXG.

— Change Trigger and/or Marker settings.
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 Using the VSA Flex Frame to Create a DVB-S2X Signal 
The Flex Frame extension (89601AYAC) for the 89600 VSA software provides a 
means of creating complex frames to demodulate and analyze advanced 
custom IQ signals.

A frame can contain a combination of flexible elements, or allocations. Each 
allocation can be a Preamble, Pilot, Data or an Idle period. Allocations have 
configurable payload PN sequence and modulation type.

As you build the flexible frame in the Frame Definition tab, an Allocation 
Summary panel displays the order of each assembled frame part and 
allocation, and shows how the total number of symbols are distributed across 
the frame.

There are two parts to this example.

The first example uses N7623C Signal Studio for Digital Video. The N7623C 
generates a fully coded, full-standard compliant DVB-S2X waveform. Then, we 
will use VSA Flex Frame to demod the signal. 

The second example uses PathWave N7608C Custom Modulation. Since the 
N7623C cannot provide an uncoded signal, we will use the N7608C to 
uncoded the signal to perform a Bit Error Rate (BER) measurement. 

For this example, we will use the following equipment:

— N7623C Signal Studio for Digital Video (Software release 2020 Update 1.0 
or higher

— N7608C Signal Studio for Custom Modulation (Software release 2021 or 
higher)

— 89600 VSA Digital Demodulation Analysis, Flex Frame Measurement 
(Software release VSA 2022 or higher)
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DVB-S2X PHY Layer Framing

256 APSK modulation is used in this demo guide. The coding rate is 
represented differently between Signal Studio for Digital Video (N7623C), 
Signal Studio for Custom modulation (N7608C), and VSA Flex Frame 
(89601AYAC). N7608C and 89601AYAC use “Implementation MODCOD” name 
and N7623C uses “Canonical MODCOD” name. 

In this example, we will use a coding rate of 32/45 in the N7623C which 
corresponds to 128/180 in the N7608C and VSA.

N7623C Signal Studio for Digital 
Modulation

N7608C Signal Studio for Custom 
Modulation

89601AYAC Flex Frame

256APSK 29/45 256APSK 116/180 256APSK 116/180

256APSK 2/3 256APSK 20/30 Not supported

256APSK 31/45 256APSK 124/180 256APSK 124/180

256APSK 32/45 256APSK 128/180 256APSK 128/180

256APSK 11/15 256APSK 22/30 Not supported

256APSK 3/4 256APSK 135/180 256APSK 135/180
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Part 1: Generating a DVB-S2X Waveform Using N7623C Signal 
Studio for Digital Modulation

Setting Up the Waveform in Signal Studio for Digital Video

1. From the main menu, select Format > DVB-S2/S2X.

2. From the left panel, select Quick Setups > Hardware > Instrument. 

DVB-S2 and DVB-S2X operate in Ku band (10-14 GHz) and Ka band 
(18-30 GHz). This example uses a sub-6GHz hardware thus using a center 
frequency of 4.5 GHz. Modify the frequency based on the hardware you are 
using.
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3. Set the Frequency to 4.5 GHz and the Amplitude to -10 dBm.

4. Under Waveform Setup, select Carrier and configure the DVB-S2/S2X 
signal to the following parameters.

— Roll of Factor to 0.25

— Symbol Rate to 20 MHz

— Support DVB-S2X to True

— Modulation Type to 256 APSK

— Code Rate to 32/45
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This is equivalent to MODCOD 256APSK 128/180 in the VSA.

5. In the Waveform Setup window, set the Oversampling Ratio to 2.

This results in a Waveform Length of 3147120. We will use this length 
when configuring the signal in VSA Flex Frame.
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6. From the Control menu, select Generate. 

7. Select Control menu > Download to download it to your Signal Generator.

Setting up and Analyzing the Signal Using VSA Flex Frame

1. From the VSA menu bar, select MeasSetup > Measurement Type > 
General Purpose > Flex Frame.

2. Set the correct frequency, span, and input range. For this example, set:

— Change the Trace Layout Grid to 2 x 3.

— Change Trace B to Ch1 Spectrum, and set Center Frequency to 
4.5 GHz

— Span to 40 MHz

Depending on the signal generator you are using, the steps for 
downloading the waveform may be different. If this is the case, go to File > 
Export Waveform Data and Save the file. Then load it onto the your signal 
generator.

Changing settings on the VSA can take longer to take affect than 
expected. Wait to change the next setting until the previous setting has 
been updated.
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— Autorange
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3. Select MeasSetup > Flex Frame Properties > Carrier Aggregation tab, then 
set CCO Absolute Center frequency to 4.5 GHz.

The Symbol Rate error will be resolved once the Symbol Rate gets 
adjusted in step 5.
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4. At the bottom right portion of the display, select Edit, then select the 
Assigned Carriers drop down and select CCO.

5. In the Flex Frame Properties window, select the Frame Definition tab and 
set:

— Frame Type to Periodic

— Symbol Rate to 20 MHz

— Length to 3147120 Symbols 

To match the waveform length in Signal Studio.
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For a bursted signal, Frame Type is set to Burst, and the frame 
length can be automatically set based on the detected burst length.

6. In the Component Carrier Configuration area, select the Modulation tab 
and set Preferred Bit to Symbol Mapping to Default.

When testing a DUT, if the bit mapping into constellation point is as 
defined by DVB-S2X, DVB-RCS2 or 802.11ad/ay standard, selecting the 
correct standard under "Bit To Symbol Mapping" is required for accurate 
Tx BER measurement. When using Signal Studio, leave it as Default.

Constellation mapping definition between VSA Flex Frame and N7608C 
Signal Studio is not aligned. VSA comes with a set of bit mappings (.txt 
file) to recall into the N7608C and this is required for successful 
demodulation. You can find it under: C:\Program Files\Keysight\ 
<version>\89600 VSA Software\Help\Signals\FlexFrame.

7. Set the Sequence Type to DVB-S2/S2X PLFRAME. 

This selects the scrambling method as described in section 5.5.4 of 
EN 302.301-1.
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8. Set both Sequence Index and Reset Symbol to 0.

Configure the Preamble (PLHEADER)

9. Select the Frame Configuration tab and configure the Start of Frame Index 
(SOF), 26 symbols long:

— In the Frame Parts area, select Alloc0.

— In the Configuration area, set

— Name to SOF

— Type to Preamble

— Sequence to Custom

— Modulation to DVB-S2/S2X π/2BPSK

— Enter the 26 symbols
01100011010010111010000010

(011 000 110 100 101 110 100 000 10)

— In the Location area, 

— Clear the End of Frame checkbox
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— Start Symbol to 0

— Total Length to 26

Note that Scrambling is not applied to Preamble.

Configure the PLS (PHY Layer Signaling) Code 64 symbols long

10. In the Frame Parts area:

— Select Add Allocation

11. In the Configuration area, set:

— Name to PLSCODE

— Type to Preamble

— Sequence to Unknown

— Modulation to DVB-S2/S2Xπ/2 BPSK

Notice that Scrambling is not applied to Preamble.

12. In the Location area, set:

— Clear the End of Frame checkbox

— Start Symbol to 26
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— Total Length to 64 Symbols

Configure the Payload

13. In the Frame Part area, select Add Allocation.

14. In the Configuration area:

— Name to Data

— Type to Data

— Sequence to Unknown

— Modulation to DVB-S2/S2X APSK

Notice that Scrambling is not applied to Preamble.

— MODCOD to 256APSK Normal 128/180

— Scrambling to Enabled
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15. In the Location area, set:

— Start Symbol to 90

— Last Symbol to End of Frame

— Select Repeat Pattern

— Set Active Symbols to 0:1439

Before the Pilot block, there are 16 payload slots, each 90 symbols 
long resulting in 1440 active symbols.

— Repeat every to 1476 Symbols

The 1440 payload symbols are followed by a 36-symbols Pilot block 
resulting in a total of 1476 symbols. This will repeat until the end of 
the frame length.

Configure the Pilot

16. In the Frame Part area, select Add Allocation. 

17. In the Configuration area:

— Name to Pilot

— Type to Pilot

— Sequence to Unknown

— Modulation to QPSK

Pilots are unmodulated, but they are identified by 

— Scrambling to Enabled
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18. In the Location area, set:

— Start Symbol to 90

— Last Symbol, select End of Frame

— Select Repeat Pattern

— Set Active Symbols to 1440:1475

Pilot is 36 symbols long following a 1440 symbols long payload.

— Repeat every to 1476 Symbols

The 1440 payload symbols are followed by a 36-symbols Pilot block 
resulting in a total of 1476 symbols. This will repeat until the end of 
the frame length.

Configure Synchronization and Equalization

19. Select the Measurement Control tab, and set:

— Synchronization Source to Auto

By default, SOF is used for synchronization. This can be changed to 
"Customized" to add additional frame parts for synchronization.

— Channel Estimation Source to Preamble and Pilots
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Equalization is off by default. You can choose the different frame 
parts for channel estimation and equalization.

Configure the Analysis Region

20. Select the Time tab, set the Result Length to 8000 Symbols.

Setting the result length to  the waveform length when oversampling 
ratio of 1, provides the best performance. In Signal Studio, when 
oversampling ratio is set to 1, the waveform length is 8370. Using a result 
length of  8370 symbols provides the best EVM performance.
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Configure the RRC filter

21. In the Filter tab, set Alpha/BT: to 0.25.

Save the Configuration as a Quick Setup

22. In the Carrier Aggregation tab, select Save As Quick Setup.

This saves the measurement settings for future use. Select Share with all 
users if you want to share with other users on the PC running the VSA 
software.
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23. Close the Properties window and change Trace A to a Constellation 
Diagram, then view the results.

You should see a successful demodulation with very low EVM. Multiple 
traces and tables are available including Error Vector Spectrum, Error 
Vector Time, demod, and BER Bits.

The FlexFrame Summary table is a type of Matrix Table that provides 
sortable rows by column, selectable column visibility, and copy/paste and 
export functionality to share rows of content or complete tables to 
applications like email, text editing or spreadsheet programs.

Right click the column header to display the menu.
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FlexFrame Summary always displays the EVM of each active segment. 
Flex Frame Syms/Errs table shows composite EVM of segment(s) selected 
under Measurement Control -> Include EVM. By default, it shows all 
segments.
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Part 2: Generating a DVB-S2X Waveform Using the N7608APPC 
Signal Studio for Custom Modulation

For this example, we will use the embedded N7608APPC application on the 
M9484C VXG. 

Setting Up the Waveform in PathWave Custom Modulation

1. On the VXG, select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 4.5 GHz and Power to 
-10 dBm.

3. Select the Radio Apps block to open the Vector Modulation Signal Setup 
panel.

4. Select Custom Modulation to enter Custom Modulation Signal Mode.

The VXG must have the N7608APPC Signal Generation for Custom 
Modulation license installed. You can also use N7608C Signal Studio for 
Custom Modulation
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5. In the Custom Modulation setup, select the Carrier tab > Quick Setups > 
DVB-S2X > 256APSK > 256APSK 128/180.

6. From the left pane, select Custom ASK & PSK & QAM Settings and set the 
Symbol Rate to 20 Msps per channel.

7. Select Filter > Alpha to 0.25. 

Filter length is 32 symbols, which we will set this value in the VSA.
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Configure the PLHEADER (Preamble)

In Part 1, the PLHEADER using π/2-BPSK modulation is split into two: SOF 
(Start of Frame) of 26 symbols and PLS (PHY Layer Signaling) of 64 symbols for 
a total of 90 symbols. The N7608C by default uses a single segment for 
PLHEADER with 90 symbols using QPSK modulation and provides a payload of 
180 symbols. For the purpose of this example, we will merge the two. You can 
split the PLHEADER into two by adding a segment and provide a payload of 
52 symbols for the SOF. Since N7608C doesn't support π/2-BPSK modulation, 
it uses QPSK so it would require a payload of 52 symbols for the SOF, instead 
of the 26-symbols used in Part 1.

Default constellation symbol mappings of VSA Flex Frame and N7608C/APPC do not 
match. VSA provides .txt files to load into the N7608C/APPC to match the mapping. 
These .txt files are in the VSA installer under:

C:\Program Files\Keysight\<version>\89600 VSA Software\Help\Signals\FlexFrame.

For the convenience of this demonstration, the QPSK text file has already 
been copied onto the VXG. 

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\QPSK_Default_for FlexFrame Example
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8. From the bottom pane, select the PLHEADER row > QPSK constellation to 
open the Constellation Edit window. 

9. In the Constellation Edit dialog, select Recall.

10. Navigate to the text file and choose Select. Select OK to Close the 
Constellation Edit dialog.
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11. In the PLHEADER row, under Payload, select 180 bits binary data [0001...] 
to open the Segment Payload Edit dialog. Select and copy the 180 
symbols. These will be pasted in to the VSA for synchronization. Select OK 
to close the dialog box.

12. To configure the Payload, from the DataSeq row, set the Number of 
Symbols to 1440. 

Use 16 payload slots (90 symbols/slot) for the radio frame. These are the 
slots prior to Pilot. Pilots are optional and not generated (See part 1 of this 
demo guide for a frame with pilot segment).

13. In the DataSeg row, under the Constellation area, select 
DVB-S2X256APSK 128/180 to open the Constellation editor, and then 
select Normalize.
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It is a good idea to normalize the power. Difference power levels between 
data and preamble can result in high EVM.

14. Close the Constellation editor and select Generate to generate the 
waveform. To view the Generated waveform, select the Waveform tab and 
select Spectrum.
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15. Select Home to exit the setup panel.

16. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

Setting up and Analyzing the Signal Using VSA Flex Frame

1. From the VSA menu bar, select MeasSetup > General Purpose > Flex 
Frame.

2. Set the correct frequency, span, and input range. For this example, set:

— Change the Trace Layout Grid to 2 x 3.

— Change Trace B to Ch1 Spectrum, and set Center Frequency to 
4.5 GHz

— Span to 40 MHz

Changing settings on the VSA can take longer to take affect than 
expected. Wait to change the next setting until the previous setting has 
been updated.
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— Autorange
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3. Select MeasSetup > Flex Frame Properties > Carrier Aggregation tab, then 
set CCO Absolute Center frequency to 4.5 GHz.
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4. At the bottom right portion of the display, select Edit, then select the 
Assigned Carriers drop down and select CCO.

5. In the Flex Frame Properties window, select the Frame Definition tab and 
set:

— Frame Type to Periodic

— Symbol Rate to 20 MHz

— Length to 1530 Symbols 

This is 90 symbols of PLHEADER plus 1430 symbols of data. 
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For a bursted signal, Frame Type is set to Burst, and the frame 
length can be automatically set based on the detected burst length.

Configure the Preamble (PLHEADER)

6. Configure the Start of Frame Index (Preamble), 90 symbols long:

— In the Frame Parts area, select Alloc0.

— In the Configuration area, set

— Name to PLHEADER

— Type to Preamble

— Sequence to Custom

— Modulation to QPSK

— Enter the 180 symbols you copied over from the Custom 
Modulation PLHEADER Payload setup in step 11.

— In the Location area, 

— Clear the End of Frame checkbox

— Start Symbol to 0
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— Total Length to 90

7. Configure the Payload 1440 symbols long:

— In the Frame Parts area:

— Select Add Allocation

8.  In the Configuration area, set:

— Name to Data

— Type to Data

— Sequence to PN15

— Modulation to DVB-S2/S2X APSK

— MODCOD to 256APSK Normal 128/180

— Select Include in BER Calculations

— Select Autodetect Bit Sequence Offset

9.  In the Location area, set:

— Start Symbol to 90
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— Last Symbol to End of Frame

TIP Include in BER Calculations: BER is supported if the allocation's payload 
sequence is either a PN type or a Custom bit sequence.

Autodetect Bit Sequence Offset: Supported when the segment(s) is not used 
for synchronization.
If not selected (unchecked), demodulator assumes the bit sequence starts at 
the beginning of the allocation.
If selected, demodulator finds the best match to the bit sequence.

Configure Synchronization and Equalization

10. Select the Measurement Control tab, and set:

— Synchronization Source to Auto

By default, PLHEADER is used for synchronization. This can be 
changed to "Customized" to also include the Data segment for 
synchronization. Calculated BER must be cleared (unchecked) from 
Data before selecting if for Synchronization.

— Channel Estimation Source to Preamble Only
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Equalization is off by default. You can choose the different frame 
parts for channel estimation and equalization.

Configure the Analysis Region

11. Select the Time tab, set the Result Length to 1530 Symbols.

90 for the preamble plus 1440 for the data.
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Configure the RRC filter

12. In the Filter tab, set Alpha/BT: to 0.25 and Length to 32 Symbols.

Save the Configuration as a Quick Setup

13. In the Carrier Aggregation tab, select Save As Quick Setup.

This saves the measurement settings for future use. Select Share with all 
users if you want to share with other users on the PC running the VSA 
software.
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14. Close the Properties window and change Trace A to a Constellation 
Diagram, then view the results.

You should see a successful demodulation with very low EVM. Multiple 
traces and tables are available including Error Vector Spectrum, Error 
Vector Time, demod, and BER Bits.
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The FlexFrame Summary table always displays EVM of each active 
segment. However, "Flex Frame Syms/Errs" Table shows composite EVM 
of segment(s) selected under Measurement Control -> Include EVM. By 
default, it is all segments.

TxBER/RawBER is returned for the Data segment. NOTE: BER is supported 
if the allocation's payload sequence is either a PN type or a Custom bit 
sequence. Reference and measured bits are returned.

— BER is expressed as a ratio and calculated as Bit Errors/Bit Count. 

— Turn On averaging to accumulate bit count. 

— Recording with 0% overlap gives gap free BER data (limited by 
memory).
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FlexFrame Summary always displays the EVM of each active segment. 
Flex Frame Syms/Errs table shows composite EVM of segment(s) selected 
under Measurement Control -> Include EVM. By default, it shows all 
segments.
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FlexFrame Summary table is a type of Matrix Table that provides sortable 
rows by column, selectable column visibility, and copy/paste and export 
functionality to share rows of content or complete tables to applications 
like email, text editing or spreadsheet programs. Right click the column 
header to display the menu.
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Creating & Analyzing a 5G NR DL 2x2 MIMO Measurement Using 
Two UXAs

We will create a 5G NR MIMO signal using a VXG with PathWave Signal 
Generation, and then analyze it with using both the X-Series 5G NR 
measurement application and the 89600 VSA software. 

The hardware setup includes a 2-channel VXG and two N9042B UXAs.

M9484C VXG N9042B UXA

Required Options

— RF bandwidth of 160 MHz or above

— Two-channel configuration

Required Options

— UXA 1
N9042MMOB Multi-box Synchronization for 
MIMO, Analysis Bandwidth of 160 MHz or 
above

— UXA 2 
Analysis Bandwidth of 160 MHz or above

Required Software

— M9484C Firmware version A.11.01 or higher

— 7631APPC PathWave Signal Generation for 5G NR

Recommended Software

— N9042B UXA Firmware version 2023 (XA34) 
or higher

— N9085EMOE 5G NR Measurement application

— 89600 VSA
89601200C for VSA Base Core
89601BHNC for VSA 5G NR
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On the VXG

1. Connect the equipment as shown above.

2. Select Preset > Preset to set the VXG to a known state.

3. Select the System menu (triple bar icon at the top left of the window), and 
then select Configure Channels > Nx2 <MIMO > Add > Apply > Apply.

4. Set the Frequency to 20 GHz and Power to 0 dBm.

5. Select the Apps block to open, then select 5G NR.
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6. Select the Waveform tab and set the Total Number of Antennas 2. This 
means that two antenna port signals will be generated.

7. Select the Carriers tab > Cell Specific node, and set Bandwidth to FR2 
100 MHz. Keep the rest of the default settings. 

8. Select the Downlink node > SS/PBCH > RB Offset by 60 kHz SCS and set 
to 0.
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This automatically changes the Delta Frequency to Carrier Center to 
-33.12 MHz. Using 0 RB Offset puts the SSB at the lower edge of the 
carrier. 

9. Select the Downlink node > DL-SCH> Transmission Settings and confirm 
DMRS ports is set to 0,1. Set Number of DMRS CDM groups without data 
to 2.

Number of DMRS CDM groups without data is used to determine how 
many resource elements are reserved for DMRS. When this parameter is 
changed, the DMRS power boosting is automatically coupled based on 
table 4.1-1 of 38.214.

You will see the layer number is updated to 2 and each layer is assigned 
with a particular DMRS port. You'll also see that Antenna Ports Generated 
is automatically set to P0,P1, which will map the multiple antenna port 
signals to different antennas (instruments). 

10. Select the Resource Allocation node and set:

— Allocated Slots to 2:79

— RB Offset to 20

— RB Number to 20
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DL-SCH0 will occupy the RBs 20-40 and DL-SCH1 will occupy the rest of 
the resources.

11. Select the Modulation and Coding node and set:

— MCS to 20

— MCS Table to 5.1.3.1-2 (256 QAM)

Notice that modulation is updated to 256 QAM. 

12. Select the DMRS Settings node and set DMRS Power Boosting to 3 dB.
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When CDM Group Number is 2, DMRS power boosting becomes 3 dB per 
3GPP.

13. Under the DL-SCH 0 node, select the + icon to add a new +DL-SCH 
(DL-SCH1).
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14. From the Channels node, select DL-SCH > DL-SCH1 > Transmission 
Settings and set DMRS port(s) to 0,1. Change the Number of DMRS CDM 
groups without data to 2.

This will create a conflict between DL-SCH0 and DL-SCH1. This will be 
resolved in a later step.
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Notice that Number of Layers is updated to 2 and each layer is assigned 
with a particular DMRS port. Antenna Ports Generated is automatically 
assigned P0,P1, which will map generated multiple antenna port signals 
to different antennas (instruments). 

15. Select the Resource Allocation node and set:

— Allocated Slots to 2:79

— RB Offset to 45

— RB Number to 18

Notice that this resolves the conflict between DL-SCH channels. (The pink 
shading is removed from the Channel Allocation graph. To clear the 
conflict error message at the bottom of the display, select the Message 
icon (bottom, right corner) and select Clear.
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16. Select the Modulation and Coding node, and set MCS to 20. 

Use the default MCS Table to Table 5.1.3.1-1 (64QAM). You will see the 
modulation is updated to 64QAM.

17. Select the Waveform tab > Select Generate. 

View the waveform by selecting Spectrum on the bottom display.

18. Select the File icon on the top right and select Export Signal Setup (*.scp), 
and save the file. 
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You will need to copy this setup file to the UXA to speed up demodulation 
on the UXA using X-Apps.

19. Select the Carrier tab and select Export 89600 VSA Setup and save the 
file.

You will need to copy this setup file to the UXA to speed up demodulation 
on the UXA using the 89600 VSA software.
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20. Select the Home icon and set RF Out to On by selecting the numbered 
channel indicator switches, and then select RF Out (All) master control 
switch to turn the RF output On for both channels or off for both channels.

21. Select the Signal block to open.

22. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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23. Select the Trigger tab and set Trigger Source to Global Trigger.

Demodulate the 5G NR 2x2 MIMO in X-Apps

On the Primary UXA:

1. From the N9042B select Mode/Meas > 5G NR &V2X Mode > OK. 

2. Select Mode Preset to set Spectrum Analyzer 5G NR mode to a known 
state.

3. From the N9042B Menu Panel (or the Screen tab), select Mode/Meas > 5G 
NR & V2X Mode > Modulation Analysis Measurement > OK. 

Changing settings on the VSA can take longer to take affect than 
expected. Wait to change the next setting until the previous setting has 
been updated.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top left of the display) to open the 
Mode/Measurement/View Selector window. 
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4. From the Menu Panel, select Meas Setup > Radio and turn MIMO On. 

5. Select Multi Channel Config to open the Configuration dialog box.

— Set Channel 1 IP Address to Local

— Enter the IP address for Channel 2 

— Select Locked for both Channel 1 and Channel 2
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Once MIMO mode is ON and both channels are locked, the 
secondary N9042B display changes as shown below. 

6. Select Recall (If accessing the signal analyzer remotely, select the Folder 
icon at the bottom of the display) > Demod Info > set Data Type to CC 
Setup > Recall From > and Recall the setup file.

You must be in the correct analysis mode to recall the .scp file. 

7. Select Trigger > Trigger tab and set Select Trigger Source to External 1 
and Trigger Level to 1 V.

8. Select Meas Setup > Settings tab> Optimize EVM.
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Optimize EVM is an immediate action to adjust the hardware settings to 
minimize EVM. 

— Normal method will capture input signal, measure its peak power 
then the algorithm will find proper setting combination for 
attenuation, preamp and IF Gain.

— Iterative method will capture input signal multiple times in a 
iteration process, demodulate the signal and calculate EVM for each 
iteration and find setting combination for attenuation, preamp and 
IF Gain with minimum EVM. 

For 5G NR signals, this method is much slower, than normal, but 
with achieve better EVM results. You can also manually adjust IF 
Gain, Frequency Extender Attenuation (use when measurement 
setup includes a V3050A frequency extender).
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View the results.

Demodulate the 5G NR 2x2 MIMO Using VSA:

1. Open the VSA software by selecting Mode Meas > Launch VSA. 

2. To configure the hardware, go to Utilities > Hardware > Configurations.

3. Open the Discovered Instruments tab and verify that the two UXAs are 
listed, if not, select the Rediscover Instruments icon.

If accessing the instrument via a Remote Desktop connection, select the Screen tab (at the top 
left of the display) to open the Mode/Measurement/View Selector window. 
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4. In the Configuration tab, select the + icon.

5. Scroll down the Possible Logical Instruments and select Keysight/Agilent 
X-Series Signal Analyzer twice. 

a. Select the first Keysight/Agilent X-Series Signal Analyzer and then 
press the right arrow to move it under the Configuration area. 

b. From the middle of the dialog box, select the down arrow next to the 
Analyzer and select the IP address of the Primary UXA. 

c. Repeat the two steps above for the second signal analyzer but 
select the IP address of the Secondary UXA.

6. Select OK to create the new configuration.
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7. In the Configurations tab, set the Current Analyzer Configuration, select 
the Analyzer number for the new configuration. In this example Analyzer 3.

8.  From the menu bar, select Input > Channels > RF > 2 Channel.



192                                                                                   M9484C VXG and X-Series SA Measurement Guide

Advanced Measurements
Creating & Analyzing a 5G NR DL 2x2 MIMO Measurement Using Two UXAs

9.  From the menu bar, select File > Recall > Recall Setup and navigate to the 
.setx file you save during the VXG waveform generation.

You can also set the frequency and span of both channels under Meas 
Setup > Frequency.

If you are using a UXR, Select Autorange . 

Auto Range samples the current input signal and then sets the full scale 
input range to the minimum range that includes the peak voltage sample 
of the input signal.

10. From the menu bar, select Input > Trigger and set:

— Style to External
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— Level to 1 V

11. From the menu bar, select MeasSetup > 5G NR Demod Properties> 
Advanced tab and select the DC Punctured check box. 

As part of conformance test, 3GPP has defined different equalizer training 
and tracking for EVM measurements. 3GPP Conformance Test is enabled 
by default where Tracking, Equalizer Training and EVM Window, and 
Symbol Timing is applied per 3GPP conformance test requirement. For 
FR1, no tracking is applied. For FR2, Phase Tracking using PTRS is applied.
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5G NR counts the DC subcarrier as a valid subcarrier for rate-matching 
purposes. The network decides if the DC subcarrier is modulated or not. 
High LO feedthrough will impact demodulation and EVM performance of 
the input signal. This is OFF by default.

12. Close the 5G NR Properties dialog.

13. From the toolbar, select the Auto-Range dropdown and select EVM-Table 
or Algorithm Based.

— EVM - Table or Algorithm Based performs EVM optimization based 
on prescribed table/algorithm instead of using EVM in the feedback 
loop. This method of EVM auto-range is normally faster than Meas 
Based Iteration, but may not achieve the most optimal setup for 
minimized EVM).

— EVM - Meas Based Iteration has a feedback loop around the entire 
measurement, uses the measured EVM in the feedback loop, and 
tries to adjust hardware parameters to minimize the EVM. It is the 
slowest EVM auto-range method, but it should achieve the most 
optimal setup for good EVM.
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Creating and Analyzing a 4x4 MIMO using a UXR Running VSA 
Software

Equipment Setup

— M9484C 

— Four channels (M9484C-004)

— N7631APPC PathWave Signal Generation for 5G NR

— UXR0334 

— UXR000-602: DDC option with 2 GHz BW

— 89600 PathWave Vector Signal Analysis (VSA)

On the VXG:

1. Connect the equipment as shown above.

2. Select Preset > Preset to set the VXG to a known state.
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If a Synchronization Alignment is required, indicated by  in the 
bottom left corner, tap or click the warning message and choose Perform 
Alignment before proceeding.

3. In the Output area for all four channels, set the Frequency to 5 GHz and 
Power to –10 dBm.
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4.  Select the Apps block to open, then select 5G NR.

5. Select the Carrier tab > DL Test Model and set the Test Model to 
NR-FR1-TM3.1. Leave other settings as default and select OK.

6.  Select the Waveform tab and set the Total Number of Antennas to 4. This 
indicates that two antenna port signals will be generated. 
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7.  Select Generate to apply the signals to each channel. The expected 
spectrum can be observed in the bottom window.

8.  To simplify analysis, select Export 89600 VSA Setup and save the file.
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9.  Select the Home icon to return to the main block diagram, and then 
select the gray 1, 2, 3, and 4 to turn on each channel. 

On the UXR

1. Open the VSA software. 

To access the VSA software, go to the Windows Start menu and find 
Keysight 89600 Software (latest installed version) folder and run the 
software.

2. From the VSA menu bar, select File > Preset > All to set the VSA to a 
known state.

3. To configure the hardware, go to Utilities > Hardware > Configurations.

If it is already configured, go to step 10.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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4. Open the Discovered Instruments tab and verify that the UXR is listed, if 
not, select the Rediscover Instruments icon.

5. In the Configuration tab, select the + icon.
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6. Scroll down the Possible Logical Instruments and select Keysight/Agilent 
Infiniium Series Oscilloscope, and then select the right arrow to move it 
under Configuration. 

7. From the middle of the dialog box, select the UXR to be used.

8. Select OK to create the UXR configuration.
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9. In the Configurations tab, set the Current Analyzer Configuration by 
selecting the Analyzer number for the new configuration. In this example 
Analyzer 3.

10. From the menu bar, select Input > Channels > Baseband > 4 Channels.
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11. From the menu bar, select MeasSetup > Frequency and set the Center 
Frequency to 5 GHz and Span to 100 MHz on all four channels. 

12. If External Trigger is available, it is recommended to use it to speed up the 
demodulation of the measurement. From the menu bar, select Input > 
Trigger and set:

— Style to External

— Level to 1 V
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13. Select File > Recall > Recall Setup and navigate to the setup file you 
saved during the VXG 5G NR setup.

14. From the menu bar, select MeasSetup > Measurement Type > Cellular > 
5G NR > 5G NR Modulation Analysis.

15. To configure the Analysis region, select MeasSetup > 5G NR Demod 
Properties > Configuration tab and select Open Test Model > TM3.1 > 
Apply > Close.

You will need to copy over the setup files to the X-Series Signal Analyzer or 
the PC running the VSA application, or continue with the settings below to 
setup the VSA manually.
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16. Select the PDSCH tab, scroll down, open the Antenna Port tab and set 
Antenna Ports Used to 0:3. Repeat for the remaining PDSCH channels by 
selecting the corresponding number at the top.

17. To reduce measurement time, select MeasSetup > 5G NR Demod 
Properties >Time and set:

— Result Length to 5 Subframes

— Meas Interval to 2 Subframes

— Enable Frame Trigger is present. 
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We are using an external trigger for this example so selecting Frame 
Trigger is Present will use the external trigger and will speed up the 
measurement significantly. If not using an external trigger, set to 
Normal.

18. At the top of the display, select Autorange.
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19. Observe the demodulation results.

— Trace A: Composite constellation diagram showing different 
modulation formats for the different channels/signals present in the 
transmitted signal. See Trace F (Frame Summary) for the list of 
channels and modulation formats. 

— Trace C: Summary trace showing composite error metrics.

— Trace D: Error Vector Spectrum showing EVM versus subcarrier and 
symbol.

— Trace E: Detected Allocations Time showing the detected 
allocations of all channels/signals within the measurement interval.

— Trace F: Frame Summary. EVM, per Layer EVM, Power per RE, Mod 
Format, Number of RB, RNTI, and BWP ID of the individual 
channels/signals.

— Trace G: MIMO Info table shows EVM, power, and time, frequency 
and phase offset for each antenna port.
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MIMO Info is a type of Matrix Table that provides sortable rows by 
column, selectable column visibility, and copy/paste and export 
functionality to share rows of content or complete tables to 
applications like email, text editing or spreadsheet programs.
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M9484C and X-Series Analyzer Measurement  Guide

4 Other X-Series Signal Analyzer Measurements 

— “Setting Up a Group Delay Measurement” on page 212

— “Setting Up Millimeter-Wave Measurements” on page 222

— “Setting up a 5G NR Millimeter-Wave Measurement” on page 222

— “Setting-up a Millimeter-Wave DVB-S2X 64APSK Measurement” on 
page 231

— “Setting-up a Millimeter-Wave 5G NR, 2 GHz BW FR2 
Measurement” on page 253

— “Using the X-Series Analyzer’s SCPI Recorder Function” on page 277

— “Using the X-Series Analyzer’s Preload/Unload Function” on page 290
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Setting Up a Group Delay Measurement

Group delay is a measure of phase distortion. Group delay is the actual transit 
time of a signal through a device under test as a function of frequency. When 
specifying group delay, it is important to specify the aperture used for the 
measurement.

In a group delay measurement:

— The linear phase shift component is converted to a constant value 
(representing the average delay).

— The higher order phase shift component is transformed into deviations from 
constant group delay (or group delay ripple).

— The deviations in group delay cause signal distortion, just as deviations from 
linear phase cause distortion.

— The measurement trace depicts the amount of time it takes for each 
frequency to travel through the device under test.

In this measurement example, we will use the M9484C VXG to generate a 
wideband modulated signal, drive this through a filter and the N9042B UXA 
will analyze the output signal and display the filter characteristics (gain, phase, 
and group-delay). Also, all settings to the VXG will be made via the Connection 
Management setup in the N9042B/N9056EM0E application. 

We will start by running a calibration to remove the fixture characteristics 
(cables, connectors, and other passive components) between the source and 
the device under test (DUT), in this case the filter. The filter in this example is a 
500 MHz bandpass filter, centered at 10.27 GHz. Settings my need to be 
adjusted for your filter.

For this example we are using the follow equipment:

— M9484C 

— Frequency range to 13.5 GHz (M9484C-514, M9484C-520, 
M9484C-532, or M9484C-544, or M9484C-554)

— N9042B (you can also use a N9040B, N9033B, N9030B, N9020B, or 
N9021B) 

— N9056EMOE Channel Quality/Group Delay Measurement application

— Accessories 

— Two 3 dB attenuators

— Baseband filter 
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1. Connect the two 3 dB attenuators, cables and adapters between the VXG 
and UXA (omitting the filter). 

After running a calibration to remove the effects of the fixturing, we will 
insert the filter between the two attenuators.

2. From the N9042B, select Mode/Meas > Channel Quality/Group Delay 
Mode > Group Delay Measurement > Quad display View. 

The Quad display shows the Spectrum, Gain Phase, Gain Magnitude, and 
Group Delay measurements.

3. In the Frequency menu panel, set the Center Frequency to 10.27 GHz and 
Span to 1 GHz.

4. In the Meas Setup menu panel, select the Signal Generator tab and 
confirm the Center Frequency is set to 10.27 GHz (the frequency of the 
filter) and set the Amplitude to +10 dBm.

The power is set to +10 dBm to compensate for the affects of the 
attenuators on the edges of the trace.This is because the SNR has been 
reduced by the attenuators and without increasing the power you would 
be essentially measuring the "noise" at the edges.

5. Select Connection Management. 

6. In the New Signal Generator area, specify the Hostname or IP address of 
the VXG, then select Add to Generator List > Connect.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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This allows us to setup the VXG directly from the UXA.

7. Select Apply Settings to Signal Generator to send these settings directly 
to the VXG, then Close the Connection Management window.

8. In the Meas Setup menu panel select the Tone tab and set the Number of 
Tones to 501 with a Tone Spacing of 1 MHz to provide a 500 MHz 
wideband signal. 

Notice that the span has automatically changed to 626.3 MHz to 
accommodate the Tone settings.

9. Select Configure Tone Table. There are lots of settings to choose from, but 
we will use these default settings.
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— Fill Type to Random Phase

— Random Seed Type to Fixed

— Random Seed to 0 

10. Select Apply Fill and all of the phase points get filled in for the 501 points. 
(Originally there were 64.)

11. Select Apply Tones to Signal Generator to setup the multitone signal. 

You will notice there is some ripple in the traces.

12. Close the Configure Tone table.

13. Select the Calibration tab > Calibrate Tones. 

The calibration will calculate the difference between tone definition and 
average input trace (magnitude and phase).

14. Once the calibration is complete, connect the filter between the two 3 dB 
attenuators to see the response of the filter.

15. For this example, set the Gain Magnitude Scale/Div to 5 dB and the 
Group Delay Scale/Div to 1 ns. For your specific measurement adjust the 
screen settings to a value that allows you to get the best signal resolution 
on your measurement displays.

If there is an Input Overload in the UXA, go to Amplitude > Attenuation tab > and increase 
the Mech Atten 2 dB at a time until the overload condition is resolved.
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16. From the menu panel, select Marker > Settings > Marker Settings 
Diagram. 

17. Activate Marker 1 by setting Marker Mode to Normal and set Marker 
Trace to Gain Phase. Click and drag Marker 1 to the Reference Marker 2 
position.   Activate Marker 2 by setting Marker Mode to Delta, then set 
Marker Trace to Gain Phase to put the marker on the Gain Phase 
measurement, then Close the window.

The Gain Phase is really input versus output instead of absolute phase.

18. Move Marker 1 to the Peak of the Signal within the bandwidth range of 
the signal and Marker 2 to the minimum.
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This provides the peak-to-peak deviation across this portion of the 
bandwidth of the filter. For this example, Peak to Peak Deviation is 
54.69 °.

19. Go back into the Marker Menu and turn on Marker 3 and set Marker Mode 
to Normal and Marker Trace to Avg Group Delay. Drag Marker 3 to Marker 
4’s Reference Position. Turn on Marker 4 and set Marker Mode to Delta 
and Marker Trace to Avg Group Delay. Close the Marker Settings Diagram.
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20. Move Marker 3 to the peak of the trace and Marker 4 to the minimum. 

For this example, peak to peak Average Group Delay is 4.42 ns.

21. From the menu panel, select Trace > Averaged Trace Off. With Averaged 
Trace Off, you can capture smalls spurs that might occur on the trace. 



 M9484C VXG and X-Series SA Measurement Guide                                                                                        219  

Other X-Series Signal Analyzer Measurements
Setting Up a Group Delay Measurement

22. Turn Instantaneous Trace Off and Averaged Trace On then set the 
Aperture to 10% to get a smoother result, but lose a little bit more at the 
beginning and the end of the 500 MHz band.

The Group Delay Aperture is the span over which the math of the delta 
phase over delta frequency is calculated. 
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23. Now set Aperture to a very narrow aperture of 1%. Any deviation or noise 
in the phase trace will show up a lot more. However as it averages down, 
the noise will average away.

24. From the N9042B, select Mode/Meas > Channel Quality/Group Delay 
Mode > Group Delay Measurement > 3x2 View. 

The 3x2 View will add the RF Envelope (Instantaneous Envelope) and 
Metrics. Other interesting Views to look are the IQ Waveform that is similar 
to the RF Envelope, or add the Phase View. Phase only is the absolute 
phase of the tone.
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Setting Up Millimeter-Wave Measurements
The V3080A Vector Signal Generator Frequency Extenders are designed to 
extend the frequency range of Keysight’s M9484C for millimeter-wave 
applications up to 110 GHz.

The V3050A Signal Analyzer Frequency Extenders are unbanded, preselected 
devices designed to extend the frequency range of Keysight’s N9042B UXA for 
millimeter-wave applications up to 110 GHz. 

We will connect the output of the M9848C VXG to the V3080A, then connect 
the output of the V3080A to the input of the V3050A, and finally connect the 
V3050A to the UXA to measure frequencies at 60 GHz and above. For complete 
setup instructions, refer to the V3080A Startup Guide.

Setting up a 5G NR Millimeter-Wave Measurement

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 60 GHz and Power to 
-10 dBm.

3. Select the Radio Apps block to open the mode selection panel.

The VXG must have the N7631APPC Signal Generation for 5G NR license 
installed.
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4. Select 5G NR to enter the 5G NR signal mode.

5. In the 5G NR setup, select the Waveform tab and observe the Phase 
Compensation and Radio Frequency settings.
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Phase Compensation is applied by default at baseband for RF 
up-conversion. This means it depends on the carrier frequency, and the 
waveform should only be played at the carrier frequency it was generated 
for, unlike conventional Signal Studio waveforms, which are independent 
from carrier frequency. Phase Compensation is set to Auto by default. The 
frequency is coupled with the VXG frequency setting. You can select 
Manual to specify a different frequency, or turn it off.

TIP Some applications, like power amplifier measurements use the same 
waveform at different frequencies and can be time consuming to generate a 
separate waveform for each frequency. In this case, you would turn Phase 
Compensation Off, so the waveform becomes independent from the carrier 
frequency. You need to do the same on the analysis side, or the demodulation 
will fail.

6. Select the Carrier tab.

7. Select DL Test Model and set Bandwidth to 
FR2 400 MHz and Test Model to NR-FR2-TM3.1a.
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Notice that the description of the currently selected test model appears to 
the right. These test models are defined in the section 3GPP TS 4.9.2 of 
38.141.

8. Select OK to exit the Downlink Test Model setup. 

9.  Select Generate to generate the Waveform, and then select Home to exit 
the setup panel.

10. Set RF Out to On by selecting the numbered channel indicator switch. 
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This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

11. Select the System menu (triple bar tab at the top left of the window) to 
open the System Menu and then select Configure Analyzer.

12. In the System Configuration setup, click on the Remote Signal Analyzer 
block (on far right) to setup the communication channel to the Keysight 
X-Series Signal Analyzer. 

13. Set Connection Type to LAN.

14. In the Connect Remote X-Series Signal Analyzer setup, enter the 
Hostname or IP Address for the signal analyzer.

15. Under Set Protocol, select HiSLIP and use the Remote name hislip0.
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16. Select Test Connection to verify, then Back.

17. Select Auto Configure Analyzer to send the VXG settings to the analyzer. 

18. On the N9042B, select Meas Setup > Optimize EVM.

Optimize EVM is an immediate action to adjust the hardware settings to 
minimize EVM. 

— Normal method will capture input signal, measure its peak power 
then the algorithm will find proper setting combination for 
attenuation, preamp and IF Gain.
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— Iterative method will capture input signal multiple times in a 
iteration process, demodulate the signal and calculate EVM for each 
iteration and find setting combination for attenuation, preamp and 
IF Gain with minimum EVM. 

For 5G NR signals, this method is much slower, than normal, but 
with achieve better EVM results. You can also manually adjust IF 
Gain, Frequency Extender Attenuation (use when measurement 
setup includes a V3050A frequency extender).

19. View the results on the signal analyzer. 

20. Change the frequency and power level of the M9484C and frequency of 
the N9042A to view other results. Remember to Optimize EVM after each 
change.
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This measurement was done at 70 GHz, - 10 dBm.

This measurement was done at 80 GHz, - 10 dBm.
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This measurement was done at 85 GHz, - 10 dBm.
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Setting-up a Millimeter-Wave DVB-S2X 64APSK Measurement

Setting up the VXG

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 81 GHz and Power to 
-10 dBm.

3. Select the Radio Apps block to open the mode selection panel.

4. Select Custom Modulation to enter Custom Modulation Signal Mode.

5. Select the Carrier tab.

The VXG must have the N7608C Signal Studio for Custom Modulation 
license installed.
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6. In the Custom Modulation setup, select the Carrier tab > Quick Setups > 
DVB-S2X > 64APSK > 4+12+20+28APSK 132/180.

7. From the left pane, select Custom ASK & PSK & QAM Settings and set the 
Symbol Rate to 400 Msps per channel.

8. Select Filter > Alpha to 0.1. 
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We will match these settings in the UXA setup.

9.  Select the Waveform tab, then Generate to generate the Waveform, and 
then select Home to exit the setup panel.

10. Set RF Out to On by selecting the numbered channel indicator switch. 
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This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

Setting Up the UXA Using X-Apps

1. Using Spectrum Analyzer Swept SA mode, set Frequency to 81 GHz and 
Span to 500 MHz.

2. Select Marker > Marker Function tab > Band Function and select to Band 
Power.

3. Set Marker Frequency to 81 GHz.

4. Set Band Span to 400 MHz.

5. Select Mode/Meas > Vector Modulation Analyzer Mode > Digital Demod 
Measurement > Dual Segment View.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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6. Select Frequency and set to 81 GHz.
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7. Select Meas Setup >Meas Standard tab > Presel to Std, and then select 
Digital Video > DVB-S2X > 64-APSK Code Rate 132/180 (11/15), then OK 
to close the window.

8. Select BW and set to Info BW to 440 MHz.
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9.  Select Meas Setup > Demod tab and set the Symbol Rate to 400 MHz and 
Filter Alpha to 0.1 for both Segment 1 and Segment 2 to match the 
settings in the Custom Modulation Setup.

10. Select the Meas Time tab and note that Meas Interval for Segment 1 is set 
to 90 symbols, the same as the Header setting in the Custom Modulation 
setup. Select Segment 2 and set Meas Interval to 2000 symbols to match 
the Data Segment in the Custom Modulation setup.
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11. Select the Frame tab > Segment Config Diagram and set Equalizer to turn 
on for both Segment 1 and Segment 2, then Close the window.

12. Select Amplitude > Signal Path tab > select Allow Full Bypass in Auto to 
turn On.

Notice that is recommended in the Meas Setup > Settings tab to turn this 
on for best EVM results.
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13. At the top of the display, select Equalizer On/Off. From the dropdown, 
select Equalizer Reset.
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14. In the Seg2_IQ Meas Time display, notice that the constellation diagram 
goes off the display. To adjust the scaling, select the left side of the 
window and set the Scale/Div to .3 (300.00 m per division) > Enter. 
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15. Select Meas Setup > Settings tab > Optimize EVM.

The default setting uses the Normal method for Optimize EVM. This is a 
quick way to improve your measurement results. The EVM will continue to 
reduce as the UXA continues to sweep. This is because the Equalizer is 
correcting for linear distortions in the measurement setup.

You must set this value to 300 instead of .3, the scaling gets changed to 
250 k per division instead of 250 m per division.
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You can also set EVM Optimization Method Iterative mode, then select 
either segment for optimization. This method takes a few minutes to 
complete. For the example below, we set the Optimization Target to 
Segment 2. Notice how the EVM went from .89% to .74%. 

TIP You can also manually adjust to optimize EVM.

—  Select Amplitude menu > Attenuation > Frequency Extender Atten. 
Use the step keys to increase and decrease the attenuation by 2 dB 
per step. After each increment, wait for the update to determine 
where the lowest EVM point is achieved.

— Select Meas Setup > Advanced > IF Gain Other. Use the step keys to 
increase and decrease the attenuation by 1 dB per step. After each 
increment, wait for the display to updated to determine where the 
lowest EVM point is achieved.

In this example, we found the optimum settings were 10 dB of Mechanical 
Attenuation and -8 dB of IF Gain. We will use these settings in the 89600 VSA 
setup. 
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Setting Up the UXA Using 89600 VSA

1. Open the VSA software. 

To access the VSA software, go to the Windows Start menu and find 
Keysight 89600 Software (latest installed version) folder and run the 
software.

2. From the VSA menu bar, select File > Preset > All to set the VSA to a 
known state.

3. From the menu bar, select Input > Channels > External Mixer > 1 Channel.

4. In the Spectrum window, select Center and set the Center Frequency to 
81 GHz. and Span to 1 GHz.

Changing settings on the VSA can take longer to take affect than 
expected. Pausing the measurement until all settings have been made will 
help speed up the time. Wait to change the next setting until the previous 
setting has been updated.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 



244                                                                                   M9484C VXG and X-Series SA Measurement Guide

Other X-Series Signal Analyzer Measurements
Setting Up Millimeter-Wave Measurements

5. From the menu bar, select Input > Extensions and set:

— Microwave Path Control to Full Bypass

— Phase Noise Optimization to Best Wide Offset

— IF Gain to -8 dB 

— Select the External Mixer tab and set Input Attenuation to 10 dB

These are the optimized settings we used in the X-Apps 
measurement. 
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6. From the menu bar, select MeasSetup > General Purpose > Flex Frame.

7. Change the Trace Layout Grid to 2 x 3.

8. Select MeasSetup > Flex Frame Properties > Carrier Aggregation tab, and 
set: 

— CCO Absolute Center frequency to 81 GHz

— Symbol Rate to 400 MHz.
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— Edit dropdown and set Assigned Carriers to CCO.

9. In the Flex Frame Properties window, select the Frame Definition tab. 
Under Component Carrier Configuration, select the Modulation tab, and 
then set Preferred Bit to Symbol Mapping to DVB-S2X.
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10. In the Frame Definition tab, under Component Carrier Configuration, 
select the Frame Configuration tab and set Symbol Rate to 400 MHz and 
Length to 2090 Symbols. 

11. To configure the Pilot:

— In the Frame Parts area, select Alloc0

— In the Configuration area, set

— Name to PLHEADER

— Type to Pilot

— Sequence to Custom

— Modulation to QPSK

— Select Include BER Calculations
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— Go back into the VXG Custom Modulation setup Carrier 
tab and select PLHEADER Payload to open and copy the 
symbols.

— Paste the symbols you copied over from the Custom 
Modulation PLHEADER Payload setup.

— In the Location area, 

— Clear the End of Frame checkbox

— Start Symbol to 0
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— Total Length to 90

12. In the Frame Parts area, select Add Allocation and set:

— Name to Data

— Type to Data

— Sequence to PN15

— Modulation to DVB S2/S2X APSK

— MODCOD to 4+12+20+ 28APSK Normal 132/180

— Select Include in BER Calculations
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— In the Location area, set Start Symbol to 90.

13. In the Measurement Control tab, and set: 

— Channel Estimation Source to Allocations with Known Sequences

— Select Initial Equalization

— Normalized Channel Delay Spread to 20 Symbols
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— Clear the Show EVM in dB checkbox

14. In the Time tab, set Result Length to 2090 Symbols. 
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15. In the Filter tab, set Alpha BT to 0.1 and Length to 32 Symbols and then 
close the Flex Frame Properties window.

16. View the results of the measurement. Try to improve EVM by adjusting 
the IF Gain and Mechanical Attenuation settings in the Input >Extensions 
and the Input > External Mixer windows.
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Setting-up a Millimeter-Wave 5G NR, 2 GHz BW FR2 Measurement

This measurement example will show you how to configure and analyze a
 2000 MHz 5G NR, FR2, signal. 3GPP Rel-17 introduced a new frequency band 
52.6 - 71 GHz, with new numerology (480 kHz, 960 kHz) and new bandwidth 
(800 MHz, 1600 MHz, 2000 MHz). Support for these new 
numerologies/bandwidths was added in VSA2023 Update 2.0 release and will 
be part of PWSG 2023 Update 1.0.

Software Requirements

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 70 GHz and Power to 
-10 dBm.

3. Select the Radio Apps block to open the mode selection panel.

4. Select 5G NR.

5. Select the Waveform tab and turn off Phase Compensation so the same 
waveform can be used at different frequencies.

PathWave Signal Generation for 5G NR N7631APPC 2023U1 or later

89600 VSA software 89601BHNC VSA2023U2 or later

Waveform generation and analysis speed will be very slow since we are 
generating and analyzing a 2 GHz wide NR signal. (That is, 5 times more 
data compared to a 400 MHz 5G NR signal.) To improve some 
demodulation speed, use VSA2024, which has some speed improvement 
and also use an external trigger for demodulation. (N9042B rear panel 
Trigger 1 In to M9484C rear panel 10 MHz Ref Out.) Furthermore, to 
improve VSA setup speed Stop the measurement until all parameters are 
correctly configured, then run the measurement (Control menu > Stop).
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Phase compensation is applied by default at baseband for RF 
up-conversion. This means, it depends on carrier frequency, so a 
waveform needs to be generated per carrier frequency unlike conventional 
waveforms which are independent from carrier frequency. Phase 
Compensation default is set to AUTO. The frequency is coupled with VXG 
frequency setting. You can select Manual to specify different frequency or 
turn it OFF so it is not frequency dependent. 

6. To configure the Downlink carrier, select the Carrier tab > Full-filled 
Config and set:

— Bandwidth to FR2 2000 MHz

— Duplex Type to TDD

— Number of Downlink slots to 59

— Number of Uplink Slots to 18

— Modulation to 256 QAM
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— Select OK to close the window.

These parameters are based on 3GPP endorsed Test Model for 
2000 MHz bandwidth. 
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7. Under the Carrier (DL) side tab, scroll down and set Cell ID to 201.

8. Select Channel Setup > SS/PBCH and set Active Indices to 0:63.

With RB Offset by 60 kHz SCS set to 1024 and kSSB by 
subcarrierSpacingCommon set to 0, the SSB is set to the center of the 
carrier. This is shown in the Channel Allocation graph at the bottom of the 
window. If you set it to 0, the SSB will be set in the lower band of the 
carrier. 
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Unlike LTE, there is no fixed frequency location for SS/PBCH in NR. By 
default, PWSG transmits SS/PBCH (20 RB or 240 subcarriers wide) 
centered at the carrier bandwidth (2000 MHz channel BW in this 
example). This is a very important parameter since it shows were the 
SS/PBCH is located within the channel bandwidth in the frequency 
domain and it is relative to common resource block 0 (CRB0). 

9. Select DL-SCH > DL-SCH0_D.

You should see DL-SCH0_D and DL-SCH0-S. These are configured from 
the Full-filled Config settings above. We will make a couple edits to the 
Reference Signal configurations.

— Confirm Allocated Slots is set to 
0:58,80:138,160:218,240:298,320:378,400:458,480:538,560:618

These values will be used in the VSA/X-App. You can copy these 
values for easier setup later. 

— Confirm that MCS Table is set to 256QAM and MCS to 20. MCS 
table, MCS value, scaling factor, etc. must match with the VSA (or 
X-App) for successful decoding (CRC pass/fail). 

— Set DMRS-add-pos to 1. Additional DMRS is transmitted on a 
symbol before the last symbol.

— Select PTRS Enabled. For FR2, PTRS is used for phase tracking.
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— Set Time Density to 4.
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10. Select DL-SCH0_S. Set PTRS Enabled and Time Density to 4. Confirm that 
Allocated Slots is set to 59,139,219,299,379,459,539,619. 

11. Select the Waveform tab, then Generate to generate the Waveform, and 
then select Home to exit the setup panel.
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TIP When using 89600 VSA software for demodulation, you can export the VSA 
setup file from PathWave to demodulate the waveform quickly and easily or 
export the setup file into X-Apps. 

12. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.
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Setting Up the UXA Using 89600 VSA

1. Open the VSA software. 

2. From the VSA menu bar, select File > Preset > All to set the VSA to a 
known state.

3. From the menu bar, select Input > Channels > External Mixer > 1 Channel.

4. In the Spectrum window, select Center and set the Center Frequency to 
70 GHz.

Notice there is an OV1 error indicator. The OVx indicator appears when 
the trace was created from data that contained an ADC overload. We will 
resolve this in step 7.

Changing settings on the VSA can take longer to take affect than 
expected. Stopping the measurement (Control menu > Stop) until all 
settings have been made will help speed up the setup time. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window, then select Launch VSA.



262                                                                                   M9484C VXG and X-Series SA Measurement Guide

Other X-Series Signal Analyzer Measurements
Setting Up Millimeter-Wave Measurements

5. From the menu bar, select Input > Trigger and set Style to External and 
Level to 500 mV.

Using the External Trigger will help to improve the demod speed.

6. Select the Extensions tab and set:

— IF Path to 2 GHz

— Microwave Path Control to Full Bypass

— Phase Noise Optimization to Best Wide Offset
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7. Select the External Mixer tab and set Input Attenuation to approximately 
20 dB, or a level where the overload flag disappears. This is to bring the 
waveform up on the spectrum display.

8. In the Spectrum window, right click on the Spectrum display and select 
Auto Scale.
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9.  From the menu bar, select MeasSetup > Cellular > 5G NR > 5G NR 
Modulation Analysis.

10. Change the Trace Layout Grid to 2 x 3. Right click on the Spectrum 
window and select Auto Scale to bring the waveform back up on the 
display.
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11. Select the Control menu > Stop to stop the measurement until all 
parameters have configured. This will greatly improve setup speed.

12. Select MeasSetup > 5G NR Demod Properties > Configuration tab > 
Carriers panel and set: 

— Cell ID to 201 (or select the box to the right to Auto Detect the cell 
ID)

— Bandwidth to FR2 2000 MHz

— Frequency for Phase Compensation to Disabled.

Cell ID is carried on PSS and SSS so the SS/PBCH must be transmitted 
and enabled for Auto Cell ID to work and must be a Downlink since 
SS/PBCH is only transmitted in the DL.

13. Select MeasSetup > 5G NR Demod Properties > Configuration tab > 
Bandwidth panel. This section of the UI is to configure Resource Grid for 
each Numerology. Numerology is set to kHz. 
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For FR2 2000 MHz, only the 960 kHz subcarrier spacing is available. This is 
why the other numerologies are not shown. The Max RB is 148 RB. We will 
use this value when we configure BWP, SS/PBCH, and PDSCH parameters.

14. Select MeasSetup > 5G NR Demod Properties > Configuration tab > BWP 
panel. We will use the default settings for DL-BWP 1.

This section of the UI is to configure the DL BWP allocation within the 
component carrier and the control resource set (CORESET). CORESET is 
used for PDCCH configuration and there is no PDCCH in this measurement 
example, so we don't need to make changes.

A CC with 2000 MHz at FR2 has a max RB of 148 for 960 kHz numerology. 
In this example, the DL-BWP uses the full carrier bandwidth of 148 RBs 
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When using multiple BWPs within a single component carrier, you will 
spread the total 148 RBs across the multiple BWPs.

15. Select MeasSetup > 5G NR Demod Properties > Configuration tab > 
Channel > SS/PBCH.

The auto detected parameters are returned in the Summary table trace. 
Once you see what has been auto detected and are happy with what you 
see, you can do "Copy Auto to Manual" to copy the detected parameters 
into the SS/PBCH settings. See image below.
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The auto detected SSB parameters are returned in the Summary table.  
"Copy Auto to Manual" will copy these detected parameters into the 
SS/PBCH settings. 

16. Select MeasSetup > 5G NR Demod Properties > Configuration tab > 
Channel > SS/PBCH.

PSS and PBCH Power boosting cannot be auto detected, you must enter 
power boosting values under SS/PBCH. We will use the default values. 
Notice that the remaining values are grayed out as we are in Auto 
Detection mode.

Note that the frequency location of a SSBlock is not fixed. In our software, 
the default value of 1024RB and kSSB of 0 subcarriers places it in the 
center of the carrier bandwidth. If you set RB Offset to 0 dB, it places the 
SSB on the lower edge of the carrier bandwidth 
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17. Select MeasSetup > 5G NR Demod Properties > Configuration tab > 
Channel > PDSCH and set:

— MCS Table to Table 256QAM

— MCS to 20

Transport Block Size value must match the PathWave 5G NR 
settings for successful decoding (CRC result). 

— Allocated Slots to 
0:58,80:138,160:218,240:298,320:378,400:458,480:538,560:618 

TIP You can copy/paste these values from PathWave 5G NR Signal Generation. 
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18. Scroll Down to RS Sequence and set:

— DMRS AddPos to Pos1

— Select Enable PTRS
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— LPTRS to 4

19. Select Add PDSCH and then select PDSCH 1. Set:

— MCS Table to Table 256 QAM

— MCS to 20

Transport Block Size value must match the PathWave 5G NR 
settings for successful decoding (CRC result). The Value depends 
on parameters in this section and the RNTI value of the PDSCH 
much also match. This will not affect EVM.

— Allocated Slots to 59:80:619
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— Last Symbol to 5

20. Scroll Down to RS Sequence and set:

— DMRS AddPos to Pos1

— Select Enable PTRS
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— LPTRS to 4

21. In the Time tab set: 

— Result Length to 4 Subframes 

— Meas Interval to 1 Subframes

We are reducing the analysis region since a 2000 MHz carrier has a 
large amount of data resulting in very slow demod speed. (That is, 
5x more data than 400 MHz carrier.) 

— Acquisition Mode to Frame Trigger is Present
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We are using an external trigger for this example, so selecting 
"Frame Trigger is Present" will use the external trigger and will 
speed up the measurement significantly.

22. Select the Advanced tab:

— Clear the 3GPP Conformance checkbox

— In the Tracking area, set Tracking Source to RS + Data and select 
Phase

— In the Equalizer Training area, set Signal Source to RS + Data and 
clear the Freq Moving Avg. Filter checkbox.

— Turn on DC Punctured.
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5G NR counts the DC subcarrier as a valid subcarrier for 
rate-matching purposes. High LO feedthrough will impact 
demodulation and EVM performance of the input.

23. Close the 5G NR Demod Properties window and select Control > Restart 
to restart the measurement.

24. View the results of the measurement. Try to improve EVM by adjusting 
the Mechanical Attenuation setting until the OV1 indicator goes away in 
the IF Gain and Mechanical Attenuation settings in the Input >Extensions 
and the Input > External Mixer windows.

For this example, the optimum settings were Input Attenuation set to 
8 dB and IF gain set to -12 dB. 
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Using the X-Series Analyzer’s SCPI Recorder Function 
The SCPI Recorder feature allows you to view active recording content, and 
edit the content. Right-click or touch and hold on any UI control to display a 
menu allowing you to record the SCPI associated with the control. You can also 
record a series of commands. These commands can be viewed and edited 
directly, or you can also play, save/recall for future use.

For this example, we will generate a simple 5G NR 100 MHz signal.

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 3.5 GHz and Power to 
0 dBm.

3. Select the Radio Apps block to open the mode selection panel.

4. Select 5G NR.
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5. Select the Carrier tab > DL Test Model and set Test Model to 
NR-FR1-TM3.1b, leave the remain settings at their default values, and 
select OK. 

 



 M9484C VXG and X-Series SA Measurement Guide                                                                                        279  

Other X-Series Signal Analyzer Measurements
Using the X-Series Analyzer’s SCPI Recorder Function

6.  Select the Waveform tab, then Generate to generate the Waveform, and 
then select Home to exit the setup panel. 

7.  Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. Select Mode/Meas > 5G NR &V2X Mode > OK. 

2. Select Mode Preset to set Spectrum Analyzer 5G NR mode to a known 
state.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top left of the display) to open the 
Mode/Measurement/View Selector window. 
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3. From the N9042B Menu Panel (or the Screen tab), select Mode/Meas > 5G 
NR & V2X Mode > Modulation Analysis Measurement > OK. 

4. Select Frequency and set Carrier Reference Frequency to 3.5 GHz.

— Touch and hold the Carrier Reference Frequency function for at 
least one second on the touch screen or if using a mouse pointer 
and right click to open the menu.

— Select Show SCPI Command.

The SCPI command for this function is displayed in the dialog box.

Select Copy to copy the current SCPI command string for further 
use.

If you use Windows Remote Desktop or a VNC viewer with clipboard 
synchronization enabled, you can copy the SCPI command into the 
clipboard. This makes SCPI commands available on the fly via a 
simple copy/paste operation.

— Select Help on this setting to open the SCPI syntax document page.
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You will see the background information for that setting including 
allowed values, SCPI command and examples, and other useful 
information. 

To Start Continuous SCPI Recording: 

The SCPI Recorder supports an automatic mode of operation. In this mode, a 
series of manual operations can be added to the list automatically without any 
further user activity. You can start the recording process by enabling the 
Continuous SCPI Recording, then disable it to stop recording after completing 
all configuration steps. This is normally the best choice for fast and convenient 
SCPI list recording. 

There are two ways to start continuous SCPI recording:
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— From the System Settings > SCPI Recorder.

— From the context sensitive menu of the function key.
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1. Select Mode Preset to set 5G NR V2X mode to a known state.

2. For this example, select the System Settings icon (Gear wheel on top right 
of the display) > SCPI Recorder > Continuous SCPI Recording On. Close 
the System Settings window by selecting the "X" at the top of the window.

3. Select Mode/Meas > 5G NR &V2X Mode > Modulation Analysis 
Measurement > Normal View > OK. 

4. Select Frequency > Carrier Reference Frequency and set to 3.5 GHz.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top left of the display) to open the 
Mode/Measurement/View Selector window. 
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5. Select Meas Setup > Meas Standard > RB Alloc Preset > DL NR-TM3.1 > 
DL NR-TM3.1b (1024QAM) > OK.

6. Select Apply Preset (to All CCs).



 M9484C VXG and X-Series SA Measurement Guide                                                                                        285  

Other X-Series Signal Analyzer Measurements
Using the X-Series Analyzer’s SCPI Recorder Function

7. Select the Settings side tab and select Optimize EVM.

8. Select Sweep > Sweep/Meas to Single > Restart.
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9. Select the System Settings icon (Gear wheel on top right of the display) > 
SCPI Recorder > Continuous SCPI Recording Off. Close the System 
Settings window by selecting the "X".

Manual Recording, Edit, Save and Play Functions

The SCPI Recorder supports manual recording of a list consisting of SCPI 
commands comprising any number of parameter variations when Continuous 
SCPI Recording is off. In this mode, the user can decide which SCPI commands 
should be added to the SCPI list. This mode of recording is helpful if a certain 
configuration must be figured out, and you only want to record the final, 
correct settings and not every variation or keystroke. 
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1. Touch and hold the any function for at least one second on the touch 
screen or if using a mouse pointer and right click to open the menu and 
select Add to SCPI Recorder. For this is example we will change EVM 
Optimization Method to Iterative.

2. To view the newly added command, go to System Settings icon (Gear 
wheel on top right of the display) > SCPI Recorder.
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From the SCPI Recorder provides several operations to edit the SCPI list 
you created. You can Play, Copy, Move Up or Down the selected SCPI 
command, Delete the command, or Delete All the commands.

The recorded SCPI list can be exported as a script file in .TXT format via 
the Save/Recall function at the bottom of the main window. 
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There are two ways to playback SCPI commands. One is recalling from a 
script file. And another one is pressing the 'Play' button in 'SCPI Recorder' 
tab view. 

Recalling SCPI script file allows you to play back a series of operations in 
the same or another instrument, which helps you setup complex 
measurement scenarios quickly and easily.

To recall the SCPI recording, go to Save/Recall and navigate to the saved 
file.
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Using the X-Series Analyzer’s Preload/Unload Function

The Preload/Unload function allows you to flexibly configure which 
applications should be preloaded when the software starts up, or also unload 
any previously loaded applications. This can help to save startup time or 
system memory as needed. 

1. Select the System Settings icon (Gear wheel on top right of the display) > 
Preload/Unload.

— Power On Mode displays a list of licensed Applications. Use this 
control to change the factory default Power-On Mode. The 
instrument will execute the selected Application after power up. 
Selecting the Power-On Mode here automatically enables that 
Mode for preloading

— Select All, Deselect All toggles the Preload checkbox state for all 
applications listed, except for the Power-On application.

— Move Up, Move Down allows you to reorder the listed applications 
in the table. This is the order in which they are displayed in the 
Mode/Measurement/View Selector dialog. 

— Unload Mode unloads the specified mode.

— Loaded Modes returns a list of loaded modes.
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5 5G New Radio (NR) Measurements using X-Apps

This section includes the following topics:

— “5G Waveform, EVM, and ACP Analysis Using X-Applications” on page 292

— “Setting Up Triggers on the Signal Analyzer using 5G NR Mode” on 
page 292

— “Setting Up a 1 CC 28 GHz EVM Measurement” on page 294

— “Setting up an 8 CC 28 GHz EVM Measurement” on page 301

— “Setting Up a 1 CC 3.5 GHz ACP Measurement” on page 311

— “Using PathWave N7631APPC to Create a Waveform File then 
Automatically Configure the Analyzer to View the Results” on 
page 316
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5G Waveform, EVM, and ACP Analysis Using X-Applications
The VXG enables 5G testing with a low error vector magnitude (EVM) at high 
frequencies. The VXG has extremely good EVM at high power levels. However, 
not all signal analyzers can capture this low value. We will use the X-Series 
signal analyzer with the 5G NR X-Series application to observe EVM and 
adjacent channel power (ACP). 

Setting Up Triggers on the Signal Analyzer using 5G NR Mode

Setting Up Triggers on the X-Series Signal Analyzer

Using the graphical user interface

1. On the signal analyzer, select Mode/Meas > 5G NR & V2X mode. 

2. Select Mode Preset to set 5G NR mode to a known state.

3. Select Mode/Meas > 5G NR V2X Mode > Modulation Analysis 
Measurement.

4.  From the Menu Panel (on the top right of the display), select Trigger and 
set Select Trigger Source to External 1 and Trigger Level to 1 V.

Refer to “Equipment Setup” on page 11 for connecting the instruments and 
accessing the VXG SFP.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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Using the equivalent SCPI commands

On the X-Series Signal Analyzer:

INSTrument:CONFigure:NR5G

SYSTem:PRESet

Change the current window to 5G NR Modulation Analysis Measurement Mode

INSTrument:CONFigure:NR5G:EVM

TRIGger:EVM:SOURce EXTernal1

TRIGger:EXTernal1:LEVel 1V
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Setting Up a 1 CC 28 GHz EVM Measurement 

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. In the Output 1 area, set Frequency to 28 GHz and Power to 
5 dBm.

3. Select Group 1: Signals block to open.

4. Select the arrow for Signal 1 to open the Signal Setup window.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 11 and “Setting Up Triggers on the Signal 
Analyzer using 5G NR Mode” on page 292. 

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples
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and choose
5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DCPunctured
_28GHz.wfm > Select.

d. Select the General tab > Enable.

6. Close the Vector Modulation Signal Setup by selecting the Home icon at 
the top of the display.

7. Select the Adjustments block and select Optimize Dynamic Range with 
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW  This setting filters the system 
RF flatness correction coefficients over the instantaneous bandwidth 
indicated in the waveform header (or in the “Occupied Bandwidth” 
settings area under the Signal block > Occupied Bandwidth setting). 
This has the potential to improve EVM performance by not having to 
correct for flatness errors outside the requested bandwidth. For 
example, if RF flatness correction was done at 2 GHz, but you are 
only interested in an 800 MHz section, then applying the correction 
flatness to that portion only can improve signal to noise ratio, and 
therefore EVM when there is a lot of hardware roll off.
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Enable System RF Flatness Correction -   Disabling this function 
disables the factory calibrated RF channel flatness equalizer. 
Depending on the hardware channel response, this may hurt or 
improve the EVM. This is due to the dynamic range implications as it 
relates to signal to noise ratio. The greater the RF hardware 
variations in flatness, the greater the amount of correction is 
required, the greater the correction effectively reduces the number of 
resolution DAC bits that can be used, which degrades the signal to 
noise ratio and therefore potentially EVM. The trade-off is to balance 
between flatness and signal to noise ratio.

8.  Close the Adjustments Setup by either selecting the Back or the Home 
icon at the top of the display.

9.  Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

10. For two channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.
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On the X-Series Signal Analyzer:

1. Select Recall (If accessing the signal analyzer remotely, select the Folder 
icon at the bottom of the display) Demod Info > Set Data Type to CC Setup 
> Recall From > 

5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC punctured_
28GHz_34.scp 

Recall

2. Select Meas Setup > Meas Time and set:

— Search Length to 10 ms

— Result Length to 2 Sub Frame

— Frame Trigger to On

3. Select the Settings tab > Optimize EVM.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or 
the PC running the VSA application.
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The Optimize EVM function automatically sets the combination of 
preamplification, mechanical and electronic attenuation, and IF gain based 
on the measured signal peak level. 

EVM should be less than 1%. 
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude 5dBm

SIGNal1:MODE WAVeform

Navigate to the desired waveform file.

SIGNal1:WAVeform “D:\Users\Instrument\Documents\demo 
waveforms 
5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC punctured_
28GHz_34.scp ”

SIGNal1 ON

IQO:CORR:OPT:DYN:RANG:OBW ON

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

MMEMory:LOAD:EVM:SETup CC0, 
“D:\Users\Instrument\Documents\NR5G\data\NR5GEvm\CarrierSetu
p\5GNR_1CC_FR2_120kHz 
SCS_100MHz_256QAM_DCpunctured_28GHz.scp”

EVM:CCARrier0:TIME:LENGth:SEARch 10ms

EVM:CCARrier0:TIME:LENGth:RESult 2

EVM:CCARrier0:FRAMe:TRIGger ON

EVM:CCARrier0:DC:PUNCture ON

EVM:CCARrier0:PHASe:COMPensation:AUTO OFF

EVM:CCARrier0:PHASe:COMPensation:FREQuency 0 Hz

EVM:OPTimize

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal 
AnalyzerX-Series Signal Analyzer or the PC running the VSA application.
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Setting up an 8 CC 28 GHz EVM Measurement

This procedure shows you how to use the X-Series signal analyzer with the 
5G NR & V2X X-Series application to observe EVM on an eight-carrier 
waveform. 

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. Set Frequency to 28 GHz and Amplitude to 5 dBm. 

3. Select Group 1: Signals block to open.

4. Select the arrow for Signal 1 to open the Signal Setup window.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 11 and “Setting Up Triggers on the Signal 
Analyzer using 5G NR Mode” on page 292.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples
and choose
5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_28GHz.
wfm
then Select.
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d. Select the General tab > Enable.

6.  Close the Signal Setup by selecting the Home icon at the top of the 
display.

7. Select the Adjustments block and select Optimize Dynamic Range with 
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW  This setting filters the system 
RF flatness correction coefficients over the instantaneous bandwidth 
indicated in the waveform header (or in the “Occupied Bandwidth” 
settings area under the Signal block > Occupied Bandwidth setting). 
This has the potential to improve EVM performance by not having to 
correct for flatness errors outside the requested bandwidth. For 
example, if RF flatness correction was done at 2 GHz, but you are 
only interested in an 800 MHz section, then applying the correction 
flatness to that portion only can improve signal to noise ratio, and 
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction -   Disabling this function 
disables the factory calibrated RF channel flatness equalizer. 
Depending on the hardware channel response, this may hurt or 
improve the EVM. This is due to the dynamic range implications as it 
relates to signal to noise ratio. The greater the RF hardware 
variations in flatness, the greater the amount of correction is 
required, the greater the correction effectively reduces the number of 
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resolution DAC bits that can be used, which degrades the signal to 
noise ratio and therefore potentially EVM. The trade-off is to balance 
between flatness and signal to noise ratio.

8.  Close the Adjustments Setup by either selecting the Back or the Home 
icon at the top of the display.

9.  Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

10. For multi-channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.
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On the X-Series Signal Analyzer:

1. Select Recall (If accessing the signal analyzer remotely, select the Folder 
icon at the bottom of the display) > Demod Info > set Data Type to CC 
Setup > Recall From > 
5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_28GHz
_34.scp > Recall.

You must be in the correct analysis mode (in this case, 5G NR & V2X1 
>Modulation Analysis mode) to recall the .scp file. 

2. Select Meas Setup > Meas Time tab and set:

— Search Length to 10 ms

— Result Length to 2 Sub Frame

— Frame Trigger to On

3. Select Meas Setup > Advanced tab > Advanced Demod Setup and verify 
that both Multi-Carrier Filter and DC Punctured are on.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the signal analyzer or the PC running 
the VSA application.
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The multi-carrier filter is used to filter out the unwanted carriers and 
minimize leakage into the component carrier of interest.

4. Ensure that RF for Phase Compensation is not selected and the value is 
0 Hz, then Close the Advanced Settings table.

5. Select Meas Setup > Settings tab > Optimize EVM. 

It will take a couple of minutes for the UXA to measure all 8 carriers.

Notice that the Error Summary measurement has a scroll bar allowing you 
to view the results of all 8 component carriers.

If you are getting a "Sync Error; Sync not found" or "Input Overload - 
Detected; ADC over range" message), go to Amplitude > Attenuation > and 
increase the Mechanical Attenuation by 2 dB until the Sync Error is resold.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude 5dBm

SIGNal1:MODE WAVeform

Navigate to the desired waveform file.

SIGNal1:WAVeform “D:\Users\Instrument\Documents\demo 
waveforms\5GNR_8CC_FR2_120kHz_SCS_100MHz_Corrected_28GHz.wfm
”

SIGNal1 ON

IQO:CORR:OPT:DYN:RANG:OBW ON

IQO:CORR:CHANNel:FLATness ON

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

Navigate to the desired waveform file.

MMEMory:LOAD:EVM:SETup CC0, 
“D:\Users\Instrument\Documents\NR5G\data\NR5GEvm\CarrierSetu
p\8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_28GHz_34.scp ”

EVM:CCARrier0:TIME:LENGth:SEARch 10ms

EVM:CCARrier0:TIME:LENGth:RESult 2

EVM:CCARrier0:FRAMe:TRIGger ON

EVM:CCARrier0:MCFilter ON

EVM:CCARrier0:DC:PUNCture ON

EVM:CCARrier0:PHASe:COMPensation:AUTO OFF

EVM:CCARrier0:PHASe:COMPensation:FREQuency 0 Hz

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or the PC 
running the VSA application.
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To Optimize EVM for Multi-Carrier Waveforms

POWer:ATTenuation 0dB

[POWer:ATTenuation 2dB], …

EVM:IF:GAIN:LEVel 0dB
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To View the Results of Two Carriers

Set the top right window (Window 2) to display IQ Meas Time

DISPlay:EVM:WINDow2:DATA MTIM

Set the top right window to display Component Carrier 1

DISPlay:EVM:WINDow2:CCARrier CC1

Set the middle right window to display the FFT of the Raw Main Time waveform

DISPlay:EVM:WINDow4:DATA SPEC

DISPlay:EVM:WINDow4:CCARrier CC1

Set the bottom right window to display a table of general measurement numeric results

DISPlay:EVM:WINDow6:DATA DRES

DISPlay:EVM:WINDow6:CCARrier CC1

Set the bottom left window to display the error summary for CC0

DISPlay:EVM:WINDow5:DATA DRES
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Setting Up a 1 CC 3.5 GHz ACP Measurement

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. Set Frequency to 3.5 GHz and Amplitude to 0 dBm. 

3. Select Group 1: Signals block to open.

4. Select the arrow for Signal 1 to open the Signal Setup window.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 11 and “Setting Up Triggers on the Signal 
Analyzer using 5G NR Mode” on page 292.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples
and choose
5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DCPunctured.
wfm
then Select.
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d. Select the General tab > Enable.

6. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

7. For multi-channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

On the X-Series Signal Analyzer:

1. Select Mode Preset to set 5G NR V2X mode to a known state.

2. Select Mode/Meas > 5G NR & V2X Mode > ACP Measurement.

3. Select Frequency and set Carrier Reference Frequency to 3.5 GHz.

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 3.5GHZ

RF1:POWer:AMPLitude 0dBm

SIGNal1:MODE WAVeform

SIGNal1:WAVeform “D:\Users\Instrument\Documents\MCS demo 
waveforms\5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DCPunctured.w
fm”

SIGNal1 ON

DM:OPTimization:CHANnel ACP

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

SYSTem:PRESet

INSTrument:CONFigure: NR5G:ACP

CCARrier:REFerence 3.5GHZ

ACPower:CORRection:NOISe ON
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Using PathWave N7631APPC to Create a Waveform File then 
Automatically Configure the Analyzer to View the Results

PathWave software tools can be used to create, download, and playback 
waveforms through the VXG.

This example shows you how to create and analyze a 5G NR signal using the 
embedded PathWave software and then automatically configure the analyzer 
to make the measurement. 

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 28 GHz and Power to 
-10 dBm.

3. Select the Radio Apps block to open the mode selection panel.

4. Select 5G NR to enter the 5G NR signal mode.

5. In the 5G NR setup, select the Waveform tab and observe the Phase 
Compensation and Radio Frequency settings.

Phase Compensation is applied by default at baseband for RF 
up-conversion. This means it depends on the carrier frequency, and the 
waveform should only be played at the carrier frequency it was generated 
for, unlike conventional Signal Studio waveforms, which are independent 

The VXG must have the N7631APPC Signal Generation for 5G NR license 
installed.



M9484C VXG and X-Series SA Measurement Guide                                                                                        317

5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

from carrier frequency. Phase Compensation is set to Auto by default. The 
frequency is coupled with the VXG frequency setting. You can select 
Manual to specify a different frequency, or turn it off.

TIP Some applications, like power amplifier measurements use the same 
waveform at different frequencies and can be time consuming to generate a 
separate waveform for each frequency. In this case, you would turn Phase 
Compensation Off, so the waveform becomes independent from the carrier 
frequency. You need to do the same on the analysis side, or the demodulation 
will fail.

6. Select the Carrier tab.

7. Select Full-Filled Config and set Bandwidth to 
FR2 100 MHz, Numerology to  3:120 kHz, and Modulation to 256 QAM.

Full Filled Configurations is a great place to start creating your waveform. 
You can select FR, bandwidth, and modulation format with a fully 
allocated PDSCH data channel. This would represent a spectrally correct 

If you have a signal analyzer with demodulation bandwidth that is wide 
enough to cover the other FR2 bandwidths, 200 MHz or 400 MHz, you can 
choose to use a wider bandwidth.
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signal that is typically used in power amplifier measurements. You can 
modify the RB allocations and Slot allocations if fully allocated data 
channels are not desired.

8. Select OK to exit the Full Filled Config setup. 

9. From the Carrier panel (in the left pane), select Spectrum Control > DC 
Punctured On. 

When DC Punctured is enabled, the DC subcarrier is excluded from the 
measurement results. This is often helpful to avoid obscuring 
measurement results with artifacts of LO feedthrough.

10. From the Carrier panel (in the left pane), select Downlink > SS PBCH > SS 
PBCH Block and set Lmax to 64 and Active Indices to = 0:7.
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Instead of transmitting all 64 beams, we enable only 8 of them by setting 
Active Indices to 0:7.

11. From the Carrier panel (in the left pane), select Downlink > DL-SCH > 
DL-SCH0 > Modulation and Coding and set MCS Table to Table 5.1.3.1-2 
(256QAM) and MCS to 20.

The Modulation Coding Scheme (MCS) specifies the modulation, coding 
and overall spectral efficiency of the PDSCH as specified in 3GPP Table 
5.1.3.1.

Lmax sets the maximum number of possible SS/PBCH blocks in a transmission 
opportunity. This value is fixed for a given carrier bandwidth. Typically, higher 
frequency and bandwidth carriers use a larger set of SS/PBCH opportunities to 
support a larger set of antenna beams.Lmax is either 4 or 8 for FR1 and 64 for 
FR2. 
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12. Select Generate to generate the Waveform, and then select Home to exit 
the setup panel.

13. Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.
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Setup Auto Configure Analyzer 

1. Select the System menu (triple bar tab at the top left of the window) to 
open the System Menu and then select Configure Analyzer.

2. In the System Configuration setup, select the Remote Signal Analyzer 
block (on far right) to setup the communication channel to the Keysight 
X-Series Signal Analyzer. 

3. Set Connection Type to LAN.

4. In the Connect Remote X-Series Signal Analyzer setup, enter the 
Hostname or IP Address for the signal analyzer.

5. Under Set Protocol, select HiSLIP and use the Remote name hislip0.
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6. Select Test Connection to verify, then the Back icon to go back to the 
main Configure Analyzer display.

7. Select Auto Configure Analyzer to send the VXG settings to the analyzer. 

8.  View the results on the signal analyzer. 

The System Configuration selection brings up a screen that lets you perform a 
Generation-to-Analysis work flow. The “Auto Configure Analyzer” button will 
automatically transfer the setup from the source to a Keysight X-Series signal 
analyzer, in order to measure the desired signal from the source. If you are gen-
erating a 3GPP 5G New Radio signal, and the 5G New Radio application is 
licensed on the analyzer, the analyzer will perform demodulation of the signal. 
Otherwise, the analyzer will auto-tune on the signal being generated. The Key-
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sight X-Series Signal Analyzer requires firmware version x.24.00 or greater.

More About the 5G NR Traces

— Trace 1: shows the composite constellation diagram showing different 
modulation formats for the different channels/signals present in the 
transmitted signal. See Trace 6 (Frame Summary) for the list of channels. 
Again, when enabling BWP, SS Block is grayed out. When enabling SS 
Block, channels withing BWP are grayed out.

— Trace 2: shows the envelope of the captured raw data. This data is 
unprocessed and includes additional points acquired for settling of the 
filters involved in subsequent processing, such as the demodulation 
filtering.

— Trace 3: shows the FTT of the Raw Main Time waveform.

— Trace 4: shows the general measurement numeric results.

— Trace 5: shows the detected allocations of all channels/signals within the 
measurement interval (2 Subframes in this example).

— Trace 6: shows EVM, Power, and Number of RB of the individual 
channels/signals.

TIP The Frame Summary table shows Num. RB for PDSCH of 1056 and 1016 for 
PDSCH-DMRS. The signal configuration has only 66 RBs. The RB result in the 
Frame Summary Table is per Slot. In this example procedure, we changed the 
measurement interval to 2 Subframes, which is 16 slots for 120 kHz 
numerology (8 slots/subframe). 66 * 16 = 1056. For PDSCH-DMRS, the value 
is 1016 because two of the 16 slots overlap with the SS Block which occupies 
20 RBs resulting in 20 RBs being punctured from DMRS in these two slots. 
Therefore, the total RB Number for DMRS is 1056 - 20 * 2 = 1016.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude -10dBm

RADio:SELect NR5G

RADio:NR5G:WAVeform:CCARrier:BWIDth FR2BW100M

Select µ = 3: 120kHz:

RADio:NR5G:WAVeform:CCARrier:SNUMerology MU3

RADio:NR5G:WAVeform:CCARrier:DLINk:SSBLock:LMAX 64

RADio:NR5G:WAVeform:CCARrier:DLINk:SSBLock:ACTive:INDices 
"0:7"

RADio:NR5G:WAVeform:CCARrier:DLINk:SCH0:MCS 20

RADio:NR5G:WAVeform:CCARrier:DLINk:SCH0:MCS:TABLe TABLe52

RADio:NR5G:WAVeform:GENerate

GROup:SIGNal1 ON

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON
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6 5G NR Measurements Using the VSA Software

This section includes the following topics:

— “5G Waveform and EVM Analysis Using VSA Software” on page 326

— “Setting Up a 1 CC 28 GHz EVM Measurement” on page 326

— “Setting Up an 8 CC 28 GHz EVM Measurement” on page 339

— “Creating a Basic 5G NR Signal Using PathWave N7631APPC 
Embedded Software” on page 349

— “Creating a DL MIMO Signal Using PathWave N7631APPC Signal 
Generation” on page 369
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5G Waveform and EVM Analysis Using VSA Software
The VXG enables 5G testing with a low error vector magnitude (EVM) at high 
frequencies. The VXG has extremely good EVM at high power levels. However, 
not all signal analyzers can capture this low value. We will use the X-Series 
Signal Analyzer with the Vector Signal Analysis (VSA) software to observe EVM. 

Setting Up a 1 CC 28 GHz EVM Measurement

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. In the Output 1 area, set Frequency to 28 GHz and Power to 
5 dBm.

3. Select Group 1: Signals block to open.

4. Select the arrow for Signal 1 to open the Signal Setup window.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 11.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
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5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DCPunctured
_28GHz.wfm
then Select.

d. Select the General tab > Enable.

6. Close the Vector Modulation Signal Setup by selecting the Home icon at 
the top of the display.
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7. Select the Adjustments block and select Optimize Dynamic Range with 
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW  This setting filters the system 
RF flatness correction coefficients over the instantaneous bandwidth 
indicated in the waveform header (or in the “Occupied Bandwidth” 
settings area under the Signal block > Occupied Bandwidth setting). 
This has the potential to improve EVM performance by not having to 
correct for flatness errors outside the requested bandwidth. For 
example, if RF flatness correction was done at 2 GHz, but you are 
only interested in an 800 MHz section, then applying the correction 
flatness to that portion only can improve signal to noise ratio, and 
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction -   Disabling this function 
disables the factory calibrated RF channel flatness equalizer. 
Depending on the hardware channel response, this may hurt or 
improve the EVM. This is due to the dynamic range implications as it 
relates to signal to noise ratio. The greater the RF hardware 
variations in flatness, the greater the amount of correction is 
required, the greater the correction effectively reduces the number of 
resolution DAC bits that can be used, which degrades the signal to 
noise ratio and therefore potentially EVM. The trade-off is to balance 
between flatness and signal to noise ratio.

8.  Close the Adjustments Setup by either selecting the Back or the Home 
icon at the top of the display.

9.  Set RF Out to On by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.
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10. For two channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

On the X-Series Signal Analyzer:

1. Select Recall (If accessing the signal analyzer remotely, select the Folder 
icon at the bottom of the display) Demod Info > Set Data Type to CC Setup 
> Recall From > 

5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DC punctured_
28GHz_34.scp >Recall

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or 
the PC running the VSA application.
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2. Select Meas Setup > Meas Time and set:

— Search Length to 10 ms

— Result Length to 2 Sub Frame

— Frame Trigger to On

3. Ensure that RF for Phase Compensation Auto is not selected and the value 
is 0 Hz. Close the Advanced Settings table.

4. Select the Settings tab > Optimize EVM.

The Optimize EVM function automatically sets the combination of 
preamplification, mechanical and electronic attenuation, and IF gain based 
on the measured signal peak level. 

EVM should be less than 1%. 

On the X-Series Signal Analyzer:

— Open the VSA software by selecting Mode Meas > Launch VSA. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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In the VSA software:

1. From the menu bar, select File > Preset > All to set the VSA to a known 
state.

2. Select File > Recall > Recall Setup and navigate to 
5GNR_1CC_FR2_120kHz SCS_100MHz_256QAM_DC 
Punctured_28GHz.setx 

3. From the toolbar, select the Pause Icon. 

Pausing the measurement will help to speed up the setup time.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or the PC 
running the VSA application.
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4. From the menu bar, select Input > Trigger and set Style to External and 
Level to 1.0 V.



334                                                                                      M9484C VXG and X-Series SA Measurement Guide

5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

5. Select the Extensions tab and change the External Trigger location to 
Trigger 1 In (if using an N9040B with Option H1G, select Trigger 3) and 
Phase Noise Optimization to Best Wide Offset. 

6. From the menu bar, select MeasSetup > 5G NR Demod Properties > Time 
tab.

— Set Result Length to 10 Subframes.

— Set Meas Interval to 2 Subframes.
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— Select Frame Trigger is Present.

7. From the toolbar, select the Auto-Range dropdown and select EVM-Table 
or Algorithm Based.

— EVM - Table or Algorithm Based performs EVM optimization based 
on prescribed table/algorithm instead of using EVM in the feedback 
loop. This method of EVM auto-range is normally faster than Meas 
Based Iteration, but may not achieve the most optimal setup for 
minimized EVM).

— EVM - Meas Based Iteration has a feedback loop around the entire 
measurement, uses the measured EVM in the feedback loop, and 
tries to adjust hardware parameters to minimize the EVM. It is the 
slowest EVM auto-range method, but it should achieve the most 
optimal setup for good EVM.

8. Select the Auto-Range icon to run the measurement for EVM optimization. 
This may take a few minutes to complete.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude 5dBm

SIGNal1:MODE WAVeform

SIGNal1:WAVeform “D:\Users\Instrument\Documents\MCS demo 
waveforms 
5GNR_1CC_FR2_120kHz_SCS_100MHz_256QAM_DCPunctured_28GHz.wfm”

SIGNal1 ON

IQO:CORR:OPT:DYN:RANG:OBW ON

IQO:CORR:CHAN:FLAT ON

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

INSTrument:SELect VSA89601

SYSTem:PRESet

MMEMory:LOAD 
“D:Users\Instrument\Documentts\NR5G\data\NR5GEvm\Carrier 
Setup\5GNR_1CC_FR2_120kHz 
SCS_100MHz_256QAM_DCPunctured_28GHz.setx”

INITiate:PAUSe

INPut:TRIGger:STYle "EXTERNAL"

INPut:TRIGger:LEVel:EXTernal 1V

INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2

INPut:EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1

Set the 5G NR Demod Result Length to 10 Subframes:

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or the PC 
running the VSA application.
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NR5G:RLENgth 10

NR5G:SUBFrame:INTerval 2

Set the Acquisition Mode to “Frame Trigger is Present”

nr5g:FRAMe:TRIGger:ENABled 1
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Setting Up an 8 CC 28 GHz EVM Measurement

Using the graphical user interface

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. Set Frequency to 28 GHz and Amplitude to 5 dBm. 

3. Select Group 1: Signals block to open.

4. Select the arrow for Signal 1 to open the Signal Setup window.

Ensure the equipment and triggers are properly configured. Refer to 
“Equipment Setup” on page 11.

This screen is only accessible if Option M9484C-8SG (8 virtual signal 
generators) is installed. For all other option configurations, continue to the 
next step.
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5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples
and choose
5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_28GHz.
wfm
then Select.

d. Select the General tab > Enable.
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6.  Close the Signal Setup by selecting the Home icon at the top of the 
display.

7. Select the Adjustments block and select Optimize Dynamic Range with 
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW  This setting filters the system 
RF flatness correction coefficients over the instantaneous bandwidth 
indicated in the waveform header (or in the “Occupied Bandwidth” 
settings area under the Signal block > Occupied Bandwidth setting). 
This has the potential to improve EVM performance by not having to 
correct for flatness errors outside the requested bandwidth. For 
example, if RF flatness correction was done at 2 GHz, but you are 
only interested in an 800 MHz section, then applying the correction 
flatness to that portion only can improve signal to noise ratio, and 
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction -   Disabling this function 
disables the factory calibrated RF channel flatness equalizer. 
Depending on the hardware channel response, this may hurt or 
improve the EVM. This is due to the dynamic range implications as it 
relates to signal to noise ratio. The greater the RF hardware 
variations in flatness, the greater the amount of correction is 
required, the greater the correction effectively reduces the number of 
resolution DAC bits that can be used, which degrades the signal to 
noise ratio and therefore potentially EVM. The trade-off is to balance 
between flatness and signal to noise ratio.

8.  Close the Adjustments Setup by either selecting the Back or the Home 
icon at the top of the display.

9.  Set RF Out to On by selecting the numbered channel indicator switch. 
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This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

10. For multi-channel instruments only: In the top right corner of the display, 
set RF Out (All) to On by selecting the switch. 

On the X-Series Signal Analyzer:

— Open the VSA software by selecting Mode Meas > Launch VSA. 

In the VSA software:

1. From the menu bar, select File > Preset > All to set the VSA to a known 
state.

2. Select File > Recall > Recall Setup and navigate to 
D:Users\Instrument\Documents\NR5G\data\NR5GEvm\Carrier Setup, 
then open 
5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Corrected_1.setx 

3. From the toolbar, select the Pause Icon. 

Pausing the measurement will help to speed up the setup time.

In order to turn on RF for any channel, both the RF Out for the specific 
channel (for example, Channel 1 or Channel 2), and RF Out All must be 
turned on.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or 
the PC running the VSA application.
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4. From the menu bar, select Input > Trigger and set Style to FreeRun.

5. Select the Extensions tab and change Phase Noise Optimization to Best 
Wide Offset. (For an N9040B only, set External Trigger Location to Trigger 
3 In.)
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6. From the menu bar, select MeasSetup > 5G NR Demod Properties > Time 
tab.

— Set Result Length to 10 Subframes.

— Set Meas Interval to 2 Subframes.

7. Select the Advanced tab select DC Punctured to On.
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8. In the bottom center trace window, select the Trace Data menu and select 
Demod: > CC Summary. 

9.  In the Spectrum trace window (bottom left window), select Center and 
change the frequency to 28 GHz.

10. From the toolbar, select the Autorange dropdown and select EVM-Table 
or Algorithm Based.

— EVM - Table or Algorithm Based performs EVM optimization based 
on prescribed table/algorithm instead of using EVM in the feedback 
loop. This method of EVM auto-range is normally faster than Meas 
Based Iteration, but may not achieve the most optimal setup for 
minimized EVM).

— EVM - Meas Based Iteration has a feedback loop around the entire 
measurement, uses the measured EVM in the feedback loop, and 
tries to adjust hardware parameters to minimize the EVM. It is the 
slowest EVM auto-range method, but it should achieve the most 
optimal setup for good EVM.

11. Select the Autorange icon to run the measurement for EVM optimization 
on all eight channels. This may take a few minutes to complete.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude 5dBm

SIGNal1:MODE WAVeform

SIGNal1:WAVeform “D:\Users\Instrument\Documents\MCS demo 
waveforms\5GNR_8CC_FR2_120kHz_SCS_100MHz_Corrected_28GHz.wfm
”

SIGNal1 ON

IQO:CORR:OPT:DYN:RANG:OBW ON

IQO:CORR:CHAN:FLAT ON

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer
INSTrument:SELect VSA89601

MMEMory:LOAD:DEMO 
"D:\Users\Instrument\Documents\NR5G\data\NR5GEvm\CarrierSetu
p\1CC_FR2_120kHz SCS_100MHz_256QAM_DC Punctured_28GHz.setx"

INITiate:PAUSe

INPut:TRIGger:STYLe "External"

INPut:TRIGger:LEVel:EXTernal 1V

INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2

INPut:EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1

NR5G:RLENgth 10 

NR5G:SUBFrame:INTerval 2

NR5G:FRAMe:TRIGger:ENABled 1

NR5G:CAGGregation:CONFigure "Contiguous8CC"

NR5G:DC:PUNCtured 1

NR5G:MCFilter:ENABled 1
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FREQuency:CENTer 28 GHz

INPut:ANALog:CRITeria:RANGe:AUTO "EVM", -1 

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or 
the PC running the VSA application.
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Creating a Basic 5G NR Signal Using PathWave N7631APPC 
Embedded Software

PathWave software tools can be used to create, download, and playback 
waveforms through the VXG.

This example shows you how to create and analyze a 5G NR signal using the 
embedded PathWave software. Your VXG must include the N7631APPC 
license. 

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 28 GHz and Power to 
-10 dBm.

3. Select the Radio Apps block to open the Vector Modulation Signal Setup 
panel.

4. Select 5G NR to enter 5GNR Signal Mode.

The VXG must have the N7631APPC Signal Generation for 5G NR license 
installed.
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5. In the 5G NR setup, select the Waveform tab and observe the Phase 
Compensation and Radio Frequency settings.

TIP Phase Compensation is applied by default at baseband for RF up-conversion. 
This means the waveform generation is per the carrier frequency, unlike 
conventional Signal Studio waveforms, which are independent from carrier 
frequency. Phase Compensation is set to Auto by default. The frequency is 
coupled with the VXG frequency setting under the Instrument node. You can 
select Manual to specify a different frequency, or turn it off.

Some applications, like power amplifier measurements use the same 
waveform at different frequencies and can be time consuming to generate a 
separate waveform for each frequency. In this case, you would turn Phase 
Compensation Off, so the waveform becomes independent from the carrier 
frequency. You need to do the same on the analysis side, or the demodulation 
will fail.

6. Select the Carriers tab.

7. Select the Full-Filled Config tab and set Bandwidth to FR2 100 MHz, 
Numerology to  3: 120 kHz, and Modulation to 256QAM.

Full Filled Configurations is a great place to start creating your waveform. 
You can select FR, bandwidth, and modulation format with a fully 
allocated PDSCH data channel. This would represent a spectrally correct 

If you have a signal analyzer with demodulation bandwidth that is wide 
enough to cover the other FR2 bandwidths, 200 MHz or 400 MHz, you can 
choose to use a wider bandwidth.
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signal that is typically used in power amplifier measurements. You can 
modify the RB allocations and Slot allocations if fully allocated data 
channels are not desired.

8. Select OK to exit the Full Filled Config setup.

9. From the Carrier panel (in the left pane), select Downlink > SS PBCH > SS 
PBCH Block and change Lmax to 64 and Active Indices to = 0:7.

 Instead of transmitting all 64 beams, we enable only 8 of them be setting 
Active Indices to 0:7.

Lmax sets the maximum number of possible SS/PBCH blocks in a transmission 
opportunity. This value is fixed for a given carrier bandwidth. Typically, higher 
frequency and bandwidth carriers use a larger set of SS/PBCH opportunities to 
support a larger set of antenna beams.Lmax is either 4 or 8 for FR1 and 64 for 
FR2. 
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10. From the Carrier panel (in the left pane), select Downlink > DL-SCHs > 
DL-SCH0 > Modulation and Coding and verify that MCS Table is set to 
Table 5.1.3.1-2 (256QAM) and MCS to 20.

11. Select Generate to generate the Waveform. 

12. Select the Home icon to return to the main window and set RF Out to On 
by selecting the numbered channel indicator switch. 

This enables the RF Out for the indicated channels, in this case Channel 1 
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

— Open the VSA software by selecting Mode Meas > Launch VSA. 

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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In the VSA software:

1. From the menu bar, select File > Preset > All to set the VSA to a known 
state.

2. Set the Center Frequency to 28 GHz > Span to 100 MHz, then select Auto 

Range.

Auto Range samples the current input signal and then sets the full scale 
input range to the minimum range that includes the peak voltage sample 
of the input signal.

3. From the toolbar, select the Pause Icon. 

TIP Pausing the measurement will help to speed up the setup time.
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4. From the menu bar, select Input > Trigger and set Style to External and 
Level to 1.0 V.
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5. Select the Extensions tab and change the External Trigger location to 
Trigger 1 In or Trigger 3 In (Use Trigger 3 if your N9040B has Option H1G, 
1 GHz BW) and set Phase Noise Optimization to Best Wide Offset. 

6. From the menu bar, select MeasSetup > Measure Type Cellular > 5G NR > 
5G NR Modulation Analysis.

7. From the menu bar, select MeasSetup > 5G NR Demod Properties > 
Configuration tab. 

TIP Use Quick Setups for convenient saving and loading of common 
configurations. Quick Setups are factory supplied configurations and cannot 
be deleted by users. (This includes Signal Studio Downlink and Uplink 
defaults.)
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Save As Quick Setup (saved by the user) can be specific to the current user or 
can be made available to others users. These setups can also be deleted.

8. Select the Carrier panel. 

The Carrier dialog is used to configure component carrier level 
parameters: Cell ID, Bandwidth, and Resource Grid for each Numerology.

— Set Cell ID to 0

When the checkbox is selected, Cell ID auto-detection is enabled 
for the carrier.

— Set Bandwidth to FR2 100 MHz

9. Select the Bandwidth panel and set Numerology to  3: 120 kHz

For FR2 100 MHz, the Max RB for 120 kHz numerology is 
66 RB. This value will be used when we configure BWP, SS/PBCH, and 
PDSCH.

Cell ID is carried on PSS and SSS so the SS/PBCH must be transmitted 
and enabled for Auto Cell ID to work. It must also be a downlink since 
SS/PBCH is only transmitted on a downlink.
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FR2 only uses 60, 120, or 240 kHz numerologies. This is why 15 and 
30 kHz numerologies do not show under the Resource Grid.

10. Select the BWP pane, then enable DL-BWP.

This section is used to configure the Downlink BWP allocation within the 
component carrier and the control resource set (CORESET). CORESET is 
used for PDCCH configuration and will not be used in this example. We 
will use the default values of:

— Numerology  120 kHz

— RB offset 0 RB

— RB Number 66 RB
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A component carrier with 100 MHz at FR2 has a maximum RB of 66 
for 120 kHz numerology. In this example, DL-BWP uses the full 
carrier bandwidth of 66 RBs as shown below.

TIP VSA supports a single BWP within a component carrier (CC). Signal Studio 
and X-Apps support multiple BWPs within a CC. You can use VSA 
multi-measurement to analyze multiple BWPs simultaneously. 

11. Select the Channel pane > SS/PBCH, enable SS/PBCH and set the 
following parameters:

— Lmax to L64

Lmax specifies the maximum number of SS/PBCH Blocks (that is, 
beams) in an SS Block period. 

— FR1 up to 3 GHz, Lmax = 4

— FR1 3 to 6 GHz, Lmax = 8

— FR2 6 to 52.6 GHz, Lmax = 64

— SSB Transmitted to 0:7
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For this example, we will not use all 64 SS Blocks; we will activate 
only 8 of them. You can also select the Auto Detect Active Block 
and set the Det Power Threshold to auto detect the active SS 
Blocks. 

These following settings use the default values.

— RB Offset(60kHz) = 46 RB

— kSSB(60kHz) = 0

— Periodicity = 10 ms

— Numerology =  120 kHz
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The frequency location of an SS Block is not fixed. The default value of 46 
RB and kSSB of 0 subcarriers places it in the center of the carrier 
bandwidth. This value is calculated based on the 60 kHz numerology as 
defined by 3GPP (15 and 30 kHz sub-carrier spacing uses 15 kHz 
numerology, 120 and 240 kHz spacing uses 60 kHz numerology.)

For example, to calculate the 120 kHz sub-carrier spacing, the value 
would be 

66RB/2 = 33 RB

This is the center of the carrier bandwidth. However, the SS Block is 
20 RB wide, so the start of the SS Block is 23 RB.

23 RB in 120 kHz is 23 * 2 = 46 RB in 60 kHz 

This is the default value used in the VSA software for 120 kHz numerology. 

12. From the Channel pane, select PDSCH and then set the following 
parameters: 

— Under Modulation and Config section, set MCS Table to Table 
256QAM and MCS to 20.
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TIP 3GPP has different Tables for PDSCH MCS. 

Table 5.1.3.1-2 has 256 QAM as maximum modulation

Table 5.1.3.1-3 has 64 QAM as maximum modulation

Table 5.1.3.1-1 has 64 QAM as maximum modulation, and is for low 
spectrum efficiency (LowSE). 

See 3GPP TS38.214 for more information.

— Under the Time/Freq Allocation section, set

— Allocated Slots to 0:79

— Slot Format to 0

— First Symbol to 0

— Last Symbol to 13

— RB Offset to 0 RB

— RB Number to 66 RB
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We will use the default values for RS Sequence, Power Boosting, and 
Antenna Port. Power s would not change the DMRS sequences, but they 
might be interested in modifying Power Boosting.

13. Select the Time tab and set:

— Result Length to 10 Subframes.

— Meas Interval to 2 Subframes.

— Select Frame Trigger is Present.

14. Select the Advanced Settings tab and select DC Punctured.

5G NR counts the DC subcarrier as a valid subcarrier for rate-matching 
purposes. The network decides if the DC subcarrier is modulated or not. 
High LO feedthrough will impact demodulation and EVM performance of 
the input signal. This setting is off by default.

Use Extend Frequency Lock Range if you cannot lock to the input signal.

Compensate Symbol Clock Offset is used along with timing track to 
compensate for clock error in the input signal. The Symbol Clock Error 
result is reported in the Summary trace.
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3GPP Conformance Test > Phase  is enabled by default. It is specified in 
the 3GPP requirement and is used to compensate for phase differences 
between symbols caused by up conversion or down conversion. Getting 
this setting wrong will cause demod issues. 

15. From the menu bar, select Window > Trace Layout > Tile Visible.

This will display all six 5G NR traces on the display.

16. Select the Auto-Range icon to run the measurement for EVM 
optimization. This may take a few minutes to complete.
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TIP The VSA has color coding based on channel type, marker coupling to pinpoint 
error, symbol level analysis (by changing the measurement interval, and 
measurement offset into a single symbol).

More About the 5G NR Traces

— Trace A: shows the composite constellation diagram showing different 
modulation formats for the different channels/signals present in the 
transmitted signal.

— Trace B: shows the frequency spectrum.

— Trace C: shows the composite error metrics. You can also see the 
automatically detected Cell ID value and the Channel Power.

— Trace D: shows the EVM versus subcarrier and symbol.

— Trace E: shows the detected allocations of all channels/signals within the 
measurement interval. (For this example, 2 Subframes) You can see the 8 
active SS Blocks in the first four slots.

— Trace F: shows the frame summary: EVM Power per RE, Modulation format, 
Number of RB and RTNI of the individual channels/signals.

For more information on these traces, see the Online help.
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Trace Filtering

The VSA has per-trace filtering to filter by subsegments and channels. 
Subsegment refers to Layers, (in case of MIMO), BWP, and SS Block. In the 
downlink, Layers in DL-BWP and SS Block are presented as subsegments. In 
the uplink, Layers in UL-BWP are presented as subsegments.

The following traces can be filtered by subsegments and channel types.

— OFDM Meas

— OFDM Ref

— Error Vector Spectrum

— Error Vector Time

— Detected Allocations Time trace can be filtered per channel only

The rest of the traces do not support per-trace filtering. 

A Simple Example

We will apply per-trace filtering to Error Vector Spectrum (Trace D) and 
Detected Allocations Time (Trace E) traces.

1. From the menu bar, select Trace > Digital Demod.

2. In the Trace Dialog, select Trace D (OFDM Error Vector Spectrum) from the 
dropdown.

3. In the Filtered SubSegments area, clear the Layer0 check box.
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This allows you to take a look at SS Block. You can also filter with SS 
Block Channels/Signals you want to see by using the Filtered Channel 
Type.

4. Select Trace E (OFDM Detected Allocations Time) from the Trace dialog.

5. In the Filtered SubSegments area, clear the SS Block0 check box.

This alloys you to look at Layer 0 information, which is the DL-BWP 
information. 

6. In the Filter Channel Types area, Clear All selections, then select just 
PDSCH-DMRS. 

You now see a gap in two of the DMRS symbols. Why is this?

Notice that the Frame Summary table shows Num. of RBs for PDSCH of 
1056 and 1016 for PDSCH-DMRS. The signal configuration only had 66 
RBs. Why the change in the measurement result?

The RB result in the Frame Summary table is per Slot. In this example, we 
changed the measurement interval to 2 Subframes, which is 16 slots for 
120 kHz numerology (8slots/subframe). 66*16=1056. For PDSCH-DMRS, 
the value is 1016 because of the 16 slots overlap with the SS Block, which 
occupies 20 RBs. This results in 20 RBs being punctured from DMRS in 
these two slots, so the total RB Number for DMRS is 1056-20*2 = 1016.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude -10dBm

RADio:SELect NR5G

RADio:NR5G:WAVeform:CCARrier:BWIDth FR2BW100M

RADio:NR5G:WAVeform:CCARrier:SNUMerology MU3

RADio:NR5G:WAVeform:CCARrier:DLINk:SSBLock:LMAX 64

RADio:NR5G:WAVeform:CCARrier:DLINk:SSBLock:ACTive:INDices 
"0:7"

RADio:NR5G:WAVeform:CCARrier:DLINk:SCH0:MCS 20

RADio:NR5G:WAVeform:CCARrier:DLINk:SCH0:MCS:TABLe TABLe52

RADio:NR5G:WAVeform:GENerate

GROup:SIGNal1 ON

RF1:OUTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALl:OUTPut ON

On the X-Series Signal Analyzer:

INSTrument:SELect VSA89601

SYSTem:PRESet

FREQuency:CENTer 28 GHz

INPut:ANALog:RANGe:AUTO

INITiate:PAUSe

INPut:TRIGger:STYLe "External"

INPut:TRIGger:LEVel:EXTernal 1V

INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2 (This will 
set it to Trigger 3)

NR5G:FRAMe:TRIGger:ENABled 1

INPut:EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1

MEASure:CONFigure NR5G
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NR5G:CCARrier:CIDentity:AUTO 1 |OR| NR5G:CCARrier:CIDentity 
0

NR5G:CCARrier:TBANdwidth "FRTwo100MHz"

NR5G:DBWP:ENABled 1

NR5G:DBWP:NUMerology "Mu3"

NR5G:DBWP:ROFFset 0

NR5G:DBWP:RNUMber 66

NR5G:SSBLock:ENABled 1

NR5G:SSBLock:LMAX "L64"

NR5G:SSBLock:AINDexes "0:7"

NR5G:DBWP:PDSCh1:MCS:TABLe "Table2"

NR5G:DBWP:PDSCh1:MCS 20

NR5G:DBWP:PDSCh1:SLOT:ALLocated "0:79"

NR5G:CCAR:PDSCH1:SFI 0

NR5G:CCAR:PDSCH1:SINDex:FIRSt 0

NR5G:CCAR:PDSCH1:SINDex:LAST 13

NR5G:CCAR:PDSCH1:ROFFset 0

NR5G:CCAR:PDSCH1:RNUMber 66

NR5G:RLENgth 10 

NR5G:SUBFrame:INTerval 2

NR5G:FRAMe:TRIGger:ENABled 1

NR5G:DC:PUNCtured 1

NR5G:MCFilter:ENABled 1

NR5G:FREQuency:LOCK:EXTended 1

NR5G:COMPensate:SYMBol:CLOCk:OFFset 1

DISPlay:LAYout 3,2 

INPut:ANALog:CRITeria:RANGe:AUTO "EVM", -1
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Creating a DL MIMO Signal Using PathWave N7631APPC Signal 
Generation

This procedure will show you how to configure and analyze a downlink (DL) 
multiple input, multiple output (MIMO) signal using PathWave Signal 
Generation and the 89600 VSA software. The hardware setup below includes a 
2-channel VXG signal generator and a 2+ channel, 33 GHz or higher Infiniium 
UXR-Series Oscilloscope.

TIP If you do not have access to a Keysight Infiniium UXR Real-Time Oscilloscope, 
a UXR recording waveform file has been included in the Example waveform 
file folder:

 D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy the 5GNR_UXR_Recording_28GHz.sdf file to the 
X-Series Signal Analyzer or the PC running the VSA application. Steps have 
been included below to successfully run the recording.

Hardware Requirement

— 2 channel M9484C VXG

— UXR with DDC option:

— UXR000-601: 160 MHz BW or

— UXR000-602: 2 GHz BW

Hardware accelerated DDC decimates oscilloscope captures in real-time 
enabling deep captures and fast measurement speed.

Software Requirements

Equipment Setup for the M9484C

— M9484B CH1 front panel RF Out to UXR front panel CH1

— M9344B CH2 front panel RF Out to UXR front panel CH3

— M9484C front panel Channel 1 Event 2 to UXR rear panel Aux Trig In

The VXG must have the N7631APPC Signal Generation for 5G NR license 
installed.

PathWave Signal Generation for 5G NR N7631APPC Use latest release from Keysight.com

89600 VSA software 89601BHNC VSA2023U2 or later
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— M9484C rear panel 10 MHz Out to UXR rear panel 10 MHz Ref In.

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

If a Synchronization Alignment is required, indicated by  in the 
bottom left corner, tap or click the warning message and choose Perform 
Alignment before proceeding.
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2. In the Menu/Tool Bar, select the Triple Bar icon (top left corner of the 
display, and then select Configure Channels. Change the signal 
configuration from Independent to 2 Tx Coherent > Add > Apply > Apply.

3. In the Output area for both Channel 1 and Channel 2, set Frequency to 
28 GHz, or the frequency you are using, and Power to 0 dBm.

4. Select the Apps block to open, then select 5G NR.
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5. Select the Waveform tab and set the Total Number of Antennas 2. This 
means that two antenna port signals will be generated.

6. Select the Carriers tab > Cell Specific node, and set Bandwidth to FR2 
100 MHz. Keep the rest of the default settings. 

7. Select the Downlink node > SS/PBCH > RB Offset by 60 kHz SCS and set 
to 0.
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This automatically changes the Delta Frequency to Carrier Center to 
-33.12 MHz. Using 0 RB Offset puts the SSB at the lower edge of the 
carrier.

8. Select the Downlink node > DL-SCH> Transmission Settings and confirm 
DMRS ports is set to 0,1. Set Number of DMRS CDM groups without data 
to 2.

You will see the layer number is updated to 2 and each layer is assigned 
with a particular DMRS port. You'll also see that Antenna Ports Generated 
is automatically set to P0,P1, which will map the multiple antenna port 
signals to different antennas (instruments). 

9.  Select the Resource Allocation node and set:

— Allocated Slots to 2:79

— RB Offset to 20

— RB Number to 20
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DL-SCH0 will occupy the RBs 20-40 and DL-SCH1 will occupy the rest of 
the resources.

10. Select the Modulation and Coding node and set:

— MCS to 20

— MCS Table to 5.1.3.1-2 (256 QAM)

Notice that modulation is updated to 256 QAM. 

11. Select the DMRS Settings node and notice that DMRS Power Boosting is 
set to 3 dB.
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When CDM Group Number is 2, DMRS power boosting becomes 3 dB per 
3GPP.

12. Under the DL-SCH 0 node, select the + icon to add a new +DL-SCH 
(DL-SCH1).
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13. From the Channels node, select DL-SCH > DL-SCH1 > Transmission 
Settings and set DMRS port(s) to 0,1. Change the Number of DMRS CDM 
groups without data to 2.

This will create a conflict between DL-SCH0 and DL-SCH1. This will be 
resolved in a later step.
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Notice that Number of Layers is updated to 2 and each layer is assigned 
with a particular DMRS port. Antenna Ports Generated is automatically 
assigned P0,P1, which will map generated multiple antenna port signals 
to different antennas (instruments). 

14. Select the Resource Allocation node and set:

— Allocated Slots to 2:79

— RB Offset to 45

— RB Number to 18
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Notice that this resolves the conflict between DL-SCH channels. (The pink 
shading is removed from the Channel Allocation graph. To clear the 
conflict error message at the bottom of the display, select the Message 

icon  (bottom, right corner) and select Clear.

15. Select the Modulation and Coding node, and set MCS to 20. 

Use the default MCS Table to Table 5.1.3.1-1 (64QAM). You will see the 
modulation is updated to 64QAM.
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16. Select the Waveform tab > Marker and notice that Marker 2 Source is set 
to Frame Start. Select Generate. 

17. In the bottom panel, select Spectrum.

You should see a spectrum like the one below.

18. Return to the Carriers tab and select Export 89600 VSA Setup. Save the 
.setx file to a USB drive to transfer to the VSA. We will also set up the 
89600 VSA manually in the next section.
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19. Select the Home icon and set RF Out to On by selecting the numbered 
channel indicator switches, and then select RF Out (All) master control 
switch to turn the RF output On for both channels or off for both channels.

To Setup the VSA Using the Infiniium UXR Real Time Scope

To analyze the signal using the VSA on the UXR307944

1. Open the VSA software. 

To access the VSA software, go to the Windows Start menu and find 
Keysight 89600 Software (latest installed version) folder and run the 
software.

There are two different VSA setup process. 

— If you have access to a Keysight Infiniium UXR Real Time Scope continue to the 
first step below.

— If you do not have access to a Keysight Infiniium UXR Real-Time 
Oscilloscope, a UXR recorded waveform file has been included in the 
Example waveform file folder of the VXG. Go to “To setup the VSA Using 
a UXR Recorded Waveform File” on page 401

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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2. From the VSA menu bar, select File > Preset > All to set the VSA to a 
known state.

3. To configure the hardware, go to Utilities > Hardware > Configurations.

If it is already configured, go to step 10.

4. Open the Discovered Instruments tab and verify that the UXR is listed, if 
not, select the Rediscover Instruments icon.

5. In the Configuration tab, select the + icon.
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6. Scroll down the Possible Logical Instruments and select Keysight/Agilent 
Infiniium Series Oscilloscope, and then select the right arrow to move it 
under Configuration. 

7. From the middle of the dialog box, select the UXR to be used.

8. Select OK to create the UXR configuration.
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9. In the Configurations tab, set the Current Analyzer Configuration, select 
the Analyzer number for the new configuration. In this example Analyzer 3.

The following steps perform the exact same function as loading the setup 
file you exported the VSA Setup File. At this point you can follow the steps 
below, or simply select File > Recall > Recall Setup and select the file you 
saved to the VXG.
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10. From the menu bar, select Input > Channels > RF > 2 Channels.

11. Set the center frequency of both channels to 28 GHz, or the frequency 
you are using, and span to 100 MHz.

You can also set the frequency and span of both channels under Meas 
Setup > Frequency.

If you are using a UXR, Select Autorange . 

Auto Range samples the current input signal and then sets the full scale 
input range to the minimum range that includes the peak voltage sample 
of the input signal.
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12. From the menu bar, select Input > Trigger and set:

— Style to External

— Level to 1 V

13. From the menu bar, select MeasSetup > Measurement Type > Cellular > 
5G NR > 5G NR Modulation Analysis.

14. Change the trace layout to Grid 2x3.
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TIP To improve setup speed, Pause the measurement until all parameters are 
correctly configured, then run the measurement.

15. Select MeasSetup > 5G NR Demod Properties > Configuration tab and set 
that Bandwidth FR2 100 MHz, Carrier Center and Frequency for Phase 
compensation are set to 28 GHz. Select the Cell ID checkbox.

Cell ID is carried on PSS and SSS so that SS/PBCH must be transmitted 
and enabled for Auto Cell ID to work and must be a Downlink since 
SS/PBCH is only transmitted in the DL.

Phase compensation is per the 3GPP requirement, and is enabled by 
default. It is used to compensate for phase differences between symbols 
caused by upconversion or downconversion. Getting this setting wrong 
will cause a demod issue. For this example, it is ON and it is applied at the 
center frequency. 

16. Select the Bandwidth pane and confirm that numerology is set to 
 3:120 kHz. 
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The Bandwidth panel is used to configure the Resource Grid for each 
Numerology. Note that for FR2 100 MHz, the Max RB for 120 kHz 
Numerology is 66 RB. We will use this value when we configure the 
PDSCH parameters.

17. Select the BWP pane and confirm that DL-BWP ID 1 is enabled.



388                                                                                      M9484C VXG and X-Series SA Measurement Guide

5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

For each BWP allocation, configure the numerology (µ) and RB allocation 
information. In this example, we will use the default 120 kHz numerology, 
RB Offset = 0 and RB number = 66 RB for a 100 MHz bandwidth signal.

18. Select the Channel pane > SS/PBCH and set:

a. RB Offset (60 kHz) to 0 RB 

b.  Periodicity to 10 ms

c. Lmax to L64

d. SSB Transmitted to 0:3

For this example we will use 4 of the 64 SS/PBCH Blocks (beams). In an 
SSBlock, the period is different fr the different numerologies.

— FR1 up to 3 GHz, L=4

— FR1 3 GHz to 7.125 GHz, L8

— FR2-1, FR2-2, L = 64
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The frequency location of an SSBlock is not fixed. In the VSA software, a 
default value of 46 RB and kSSB of 0 subcarriers places it in the center of 
the carrier bandwidth. Using 0 RB Offset puts the SSB at the lower edge 
of the carrier. 

19. To configure the PDSCH0, select the PDSCH pane and for PDSCH 0, set:

— MCS Table to Table 256 QAM

— MCS to 20

3GPP has different Tables for PDSCH MCS.

— Table 5.1.3.1-1 has 64QAM as max modulation

— Table 5.1.3.1-2 has 264QAM as max modulation

— Table 5.1.3.1-4 has 1024QAM as max modulation

— Table 5.1.3.1-3 has 64QAM as max modulation and is for 
low spectrum efficiency (LowSE). See 3GPP TS38.214 for 
more information.

— Allocated Slots to 2:79

— RB Offset to 20 RB
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— RB Number to 20 RB

20. Scroll down and select the Antenna Port dropdown and set:

— Antenna Ports Used,1 to 0:1

— DMRS CDM Group(s) without data to 2 (to match the PathWave 
setup)

21. Under the RS Sequence dropdown, we will use the default settings for 
DMRS and PTRS. However, this is where you would change the RS 
settings.

22. Select the Power Boosting dropdown and verify that DMRS Power 
Boosting has automatically been set to 3 dB.
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When "DMRS CDM group without data" is set to 2, the DMRS power 
boosting becomes 3 dB per 3GPP definition. 

23. To add and configure PDSCH1, select Add PDSCH. 

24. Select PDSCH1 and set:

— MCS Table to Table 64 QAM

— MCS to 20

— Allocated Slots to 2:79

— RB Offset to 45 RB
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— RB Number to 18 RB

25. Scroll down and open the Antenna Port dropdown and set:

— Antenna Ports Used to 0:1

— DMRS CDM group(s) without data to 2.



 M9484C VXG and X-Series SA Measurement Guide                                                                                      393  

5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

26. Select the Power Boosting dropdown and verify that DMRS Power 
Boosting is set to 3 dB. 

Now you should see the demodulated signal and EVM results per layer in 
the Frame Summary for PDSCHO and PDSCH1.

27. To configure the Analysis region, select the Time tab and set:

— Result Length to 5 Subframes

— Meas Interval to 2 Subframes

— Enable Frame Trigger is present. 
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We are using an external trigger for this example so selecting Frame 
Trigger is Present will use the external trigger and will speed up the 
measurement significantly. If not using an external trigger, set to 
Normal.

TIP To improve setup speed

Live measurement:

— Use external frame trigger and enable Frame trigger is 
present. The real frame boundary must be within ±50 s of 
the external trigger.

— If external frame trigger is not available, use Reduced 
acquisition length. The reduced acquisition length may fail 
to synchronize in scenarios where > 1 frame SSB 
periodicity are defined, unless hardware triggering is used.

— Change Analysis Start Boundary to Subframe.

— Reduce Result Length and Measurement Interval.

Playback mode

— Reduce the Result Length and Measurement Interval.

— Set Analysis Start Boundary to Subframe.

— Reduce the number of active traces.
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28. To configure the PBCH and PDSCH decoding, select the Decode tab and 
set.

— PBCH Decode to Decoded TB

— PDSCH Decode to Decoded TB

— PDSCH Decoder Algorithm to Offset Min Sum (default)

For successful PDSCH decoding (i.e. CRC pass), make sure the RNTI 
values (used for scrambling) and Transport Block Size matches between 
the transmitted signal and VSA. (Transport block size depends on MCS 
table, MCS value, TB Scaling Factor S, and xOverhead under PDSCH 
channel setting). 

29. Select the Advanced tab and select the DC Punctured check box. 

As part of conformance test, 3GPP has defined different equalizer training 
and tracking for EVM measurements. 3GPP Conformance Test is enabled 
by default where Tracking, Equalizer Training and EVM Window, and 
Symbol Timing is applied per 3GPP conformance test requirement. For 
FR1, no tracking is applied. For FR2, Phase Tracking using PTRS is applied.

VSA2023U2 or later releases support a user selectable Decoder Algorithm. 

Offset Min-Sum (Default) - Specifies the layered belief propagation 
algorithm with offset min-sum approximation. This is faster but less 
accurate than Belief Propagation.

Belief Propagation - Specifies the belief-passing or message-passing 
algorithm. This is better for accuracy but slow. Use for receiver sensitivity 
test where the SNR is very small.
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5G NR counts the DC subcarrier as a valid subcarrier for rate-matching 
purposes. The network decides if the DC subcarrier is modulated or not. 
High LO feedthrough will impact demodulation and EVM performance of 
the input signal. This is OFF by default.
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30. Close the 5G NR Properties dialog, start and new sweep to update the 
display, then view the results.

— Trace A: Composite constellation diagram showing different 
modulation formats for the different channels/signals present in the 
transmitted signal. See Trace F (Frame Summary) for the list of 
channels and modulation formats. 

— Trace C: Summary trace showing composite error metrics.

— Trace D: Error Vector Spectrum showing EVM versus subcarrier and 
symbol.

— Trace E: Detected Allocations Time showing the detected 
allocations of all channels/signals within the measurement interval.

— Trace F: Frame Summary. EVM, per Layer EVM, Power per RE, Mod 
Format, Number of RB, RNTI, and BWP ID of the individual 
channels/signals.

One of the most powerful tools in the 89600 VSA is the coupling of 
markers across different measurements, traces, and domains. Coupled 
markers allow you to understand the identity and characteristics of a 
symbol simultaneously in time, frequency, and error.

Place a marker on Traces A, D, and E and couple the markers (Markers > 
Couple Markers), and then show the results in a markers window (Window 
> Markers).
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Right click on Trace D and select Peak. The exact symbol associated with 
this peak EVM can now be understood in terms of time domain symbol 
index, frequency domain subcarrier number, channel type, modulation 
format, IQ magnitude, and phase values. Other parameters are shown in 
the Marker window.

Change the traces so you can see the Constellation diagram, MIMO Info 
table, Frame Summary Table (or Slot Summary Table), Summary table, 3D 
Power, Decoded Info plus any additional traces.

— Trace C: MIMO Info table shows EVM, power, and time, frequency 
and phase offset for each antenna port.

MIMO Info is a type of Matrix Table that provides sortable rows by column, 
selectable column visibility, and copy/paste and export functionality to 
share rows of content or complete tables to applications like email, text 
editing or spreadsheet programs.

— Trace E: 3D trace showing resource element (RE) power per symbol 
and per subcarrier. This is very useful when verifying base station 
systems, for example, to make sure the power per each RE is 
balanced. You can use a marker to read the power and channel 
information. A marker on this trace cannot be coupled with other 
traces. 

— Press the mouse wheel and rotate the wheel forward to 
zoom in, backward to zoom out.

— Hold left-click of the mouse for panning. Note: If marker is 
enabled (i.e. not a normal pointer), you will need to hold 
Alt in order to pan.
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— Use right click to auto scale, enable the marker, and 
change the display to different axes.

— Trace F: The Decoded Info table provides CRC pass/fail for PDSCH 
and PBCH plus the high layer information that is carried on PBCH.

If CRC of PDSCH fails, make sure the Transport Block Size matches 
between the transmitted signal and VSA (this depends on MCS 
table, MCS value, TB Scaling Factor S, and xOverhead under PDSCH 
channel setting). Also, make sure the RNTI values match since RNTI 
is used for scrambling.

Result and Display Filtering

Meas Setup > NR Demod Properties > Configuration tab > Results & Filters 
panel.

You can try to change colors of some of the channels, and/or filtering out 
all channels/signals except for SSBlock (PSS, SSS & PBCH) etc.
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Clear (Uncheck)  "Inactive" and "DC" to remove the inactive resources 
(subcarriers, symbols) and the DC subcarrier from the display and see the 
change in the 3D plot:

You can now auto-scale the 3D plot and only see the active 
channels/signals being displayed. 

Per-Trace Filtering

Trace > Digital Demod

In addition to the Results & Filters, VSA also has per-trace filtering to 
filter by subsegments and/or channels. Subsegment means MIMO Layers, 
BWP and SSBlock.

The following traces can be filtered by subsegments:

— OFDM Meas

— OFDM Ref

— Error Vector Spectrum

— Error Vector Time
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— Detected Allocations Time trace

To setup the VSA Using a UXR Recorded Waveform File

1. Open the VSA software. 

To access the VSA software, go to the Windows Start menu and find 
Keysight 89600 Software (latest installed version) folder and run the 
software.

2. From the VSA menu bar, select File > Preset > All to set the VSA to a 
known state.

3. To configure the hardware, go to Utilities > Hardware > Configurations.

If it is already configured, continue with step 9.

If accessing the instrument via a Remote Desktop connection, select the 
Screen tab (at the top of the display) to open the 
Mode/Measurement/View Selector window. 
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4. In the Configuration tab, select the + icon.

5.  In the New Hardware Configuration dialog, select Simulate Hardware 
and scroll down the Possible Logical Instruments and select 
Keysight/Agilent Infiniium Series Oscilloscope, and then select the right 
arrow to move it under Configuration. 

6. From the middle of the dialog box, select the UXR to be used.

7. Select OK to create the UXR configuration.
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8. In the Configurations tab, set the Current Analyzer Configuration, select 
the Analyzer number for the new configuration. In this example Analyzer 3.

9. If you do not have access to a Keysight Infiniium UXR Real-Time 
Oscilloscope, a UXR recorded waveform file has been included in the 
Examples waveform file folder on the VXG. 

Go to: D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

Copy the MIMO_UXR_Recording.sdf file to the signal analyzer or the PC 
running the VSA application.

10. From the Menu Bar, select File > Recall > Recall Recording and select 
MIMO_UXR_Recording.sdf.

Recalling the recording will setup all of the parameters described below. If 
you want to become familiar with the VSA setup, continue on with the 
remaining steps. 
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11. From the menu bar, select Input > Extensions > Sample Mode >FullRate 
DDC.

12. From the menu bar, select Input > Channels > RF > 2 Channels.

13. Set the center frequency of both channels to 28 GHz and span to 
100 MHz.

You can also set the frequency and span of both channels under Meas 
Setup > Frequency.
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If you are using a UXR, Select Autorange . 

Auto Range samples the current input signal and then sets the full scale 
input range to the minimum range that includes the peak voltage sample 
of the input signal.

14. From the menu bar, select MeasSetup > Measurement Type > Cellular > 
5G NR > 5G NR Modulation Analysis.

15. Change the trace layout to Grid 2x3.

Autorange does not work if you are simulating the waveform with the UXR 
recording. Continue with the next step.
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16. Select MeasSetup > 5G NR Demod Properties > Configuration tab and set 
Bandwidth to FR2 100 MHz, Carrier Center and Frequency for Phase 
compensation are set to 28 GHz. Select the Cell ID checkbox.

Cell ID is carried on PSS and SSS so that SS/PBCH must be transmitted 
and enabled for Auto Cell ID to work and must be a Downlink since 
SS/PBCH is only transmitted in the DL.

Phase compensation is per the 3GPP requirement, and is enabled by 
default. It is used to compensate for phase differences between symbols 
caused by upconversion or downconversion. Getting this setting wrong 
will cause a demod issue. For this example, it is ON and it is applied at the 
center frequency. 

17. Select the Bandwidth pane and confirm that numerology is set to 
 3:120 kHz. 
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The Bandwidth panel is used to configure the Resource Grid for each 
Numerology. Note that for FR2 100 MHz, the Max RB for 120 kHz 
Numerology is 66 RB. We will use this value when we configure the 
PDSCH parameters.

18. Select the BWP pane and confirm that DL-BWP ID 1 is enabled.
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For each BWP allocation, configure the numerology (µ) as well as RB 
allocation information. In this lab, we will use the default 120 kHz 
numerology, RB Offset = 0 and RB number = 66 RB for a 100 MHz 
bandwidth signal.

19. Select the Channel pane > SS/PBCH and set:

a. RB Offset (60 kHz) to 0 RB 

b.  Periodicity to 10 ms

c. Lmax to L64

d. SSB Transmitted to 0:3

 For this example we will use 4 of the 64 SS/PBCH Blocks (beams). In an 
SSBlock, the period is different fr the different numerologies.

— FR1 up to 3 GHz, L=4

— FR1 3 GHz to 7.125 GHz, L8

— FR2-1, FR2-2, L = 64



 M9484C VXG and X-Series SA Measurement Guide                                                                                      409  

5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

The frequency location of an SSBlock is not fixed. In the VSA software, a 
default value of 46RB and kSSB of 0 subcarriers places it in the center of 
the carrier bandwidth. Using 0 RB Offset puts the SSB at the lower edge 
of the carrier. 

20. To configure the PDSCH0, select the PDSCH pane and for PDSCH 0, set:

— MCS Table to Table 256 QAM

— MCS to 20

3GPP has different Tables for PDSCH MCS

— Table 5.1.3.1-1 has 64QAM as max modulation

— Table 5.1.3.1-2 has 264QAM as max modulation

— Table 5.1.3.1-4 has 1024QAM as max modulation

— Table 5.1.3.1-3 has 64QAM as max modulation and is for 
low spectrum efficiency (LowSE). See 3GPP TS38.214 for 
more information.

— Allocated Slots to 2:79

— RB Offset to 20 RB
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— RB Number to 20 RB

21. Scroll down and select the Antenna Port dropdown and set:

— Antenna Ports Used,1 to 0:1

— DMRS CDM Group(s) without data to 2 (to match the PathWave 
setup)

22. Under the RS Sequence dropdown, DMRS and PTRS are default settings, 
but this is where you would change the RS settings.

23. Select the Power Boosting dropdown and verify that DMRS Power 
Boosting has automatically been set to 3 dB.
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When "DMRS CDM group without data" is set to 2, the DMRS power 
boosting becomes 3 dB per 3GPP definition. 

24. To add and configure PDSCH1, select Add PDSCH. 

25. Select PDSCH1 and set:

— MCS Table to Table 64 QAM

— MCS to 20

— Allocated Slots to 2:79

— RB Offset to 45 RB
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— RB Number to 18 RB

26. Scroll down and open the Antenna Port dropdown and set:

— Antenna Ports Used to 0:1

— DMRS CDM group(s) without data to 2.
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27. Select the Power Boosting dropdown and verify that DMRS Power 
Boosting is set to 3 dB. 

28. To configure the Analysis region, select the Time tab and set:

— Result Length to 5 Subframes

— Meas Interval to 2 Subframes

— Enable Frame Trigger is present. NOTE: if using the UXR recording, 
leave Frame Trigger set to Normal. 
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The example measurement above uses an external trigger thus we 
would use Frame Trigger is Present to speed up the measurement 
significantly. If not using an external trigger or are using the UXR 
recording, set to Normal.

TIP To improve setup speed

Live measurement:

— Use external frame trigger and enable Frame trigger is 
present. The real frame boundary must be within ±50 s of 
the external trigger.

— If external frame trigger is not available, use Reduced 
acquisition length. The reduced acquisition length may fail 
to synchronize in scenarios where > 1 frame SSB 
periodicity are defined, unless hardware triggering is used.

— Change Analysis Start Boundary to Subframe.

— Reduce Result Length and Measurement Interval.

Playback mode

— Reduce the Result Length and Measurement Interval.

— Set Analysis Start Boundary to Subframe.
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— Reduce the number of active traces.

29. To configure the PBCH and PDSCH decoding, select the Decode tab and 
set.

— PBCH Decode to Decoded TB

— PDSCH Decode to Decoded TB

— PDSCH Decoder Algorithm to Offset Min Sum (default)

For successful PDSCH decoding (i.e. CRC pass), make sure the RNTI 
values (used for scrambling) and Transport Block Size matches between 
the transmitted signal and VSA. (Transport block size depends on MCS 
table, MCS value, TB Scaling Factor S, and xOverhead under PDSCH 
channel setting). 

30. Select the Advanced tab and select the DC Punctured check box. 

VSA2023U2 or later releases support user selectable Decoder Algorithm. 

Offset Min-Sum (Default) - Specifies the layered belief propagation 
algorithm with offset min-sum approximation. This is faster but less 
accurate than Belief Propagation.

Belief Propagation - Specifies the belief-passing or message-passing 
algorithm. This is better for accuracy but slow. Use for receiver sensitivity 
test where the SNR is very small.
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As part of conformance test, 3GPP has defined different equalizer training 
and tracking for EVM measurements. 3GPP Conformance Test is enabled 
by default where Tracking, Equalizer Training and EVM Window, and 
Symbol Timing is applied per 3GPP conformance test requirement. For 
FR1, no tracking is applied. For FR2, Phase Tracking using PTRS is applied.

5G NR counts the DC subcarrier as a valid subcarrier for rate-matching 
purposes. The network decides if the DC subcarrier is modulated or not. 
High LO feedthrough will impact demodulation and EVM performance of 
the input signal. This is OFF by default.
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31. Close the 5G NR Properties dialog to view the results.

— Trace A: Composite constellation diagram showing different 
modulation formats for the different channels/signals present in the 
transmitted signal. See Trace F (Frame Summary) for the list of 
channels and modulation formats. 

— Trace C: Summary trace showing composite error metrics.

— Trace D: Error Vector Spectrum showing EVM versus subcarrier and 
symbol.

— Trace E: Detected Allocations Time showing the detected 
allocations of all channels/signals within the measurement interval.

— Trace F: Frame Summary. EVM, per Layer EVM, Power per RE, Mod 
Format, Number of RB, RNTI, and BWP ID of the individual 
channels/signals.

One of the most powerful tools in the 89600 VSA is the coupling of 
markers across different measurements, traces, and domains. Coupled 
markers allow you to understand the identity and characteristics of a 
symbol simultaneously in time, frequency, and error.

Place a marker on Traces A, D, and E and couple the markers (Markers > 
Couple Markers), and then show the results in a markers window (Window 
> Markers).
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Right click on Trace D and select Peak. The exact symbol associated with 
this peak EVM can now be understood in terms of time domain symbol 
index, frequency domain subcarrier number, channel type, modulation 
format, IQ magnitude, and phase values. Other parameters are shown in 
the Marker window.

Change the traces so you can see the Constellation diagram, MIMO Info 
table, Frame Summary Table (or Slot Summary Table), Summary table, 3D 
Power, Decoded Info plus any additional traces.

— Trace C: MIMO Info table shows EVM, power, and time, frequency 
and phase offset for each antenna port.

MIMO Info is a type of Matrix Table that provides sortable rows by column, 
selectable column visibility, and copy/paste and export functionality to 
share rows of content or complete tables to applications like email, text 
editing or spreadsheet programs.

— Trace E: 3D trace showing resource element (RE) power per symbol 
and per subcarrier. This is very useful when verifying base station 
systems, for example, to make sure the power per each RE is 
balanced. You can use a marker to read the power and channel 
information. A marker on this trace cannot be coupled with other 
traces. 

— Press the mouse wheel and rotate the wheel forward to 
zoom in, backward to zoom out.

— Hold left-click of the mouse for panning. Note: If marker is 
enabled (i.e. not a normal pointer), you will need to hold 
Alt in order to pan.
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— Use right click to auto scale, enable the marker, and 
change the display to different axes.

— Trace F: The Decoded Info table provides CRC pass/fail for PDSCH 
and PBCH plus the high layer information that is carried on PBCH.

If CRC of PDSCH fails, make sure the Transport Block Size matches 
between the transmitted signal and VSA (this depends on MCS 
table, MCS value, TB Scaling Factor S, and xOverhead under PDSCH 
channel setting). Also, make sure the RNTI values match since RNTI 
is used for scrambling.

Working with Traces

— Trace A: Composite constellation diagram showing different modulation 
formats for the different channels/signals present in the transmitted signal. 
See Trace F (Frame Summary) for the list of channels and modulation 
formats. 

— Trace C: Summary trace showing composite error metrics.

— Trace D: Error Vector Spectrum showing EVM versus subcarrier and 
symbol.

— Trace E: Detected Allocations Time showing the detected allocations of all 
channels/signals within the measurement interval.

— Trace F: Frame Summary. EVM, per Layer EVM, Power per RE, Mod Format, 
Number of RB, RNTI, and BWP ID of the individual channels/signals.

One of the most powerful tools in the 89600 VSA is the coupling of markers 
across different measurements, traces, and domains. Coupled markers allow 
you to understand the identity and characteristics of a symbol simultaneously 
in time, frequency, and error.

Place a marker on Traces A, D, and E and couple the markers (Markers > 
Couple Markers), and then show the results in a markers window (Window > 
Markers).

Right click on Trace D and select Peak. The exact symbol associated with this 
peak EVM can now be understood in terms of time domain symbol index, 
frequency domain subcarrier number, channel type, modulation format, IQ 
magnitude, and phase values. Other parameters are shown in the Marker 
window.
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Change the traces so you can see the Constellation diagram, MIMO Info table, 
Frame Summary Table (or Slot Summary Table), Summary table, 3D Power, 
Decoded Info plus any additional traces.

— Trace C: MIMO Info table shows EVM, power, and time, frequency and 
phase offset for each antenna port.

MIMO Info is a type of Matrix Table that provides sortable rows by column, 
selectable column visibility, and copy/paste and export functionality to 
share rows of content or complete tables to applications like email, text 
editing or spreadsheet programs.

— Trace E: 3D trace showing resource element (RE) power per symbol and per 
subcarrier. This is very useful when verifying base station systems, for 
example, to make sure the power per each RE is balanced. You can use a 
marker to read the power and channel information. A marker on this trace 
cannot be coupled with other traces. 

— Press the mouse wheel and rotate the wheel forward to zoom in, 
backward to zoom out.

— Hold left-click of the mouse for panning. Note: If marker is enabled 
(i.e. not a normal pointer), you will need to hold Alt in order to pan.

— Use right click to auto scale, enable the marker, and change the 
display to different axes.

— Trace F: The Decoded Info table provides CRC pass/fail for PDSCH and 
PBCH plus the high layer information that is carried on PBCH.
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If CRC of PDSCH fails, make sure the Transport Block Size matches 
between the transmitted signal and VSA (this depends on MCS table, MCS 
value, TB Scaling Factor S, and xOverhead under PDSCH channel setting). 
Also, make sure the RNTI values match since RNTI is used for scrambling.

Result and Display Filtering

Meas Setup > NR Demod Properties > Configuration tab > Results & Filters 
panel.

You can try to change colors of some of the channels, and/or filtering out all 
channels/signals except for SSBlock (PSS, SSS & PBCH) etc.

Clear (Uncheck)  "Inactive" and "DC" to remove the inactive resources 
(subcarriers, symbols) and the DC subcarrier from the display and see the 
change in the 3D plot:
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You can now auto-scale the 3D plot and only see the active channels/signals 
being displayed. 

Per-Trace Filtering

Trace > Digital Demod

In addition to the Results & Filters, VSA also has per-trace filtering to filter by 
subsegments and/or channels. Subsegment means MIMO Layers, BWP and 
SSBlock.

The following traces can be filtered by subsegments:

— OFDM Meas

— OFDM Ref

— Error Vector Spectrum

— Error Vector Time

— Detected Allocations Time trace
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHz

RF1:POWer:AMPLitude 0dBm

RF2:FREQuency:CW 28GHz

RF2:POWer:AMPLitude 0dBm

CONFigure TX2

SIGNal:MODE NR

SIGNal:NR5G:CCARrier0:TYPE DL

SIGNal:NR5G:CCARrier0:CIDentity 0MIMO

SIGNal:NR5G:CCARrier0:NUM:MODE SINGLE

SIGNal:NR5G:CCARrier0:BWID FR1BW100M

SIGNal:NR5G:CCARrier0:SNUM MU1

SIGNal:NR5G:CCARrier0:SNUM:RB:NUMB 273

SIGNal:NR5G:CCARrier0:DLINk:SSBL:PERiodicity P10MS

SIGNal:NR5G:CCARrier0:DLINk:SSBL:RB:OFFSet 0

SIGNal:NR5G:CCARrier0:DLINk:SCH0:DMRS:PORT '0,1'

SIGNal:NR5G:CCARrier0:DLINk:SCH0:SLOT "2:19"

SIGNal:NR5G:CCARrier0:DLINk:SCH0:RB:OFFSet 2

SIGNal:NR5G:CCARrier0:DLINk:SCH0:RB:NUMBer 80

SIGNal:NR5G:CCARrier0:DLINk:SCH0:MCS:TABL TABL52

SIGNal:NR5G:CCARrier0:DLINk:SCH0:MCS 20

SIGNal:NR5G:CCARrier0:DLINk:SCH0:DMRS:POWer 3

SIGNal:NR5G:CCARrier0:DLINk:SCH0:ADD

SIGNal:NR5G:CCARrier0:DLINk:SCH1:DMRS:PORT '0,1'

SIGNal:NR5G:CCARrier0:DLINk:SCH1:DMRS:CGWD:COUN 2

SIGNal:NR5G:CCARrier0:DLINk:SCH1:SLOT "2:19"

SIGNal:NR5G:CCARrier0:DLINk:SCH1:RB:OFFSet 150

SIGNal:NR5G:CCARrier0:DLINk:SCH1:RB:NUMBer 100

SIGNal:NR5G:CCARrier0:DLINk:SCH1:MCS:TABL TABL51

SIGNal:NR5G:CCARrier0:DLINk:SCH1:MCS 20
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SIGNal:NR5G:WAVeform:GENerate

SIGNal ON

SIGNal:NR5G:TRIGger:SYNC:MARKer M2

RF1:OUTPut ON

RF2:OUTPut ON

RFAL1:OUTPut ON

On the Analyzer:

INSTrument:SELect VSA89601

SYSTem:PRESet

FREQuency:CENTer 28 GHz

FREQuency:SPAN 122.88 MHz

INPut:ANALog:RANGe:AUTO

INITiate:PAUSe

INP:CHAN:CONF RF,RF

MEASure:CONFigure NR5G

NR5G:DBWP:ENABled 1

NR5G:SSBLock:ENABled 1

NR5G:SSBLock:ROFFset 0

NR5G:SSBLock:PERiodicity "Period10Milliseconds"

NR5G:DBWP:PDSCh1:MCS:TABLe "Table2"

NR5G:DBWP:PDSCh1:MCS 20

NR5G:DBWP:PDSCh1:SLOT:ALLocated "2:19"

NR5G:CCARrier:PDSCh1:ROFFset 40

NR5G:CCARrier:PDSCh1:RNUMber 80

NR5G:CCARrier:PDSCh1:ANTenna:PORT:USED 3

NR5G:CCARrier:PDSCh1:RCGNumber "Two"

NR5G:DBWP:PDSCh1:BPOWer:DMRS 3

NR5G:DBWP:PDSCh2:MCS:TABLe "Table1"

NR5G:DBWP:PDSCh2:MCS 20

NR5G:DBWP:PDSCh2:SLOT:ALLocated "2:19"

NR5G:CCARrier:PDSCh2:ROFFset 150
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NR5G:CCARrier:PDSCh2:RNUMber 100

NR5G:CCARrier:PDSCh2:ANTenna:PORT:USED 3

NR5G:CCARrier:PDSCh2:RCGNumber "Two"

NR5G:DBWP:PDSCh2:BPOWer:DMRS 2

NR5G:RLENgth 10 

NR5G:SUBFrame:INTerval 2

NR5G:FRAMe:TRIGger:ENABled 1

NR5G:DC:PUNCtured 1

NR5G:MCFilter:ENABled 1

NR5G:COMPensate:SYMBol:CLOCk:OFFset 1

INPut:TRIGger:STYLe "External"

INPut:TRIGger:LEVel:EXTernal 1V

INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2

INPut:EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1

NR5G:FRAMe:TRIGger:ENABled 1

NR5G:DECode:MODE "DecodedTB"

DISPlay:LAYout 3,2 
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